Solved

IE 7 not saving setting for activex and plug-ins

Posted on 2009-07-14
16
211 Views
Last Modified: 2013-12-08
I have XP Pro, administrator rights, IE7 with all critical patches.  When I get into IE, I receive the message "Do I want to allow activex control and plug-ins to run"  Current setting is Mediium-High and I have tried altering it to Medium and tried just enabling that through Security Internet Customer setting.  I click OK or Apply (does not matter) and it works fine until I stop and restart IE, then it all goes right back to Meidum-High with the default settings.  How can I make it save the setting for good and stop defaulting.  It there something in the registry maybe I can tweak??
0
Comment
Question by:LMeyers08
  • 9
  • 7
16 Comments
 

Author Comment

by:LMeyers08
Comment Utility
One last point.  I also tried uninstalling and reinstalling IE7 with no luck on stopping the message
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
LMeyers08--For just stopping the message:
Internet Explorer select Tools|Internet Options| Security |Internet zone|Custom Level
For "Run ActiveX controls and plug-ins" select Enable.  Then click APPLY/OK.
Concerning the inability to make changes in the Security tab permanent:
Some third party "Security"  Programs will not permit changes to the IE Security settings.  These include Spybot, AdAware, SpywareBlaster, MS One Care, etc.  Try uninstalling or disabling such programs one by one.
http://www.techtalkz.com/internet-explorer/53169-ie7-security-zone-settings-registry-get-reset.html
It also could be that your client does not have Administrator rights.  
0
 

Author Comment

by:LMeyers08
Comment Utility
I will try disabling TrendMicro AV then make the change and see if it saves it.  She does have Admin rights but I have used TrendMicro for years and have never seen this symptom.  I will send an update tonight after I make the change.  Thanks for the input.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
LMeyers08--Did you see the list of programs in Frank Saunders' reply which could be causing the reset?  http://www.techtalkz.com/internet-explorer/53169-ie7-security-zone-settings-registry-get-reset.html
0
 

Author Comment

by:LMeyers08
Comment Utility
I started the computer in safe mode and tried it.  Still getting the pop ups and internet security is still set to medium-high.  I looked at the list of programs and I have none of those on the computer.  I can set it back to medium and it will stay there until I recycle IE, then it goes right back to Medium-high.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
LMeyers08--Try running IE without add-ons.  Start|All Programs|Accessories|Ayatem Tools|Internet Explorer (no add-ons).  Do you get the message?  Make the changes in Security.  When you next recycle IE, open it the same way--without add-ons.  See what happens.  If that helps you want to get rid of one or more add-ons.  We can discuss that later if you want.
0
 

Author Comment

by:LMeyers08
Comment Utility
OK, tried it without the add-ons.  Worked a couple times but now pop-ups are happening again.
0
 

Author Comment

by:LMeyers08
Comment Utility
is there a registry hack I can make that would force it to stay with RUN ACTIVEX CONTROLS AND PLUG-INS ENABLED?
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
LMeyers08--Here is where the Security Zone settings reside in Registry.
http://support.microsoft.com/default.aspx?scid=kb;en-us;182569
By all means try to make them stick.  Let us know if they do.
If that does not help--
"Worked a couple times but now pop-ups are happening again"
If you mean that it worked as long as you opened IE with no add-ons, but then went back to the problem when you opened IE the normal way, then you should determine what add-on is causing the problem.  IE Tools|Manage Add-ons|Enable or Disable Add-ons.  There are four windows of add-ons that can be accessed from the dropdown arrow.  You can disable all and see what happens, then reenable the add-ons one by one.  Or some disable half and see what happens.  Theoretically that would be faster.
0
 

Author Comment

by:LMeyers08
Comment Utility
What I meant is that for a few times with no add-ons I got no pop-ups.  I would say 3-4 times of open/closing with no add-ons, then still using the no add-ons, pop-ups started happening again.  I will try the registry modification and let you know.  Thank you for the help so far.
0
 

Author Comment

by:LMeyers08
Comment Utility
OK, I have tried the registry change and it works until I reboot the computer.  I even tried disbabling WRITE DAC to that key #3, no difference.  Something is changing it back on reboot but I have no idea what it could be.  I do not have any of the software on the PC that was reported earlier.
0
 

Author Comment

by:LMeyers08
Comment Utility
let me try making the change then booting back up in SAFE MODE with networking and see then if it changes.  I already tried booting into SAFE MODE then making the change but when I rebooted back normal, the change happened.  I will update tonight.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
LMeyers08--Perhaps I should wait until you report back, but if things still do not work
1)  You can get rid of all add-ons (and other customizations to IE) by IE Tools|Internet Options|Advanced|
Reset button.  With time you will get add-ons back as needed but you should be aware of the other consequences of using Reset.  http://support.microsoft.com/kb/936213/  From what you report, one or more add-ons seem to be involved in the problem.
2)  You can determine what programs are running on the PC, especially any that are connected to IE by using Process Explorer.  http://www.microsoft.com/technet/sysinternals/utilities/processexplorer.mspx
0
 
LVL 50

Accepted Solution

by:
jcimarron earned 500 total points
Comment Utility
LMeyers08--Perhaps far out, but easy to try with no risk.  Windows can remember only so many settings.  Perhaps you have exceeded that number.  You can increase it (at the expense of a little hard drive space).
The simplest way is to use TweakUI for XP. http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
See here for how to use TweakUI for this purpose.   http://malektips.com/xpwtw0009.html  Enter a number between 2000 and 5000.
You can get all the details here http://support.microsoft.com/kb/813711  see the "Let me fix it myself" section.
0
 

Author Comment

by:LMeyers08
Comment Utility
OK, I tried the resetting of IE with no luck.  It maintains the settings I set when I am in it but whenever I reboot the PC, it changes back to MEDIUM-HIGH with ACTIVE CONTROLS and PLUGINs PROMPT.  I will try the last entry about the settings tweak.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
LMeyers08--Glad to hear the good news!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

How many times have you been browsing the internet, with multiple tabs open, and closed the wrong one? Have you ever clicked 'Close all tabs' instead of 'Close current tab' ? Internet Explorer 8 now brings to you, what Firefox has had for a wh…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now