Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

HTTP/1.1 503 Service Unavailable' error- MS Steps

Posted on 2009-07-14
39
Medium Priority
?
1,992 Views
Last Modified: 2012-05-07

I am trying to work to make the OWA, but that is stubbornly not co-operating. It is giving the 'HTTP/1.1 503 Service Unavailable' error.

I was going through
http://support.microsoft.com/kb/840182
But I got lost in these points:
1)On Point 11 for msExchOwningPFTreeBL, what should I do with the console that was created in Step 1-2? Should it saved? closed?

2)can you please guide me where I can find the "Public Folders" directory for my server.

Thanks
0
Comment
Question by:anushahanna
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 22
  • 14
  • +2
39 Comments
 
LVL 23

Expert Comment

by:rhandels
ID: 24854360
Hey.

Yopu can simply safe the console if you please. The only thing you've done is manually created a new MMC. When opening the AD USers and Computers you are also openeing an MMC, but this is allready inthere..

Public folders should be in your Exchange server Management. You shoudl go to your server (if you have admin groups go to the admin group your server is located) go to the optionm folders and then go to Public Folders there.

The public folders are not folders located on your machine. Those are 2 files somewhere on your computer (you gave up a location when installing Exchange) and Exchange is capable or reading out those 2 files and make it into a public folder tree, something like SQL does to.
0
 
LVL 12

Expert Comment

by:Saakar
ID: 24855012
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24855143
For some reason RWW quit working also...i've been trying to fix it and OWA ....any help is highly appreciated....
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 23

Expert Comment

by:rhandels
ID: 24856792
Do you see any errors in the event viewer?? Because the info at this point is not really that much..
You could try and reinstall OWA, but still, i'm not sure if your RWW will work then..

Btw, it looks like you have some ISS issues... Try checking that to..
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24865197
rhandels,
When I tried to access 'Public Folder' according to your instruction, it gives the following error..

The HTTP Service used by Public Folders is not available, possible causes are that Public Stores are not mounted and the Information Store Service is not running.

Does it tell much?
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24866770
Euhm yeah, it tells you that your public folder store in Exchange isn't mounted. I don;t think the information store isn't running, if that was the case, you weren't able to use any kind of mailbox.

I have to do this without the manager in front of me, so bear with me :) You should go into the Exchange System Manager and then go to your servername.  Then you should to the your First mailstore.. Normally you should see 2 stores there, your first mailbox store and your public folder store.. Most propably it will be unmounted. Try to mount it by pressing with the right mouse and select mount..

If an error accours, please post it here..
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 24887415
Try removing and reinstalling the Exchange Virtual Directories using this Microsoft document:
http://support.microsoft.com/default.aspx?kbid=883380 
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24930067
RWW has working fine now.

In the document
http://support.microsoft.com/default.aspx?kbid=883380 
I tried option 3 (editing the XML file), but that did not fix it.
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24930069
rhandels
Both the stores were already mounted.
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24930102
rhandels
I should have said 'Both the stores are now mounted" But OWA still does not work. Still get the error , when I got to 'Remote Web Workplace' and click on 'Read my company e-mail'. It says 'HTTP/1.1 503 Service Unavailable'.

You had mentioned "reinstall OWA". How exactly do you do that?

thanks for your help.
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24932859
Here's how you reinstall the OWA virtual deirectories, this should do the trick..

http://support.microsoft.com/?id=883380
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24933807
rhandels,
is it enough to do one step or all three?

I already did the step3: Edit the Metabase.xml file last week, but that did not help?
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24934410
I reset my own OWA with step 1.. It's not only editing the metabase XML file, it's also deleting the Exchange Virtual directoris using your IIS admin tool and reïnstalling the virtual directories using the Exchange installation.
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24935019
rhandels,
Yes, I am trying Step 1 now.

I have come to step 9 and it says
"In this scenario, your Exchange Server users lose connectivity to their Exchange Server mailboxes.".

Will this be momentary? Today user have a busy day, and if emails stop comming, they are going to be affected a lot. If the virtual directories are not re-created, does it affect the emails that are got through outlook from the exchange server?

thanks
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24935526
Yes it will be, but the system attendent is th most important service of Exchange. If you stop this, all other Exchange services will stop working.. Normally, if you don't have any issues with your Exchange services it will take about 1 to 2 minutes..

0
 
LVL 6

Author Comment

by:anushahanna
ID: 24935569
rhandels,
I am asking just as a precaution:
if there are any issues with the Exchange services, in the worst case scenario, will a reboot of the server fix the emails to the outlook? (if that should disrupted for any reason).

thanks
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24935652
You are only restarting the services to make sure the folders will be recreated.. If you have any issues with your Exchange server it will come out eventually anyway.. I would only advice you to restart these services after working hours, not because i think you will have issues but only to make sure that if you get some worst case scenarios (which i doubt you'd get, cause else you'd have more issues allready) you don;t have your boss on your ass looking for a rope :) :) (or is your boss that kind?? ;))
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24935726
the boss is cool! but the users are not!! :-(

will let you know what comes out of it.!
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24936041
rhandels,
you are right, it took 2 minutes, but phew.. it came back again..
time is against me, so I had to take the risk..

Well, I went through point 9 & 10, and all the virtual directories I have deleted are all back. But still when i go to check OWA, I get this message
"HTTP/1.1 503 Service Unavailable".

Which security group do I need to check for the users who have access to OWA.

I also ran the configure email and internet connection wizard. No Use.

When I go to servername.com/exchange, it tells me about the certificate, i say ok, then I put th e Username and password, and then it give the final error "HTTP/1.1 503 Service Unavailable".

There are a lot of folders created under 'ExchWeb', but nothing under 'Exchange' in IIS Manager->Websites. Is that expected?

Thanks a lot for your help.
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24936127
it should have the anonymous access allowed for the default website.. The other security settings are set when you recreate the folders on the server.. So no security group onthere..

Also, what URL are you typing when you try to connect to the website?? Are you using http://servername/exchange?? Could you also try http://servername/oma?? What happens then?

Also, the actual site that is being used is ExchWeb, not the Exchange folder... So yes, this is as expected..
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24936367
I tried the http://servername/oma; it says the same about the certificate like for OWA, and then I enter the user credentials, and the error I get is "  Unable to connect to your mailbox on server SERVER. Please try again later. If the problem persists contact your administrator."

For OWA, I do use http://servername/exchange

Glad ExchWeb is what should be populated, and I am glad it is.

The Enable anonymous access check box is turned on, indeed. Actually, it was turned on when I first went in there. I left it that way. The Integrated Windows authentication check box was first turned on, and then turned off.

Under Enable anonymous access check box(which is clicked on), it say the Windows user is "IUSR_SERVER" and a password that is hidden. In Authenticated access, all four options are checked off.

But I know there is no windows user called 'IUSR_SERVER', but perhaps this is how windows sees anonymous connections?

Thanks much!
http://servername by itself works, and Remote Web Workplace also works fine.
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24936392
rhandels
Are all exchange users by default entitled for OWA, also? If that true, then all the users who have an outlook access on their computer from the SBS Exchange 2003, will have access to OWA online, without me having to put any extra setting for "OWA User directory & Permission list" of some sort?

thanks
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24937071
Yes, all domain users will have permissions for OWA. You can check in AD USers & Computers and there should be 1 Exchange tab that allows webmail. You should have an IUSR_Servername user account, this is the user that enumerates anonymous access to the website if it is turned on. So if you don;t have that user i'm afraid it has been deleted and you need to recreate it. Reinstalling IIS should do that trick, recreating the user and trying to set permissions is undoable, that account has way to much permissions..

The password for this account is set automatically. But if you are 100% sure the local databse of the server doesnt; have that account i think that;s were your issue is..
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24937798
In AD USers & Computers, where would the exchange tab be? I looked under Security Groups, and I see the Remote Web Workplace Users, but none for Exchange. For Remote Web Workplace Users, the Group scope is universal, Group type is security. It has members tab with members information, and the 'Members of' tab is blank.

please see all the list I have under Security Groups.
Thanks
SecurityGroups.bmp
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24939616
No, not a group.. If you look at the properties of a user it shuld have 4 Exchange tabs, Exchange general, Exchange Advanced, Exchange E-mail addresses and one more, not quite sure about that tabs name.. This is to check if a single specific user has these permissions..
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24939886
I see 2 Admin Users in Server->Users
IUSR_SERVER
IWAM_SERVER
WHen I right click, there is an option to disable it. So Persume that it is enabled.

But, Under Server->My Business->Computers->SBS Users, it does not have IUSR_SERVER. Is that ok.

Under  Exchange Features, I do see the users are enabled for OWA.

What else to check?

Thanks for your help

0
 
LVL 23

Expert Comment

by:rhandels
ID: 24941100
Hey,

Nothing else to check imho, did you do the entire steps pointed out in the article of Microsoft?? And yes, as long as these accounts exist your good to go with them.

Else, it might be something dead obvious which i'm not seeing but i'm out off ideas here...
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24941874
I did not try step 2. Step 1 alone worked for you. I have tried Step 1 & 3. Should I try Step 2 also?

2 hijack files were found in the server: Could this have any issue?

HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Control Panel\Homepage (Hijack.Homepage) -> Bad: (1) Good: (0)

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop\NoChangingWallpaper (Hijack.DisplayProperties) -> Bad: (1) Good: (0)
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24941990
No not really, that only means that your homepage has been set. This can also be done by a policy when in a domain.. If the default website you have is not what you expect it to be then yes it could be an issue... The second one only point out you cannot change your wallpaper..

You could give option 2 a try but imho it's the exact same thign as as doing 1 and 3, just using another method..
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24942041
so you won't worry about the 2 hijack files?

How can i set the right default website? (company web)
http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_24599617.html
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24942100
Nope i won't really.. :)

But it's still not working i guess??
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24942135
OWA still giving 503 error.
0
 
LVL 23

Expert Comment

by:rhandels
ID: 24942263
Can you try the following link??

http://support.microsoft.com/kb/823159
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24942312
rhandels
thanks. i strongly felt that this link would be it. I have been trying all the steps in it since yesterday, but still no resolution..

0
 
LVL 6

Author Comment

by:anushahanna
ID: 24942536
rhandels,
Can you please help me confirm my settings, and my concern about local path settings in IIS Manager?
kindly see
http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_24599617.html#a24942526
0
 
LVL 6

Author Comment

by:anushahanna
ID: 24944099
rhandels,
I ran the SBS Best Practice analysis tool: It has three issues with my server:
"DNS Client was not configured"
"Task Offloading is enabled"
"Sharepoint 2.0 RTM installed"

Do you see any trouble, related to OWA? I am also attaching the whole report, for the complete big picture.

Also there are 2 application log error events when I restarted the server:
MSExchangeDSAccess;Category:Topology;Event 2114; User N/A; Computer :Server
MSExchangeIS; Category:General;Event 9542; User N/A; Computer :Server
Would appreciate any feedback if this could be causing any trouble to the OWA.

Thanks
Critical-All-Issues.jpg
Info-Items.jpg
0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 2000 total points
ID: 24993946
Sounds to me like an OLE DB problem, check this link out: http://support.microsoft.com/kb/305030

if you fun through this and it's still not working check for the event viewer items it refers to when looking at registry keys over 259 characters long.

If nit resolved I would phone PSS support at MS and they will run a scanner on your registry and have this sorted in a jiffy!
0
 
LVL 6

Author Comment

by:anushahanna
ID: 25012623
Thanks.

Calendar items were present in event logs, called MS and they resolved by deleting registry Sub-key N34d90ae5 and everything now works.

Below is the resolution from Microsoft:
"the Sub key: N34d90ae5 was causing the 503 Service Unavailable issue since it has exceeded the Default 259 characters. This problem can occur if the Exoledb library does not initialize. When the Exoledb library initializes, it scans the HKEY_CLASSES_ROOT (HKCR) registry hive for content class information. If the Exoledb library finds a ProgID with a value that exceeds 259 characters, the Exoledb library cannot initialize."
0
 
LVL 6

Author Closing Comment

by:anushahanna
ID: 31603497
Bye's eye solution! Thanks much.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On September 18, Experts Exchange launched the first installment of the Help Bell, a new feature for Premium Members, Team Accounts, and Qualified Experts. The Help Bell will serve as an additional tool to help teams increase question visibility.
The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question