Wild Card Certificate and Outlook 2007

I am running windows 2008 small business server.  We have implemented outlook anywhere with exchange 2007.  Most of the clients are running Outlook 2007.  SBS comes preconfigured with everything using Remote.domain.com  and it was recommended to use a wild card ssl for different sub domains if necessary.

The issue i am running into is with Outlook Anywhere on the Outlook 2007 client machines.  In the account setup on the client machine,  In the exchange proxy settings, I have the setting use SSL checked, as well as Only connect to  proxy servers that have this principal name in the certificate:

msstd:*.domain.com

Everything works beautifully.  But on semi-frequent occassions, the above setting is automatically changing in outlook to read:  msstd:remote.domain.com  and then it fails with the password prompt over and over again.  As soon as i change the sub domain back to the * it all works again.

Is there anyway to get Outlook 2007 to stop changing that setting?  I haven't seen it occur with any of the 2003 Outlook clients.  Its really annoying.  I have people that will work for a couple of months with no issues and then I  have certain people that the setting changes every few weeks.  

Any help would be appreciated.

Thanks
jbmos2333Asked:
Who is Participating?
 
lastlostlastCommented:
run the cmd in exchange management shell

set-OutlookProvider EXPR -CertPrincipalName *.domain.com

This should help you out... let me know if you have any concerns...
0
 
MesthaCommented:
The recommendation to use a wildcard was wrong.
That cannot have been a Microsoft recommendation, as they don't say that. It sounds like yet another of the misconceptions around the SAN/UC requirement of Exchange 2007 which continues to be spread. A SAN/UC is not a wildcard certificate, and a wildcard certificate is not a suitable replacement.

The reason it is changing is because Autodiscover is correcting it. Outlook 2003 doesn't use autodiscover so cannot be corrected. SBS 2008 is built around the remote.example.com host name and most things will be set to that in the virtual directories.
I don't believe Exchange 2007 will let you set the URL for Outlook Anywhere as *.example.com, which means you cannot stop autodiscover from correcting the URL.

Your best option would be to get a SAN/UC certificate, or at least a single name certificate for remote.example.com and use that instead. If your external DNS provider supports SRV records then a single name certificate will do the job.

Simon.
0
 
jbmos2333Author Commented:
Going to give it a try.  But before I was able to, Outlook Anywhere just quit working.  Trying to get it back up.
0
 
jbmos2333Author Commented:
Exactly what i needed.  Sorry I forgot to award the points for this.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.