DHCP error on sbs 2008

This is the second time this has happened, out of the blue I get this weird event id of 1056 cenerning dchp: The DHCP service has detected that it is running on a DC and has no credentials configured for use with Dynamic DNS registrations initiated by the DHCP service.   This is not a recommended security configuration.  Credentials for Dynamic DNS registrations may be configured using the command line "netsh dhcp server set dnscredentials" or via the DHCP Administrative tool. I check the dhcp admin console, and it is running fine. According to MS i should set the credentials for dhcp server service. I went to the dhcp console, and right click my server, clicked propertied, but there is no credentials tab. Once I click properties I automatically see advance, with two entries for database path, and backup path. What could have happened to the credentials tab? is this by design for sbs 2008?
Ever so often I get these weird network errors, then when I run the fix network wizard, nothing pans out. Someone mentioned disabling ipv6, but caused more headache than comfort, so I turned it back on.
xzay1967Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

_FredCommented:
I dont think you have an issue here. This credentials would be used if you would have DHCP server to register clients at DNS, but since 2000 clients register themselfs at dns. This only would be used if you have non windows clients or very old windows clients. Anyway if you want to configure this credentials, you must do it at the DHCP console, but at IPv4 or IPv6 level, not at server level.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
xzay1967Author Commented:
Well, this a SBS 2008 server (DC and exchange) so it does function as a dns and dchp server. But, just for knowledge, how would I set the credentials at the IPv4 and IPv6 level?
0
_FredCommented:
As you would in 2003, but instead of right clicking the server you have to expand the server and then right click IPv4 and/or IPv6. Then chose properties, go to the advanced tab, click credentials and enter them.
0
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

xzay1967Author Commented:
Oh ok, now I get it, thanks.
Now another warning is appearing (well it happened before) I am getting this warning: BITS has encountered an error communicating with an Internet Gateway Device.  Please check that the device is functioning properly. BITS will not attempt to use this device until the next system reboot. Error code: 2147747073.
0
_FredCommented:
Since this is another issue, i suggest you close this post and open a another one
0
xzay1967Author Commented:
Ok I will, thanks, however, the original issue is not solved. I will start a new thread for the new error.
0
_FredCommented:
The original issue isn't solved? Can you update us on what you've done and on whats happening?
0
xzay1967Author Commented:
Well, it kind of worked (solved) itself. The funny thing is, it comes and goes; this is not the first time is has happened. The first time it happened, I ran the fix my network wizard, and it fixed it. This time the wizard did not find anything. So, what do I do, ignore it, and wait till it happenes again?
0
_FredCommented:
Well. as i said before i dont think this is an issue. I have several sbs and all of them have this warning, wich happens when the server checks its dhcp settings. If you dont have any non windows machines or very old windows machines you can ignore this. If you dont want to ignore, then preoceed as inicated before and enter the credentials.
0
xzay1967Author Commented:
Ok then, I will do as you advised and ignore it. Hope not out of line here, but can I pay you to have a look at my server?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.