Solved

How to hide the account from Windows Server 2008 Welcome screen

Posted on 2009-07-14
5
947 Views
Last Modified: 2012-06-27
Hi,

How can I hide/disable showing of the user accounts on server 2008 welcome screen?  Can't believe microsoft doesn't see this as a security risk, although it is small one but still, knowing the username is solved, now to the password, lol.

Anyways, I have googled and tried the SpecialAccounts->UserList registry edit and that doesn't seem to be working.

I hope it is super simple to fix and I am just not looking in the right place.

Thanks!
0
Comment
Question by:mwajdan
5 Comments
 
LVL 6

Expert Comment

by:ahmad2121
ID: 24855550
try

gpedit.msc > Window Settings > Security Settings > Local Policies > Security Options > Interactive Logon: Do not display last user

and

gpedit.msc > Admin Templates > System > Logon > Always Use Classic Logon

honestly, I can't say if they will do anything, but I think those are your only options. You could also set the "interactive logons: dc logons to cache" setting to 0.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 24855580
I would try, in your group policy.....Computer Settings > Admin Templates > System > Logon > Hide Entry Points for Fast User Switching....
0
 

Author Comment

by:mwajdan
ID: 24856026
Ahmad, Jay,

Tried all the suggested changes and it is still not working.  Also tried the following:

http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/0f2fc7f0-ff2d-4bc8-9f53-68f1180baff2

I must be doing something wrong.
FYI:  This is a stand alone server and not part of ANY domain.  I am connecting to the computer via RDP NOT connecting directly.
0
 
LVL 6

Accepted Solution

by:
rpassero earned 500 total points
ID: 24856946
The username you see is sent by your client as part of NLA (network level authentication). I don't know of a way to turn this behavior off other than to set RDP to allow insecure (non-NLA) connections and connect from a Windows XP workstation that doesn't have the updated client... the username you see is either being specified in your RDP profile, or is just NLA passing your local credentials.

See http://windowshelp.microsoft.com/Windows/en-us/help/ea4680d1-6962-463b-b29b-351efa676f9e1033.mspx for more on NLA and how to see if your RDP client is using it...
0
 

Author Closing Comment

by:mwajdan
ID: 31603549
Thanks, that was it.  Since I am causing the name to be populated it is really a non-issue now that I know that.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you migrate a Terminal Server licenses server inside the 2008 server family, you can takte advantage of the build-in migration tool. If you like to migrate an older 2003 Server (and the installed client CALs) to a 2008 R2 server for example, you …
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now