Solved

ATT rejecting email from exchange 2007

Posted on 2009-07-14
12
4,461 Views
Last Modified: 2012-05-07
This is the first time we have setup a Microsoft SBS 2008 with Exchange 2007.  We have the box working fine as the domain controller and have been sending and receiving emails just fine, until someone tried sending to ATT.  We were rejected due to the following:

The following organization rejected your message: nlpi078.prodigy.net.

  _____  

Sent by Microsoft Exchange Server 2007


Diagnostic information for administrators:

Generating server: blackpearl.localdomain.local

user@sbcglobal.net
nlpi078.prodigy.net #553 5.3.0 nlpi078 - n6F1QFv3010006, DNSBL:ATTRBL 521< 216.xxx.xxx.xxx >_is_blocked.__For_information_see_http://att.net/blocks ##

Original message headers:

Received: from blackpearl.localdomain.local ([fe80::41e7:b3f4:89a2:90b1]) by
 blackpearl.localdomain.local ([fe80::41e7:b3f4:89a2:90b1%10]) with mapi;
 Tue, 14 Jul 2009 20:26:13 -0500
From: bangroot <bangroot@internetdomain.net>
To: User <user@sbcglobal.net>
Date: Tue, 14 Jul 2009 20:26:11 -0500
Subject: Testing
Thread-Topic: Testing
Thread-Index: AcoE6zyvL729rT0nS42cG7mB3OaikA==
Message-ID: <F642A97CF295C4459830A9A89F974E4702BC6333FE@blackpearl.localdomain.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
acceptlanguage: en-US
Content-Type: multipart/related;
      boundary="_004_F642A97CF295C4459830A9A89F974E4702BC6333FEblackpear_";
      type="multipart/alternative"
MIME-Version: 1.0

_________________

Now I have checked the blacklist for my IP address and all is well.  I am confident it has to do with my exchange server broadcasting the internal domain name rather than the external domain.  I have gone into the exchange server and set the default exchange domain to be the external domain.  I have gone into the Send Connector and made sure the FQDN matched my reverse DNS on the public IP.

I am doing remote DNS for the Internet domain, and pointed the MX record to the public IP address of the Exchange server.   I can't seem to get the exchange server to change the sending domain name from blackpearl.localdomain.locl to blackpearl.internetdomain.net.

Help!
0
Comment
Question by:bangroot
  • 5
  • 4
  • 3
12 Comments
 
LVL 23

Expert Comment

by:debuggerau
Comment Utility
you'll need to restart the services for the change to take effect..
0
 

Author Comment

by:bangroot
Comment Utility
debuggerau,

I was making a change to the server and decided to reboot it.  I am still getting the name of blackpearl.internaldomain.local as the sending server.  I have appended a header from an email after the reboot.

Just to clarify:

I went into exchange management console and changed the following:

accepted domains: the default is now set to externaldomain.net
send connectors: FQDN is mail.externaldomain.net

After reboot, still sending mail as blackpearl.internaldomain.local

Delivery-date: Tue, 14 Jul 2009 22:16:02 -0500
Received: from mail.externaldomain.net ([216.xxx.xxx.xxx]:13246)
    by cheetah.websitewelcome.com with esmtps (TLSv1:AES128-SHA:128)
    (Exim 4.69)
    (envelope-from <bangroot@externaldomain.net>)
    id 1MQuyQ-0003Bz-JA
    for shawnring@pearl-network.com; Tue, 14 Jul 2009 22:16:02 -0500
Received: from blackpearl.internaldomain.local ([fe80::41e7:b3f4:89a2:90b1]) by
blackpearl.internaldomain.local ([fe80::41e7:b3f4:89a2:90b1%10]) with mapi;
Tue, 14 Jul 2009 22:16:04 -0500
From: bangroot <bangroot@externaldomain.net>
To: "shawnring@pearl-network.com" <shawnring@pearl-network.com>
Date: Tue, 14 Jul 2009 22:16:01 -0500
Subject: test
Thread-Topic: test
Thread-Index: AcoE+pTPt5jSar4uSbSNA/mFNPkn/A==
Message-ID: <F642A97CF295C4459830A9A89F974E4702C08DBE66@blackpearl.internaldomain.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
acceptlanguage: en-US
Content-Type: multipart/related;
    boundary="_004_F642A97CF295C4459830A9A89F974E4702C08DBE66blackpearl.int_";
    type="multipart/alternative"
MIME-Version: 1.0
0
 
LVL 23

Expert Comment

by:debuggerau
Comment Utility
Is that the FQDN under the General Tab or in the smarthost?

When you say "remote DNS", do you mean DDNS or reverse DNS lookups?

If you can connect externally to your server with the telnet test, it should reply with that same setting in the header..

telnet mail.domain.com 25
0
 
LVL 11

Accepted Solution

by:
tmeunier earned 500 total points
Comment Utility
Actually, looking at your snippet, I am seeing that your change has taken effect.  The only thing ATT (or any other host) will be concerned with is the previous hop, and that is showing
Received: from mail.externaldomain.net ([216.xxx.xxx.xxx]:13246)

The rest is all internal exchange-to-exchange comms.  I wish you hadn't munged up the IP address and actual host name; I'd be happy to verify that these are properly configured.  If you like, send me an email to tmeunier at gmail and I'll verify the headers and reply with them munged up again.  

Delivery-date: Tue, 14 Jul 2009 22:16:02 -0500
Received: from mail.externaldomain.net ([216.xxx.xxx.xxx]:13246)
    by cheetah.websitewelcome.com with esmtps (TLSv1:AES128-SHA:128)
    (Exim 4.69)
    (envelope-from <bangroot@externaldomain.net>)
    id 1MQuyQ-0003Bz-JA
    for shawnring@pearl-network.com; Tue, 14 Jul 2009 22:16:02 -0500
Received: from blackpearl.internaldomain.local ([fe80::41e7:b3f4:89a2:90b1]) by
0
 
LVL 23

Expert Comment

by:debuggerau
Comment Utility
Unfortunately, it is against site rules to contact outside the site.

Not sure about your colloquialism (munged), but if things are working well, that's well done.

Not about checking the settings, if your FQDN is not in the general tab for the internet SMTP interface, you'll have problems with some hosts. Where as a smarthost is only if your ISP supports it, and that is what you want.

If you have any doubts with your settings, I'd be happy to clarify them here.

And any tests would be done by you anyway, so particulars wont have to be given out publicly.





0
 
LVL 23

Expert Comment

by:debuggerau
Comment Utility
oops, your not the asker, sorry, my mistake..
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Author Comment

by:bangroot
Comment Utility
Ok,

Here is the actual header.  

Return-path: <sring@gopearl.net>
Envelope-to: shawnring@pearl-network.com
Delivery-date: Wed, 15 Jul 2009 07:27:37 -0500
Received: from mail.gopearl.net ([216.59.200.200]:26112)
    by cheetah.websitewelcome.com with esmtps (TLSv1:AES128-SHA:128)
    (Exim 4.69)
    (envelope-from <sring@gopearl.net>)
    id 1MR3aD-0006kL-I3
    for shawnring@pearl-network.com; Wed, 15 Jul 2009 07:27:37 -0500
Received: from BLACKPEARL.pearl-network.local ([fe80::41e7:b3f4:89a2:90b1]) by
BLACKPEARL.pearl-network.local ([fe80::41e7:b3f4:89a2:90b1%10]) with mapi;
Wed, 15 Jul 2009 07:27:35 -0500
From: Shawn Ring <sring@gopearl.net>
To: "shawnring@pearl-network.com" <shawnring@pearl-network.com>
Date: Wed, 15 Jul 2009 07:27:33 -0500
Subject: test
Thread-Topic: test
Thread-Index: AcoFR6D3gIVuNv4fTMuTU0w0jIEDTA==
Message-ID: <F642A97CF295C4459830A9A89F974E4702C08DBE6D@BLACKPEARL.pearl-network.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
acceptlanguage: en-US
Content-Type: multipart/related;
    boundary="_004_F642A97CF295C4459830A9A89F974E4702C08DBE6DBLACKPEARLpea_";
    type="multipart/alternative"
MIME-Version: 1.0

-----------------------------------------

I do see the change of Received: from mail.gopearl.net ([216.59.200.200]:26112)

I see that later in the header though it is reading blackpearl.pearl-network.local as the from.  Hope that helps you all clarify what / where the problem lies.  Look forward to hearing back.
0
 
LVL 11

Assisted Solution

by:tmeunier
tmeunier earned 500 total points
Comment Utility
Correct. This is fine, now, and you should not worry about the internal hops.  There are two problems now that I see:
1.  There is no reverse DNS for 200.200.59.216.in-addr.arpa.  This will cause some hosts to refuse email from you.  This needs to be added at your ISP.
2.  The actual error message from AT&T isn't rejecting mail as not having proper public FQDN or DNS setup.  It's telling you it's rejected at ATT BL, a private blacklist they maintain, with the reason code 521.  If you go look that up, you'll see that this means your network address has been a source of spam in the past, according to their blacklist.  http://worldnet.att.net/general-info/block_enduser.html  and that you should click the hyperlink for more info about how to get de-listed.

-tom
0
 

Author Comment

by:bangroot
Comment Utility
Ok,

I will institute reverse DNS.

About the blacklist.  I will have them remove it.  I had written them before with no answer, so I assumed it was because of my exchange settings.

I will make the changes and try it, and post the outcome.

Thanks!
0
 
LVL 11

Expert Comment

by:tmeunier
Comment Utility
Absolutely.  They have a simple automated form at http://worldnet.att.net/general-info/block_admin.html so that you can request removal.  It appears to me that your Exchange settings are fine.
0
 

Author Comment

by:bangroot
Comment Utility
Ok, ATT said they removed it...but still seeing the following error:

Is this due to the sender being .local?

Sent by Microsoft Exchange Server 2007







Diagnostic information for administrators:

Generating server: BLACKPEARL.pearl-network.local

gill@sbcglobal.net
flpi184.prodigy.net #553 5.3.0 flpi184 - n6G1lPuA026379, DNSBL:ATTRBL 521< 216.59.200.200 >_is_blocked.__For_information_see_http://att.net/blocks ##

Original message headers:

Received: from BLACKPEARL.pearl-network.local ([fe80::41e7:b3f4:89a2:90b1]) by
 BLACKPEARL.pearl-network.local ([fe80::41e7:b3f4:89a2:90b1%10]) with mapi;
 Wed, 15 Jul 2009 20:47:24 -0500
From: Shawn Ring <sring@gopearl.net>
To: Debora Gill <gill@sbcglobal.net>
Date: Wed, 15 Jul 2009 20:47:21 -0500
Subject: testing
Thread-Topic: testing
Thread-Index: AcoFt1wQ1FFostWCRO6kdbDEykCaNA==
Message-ID: <F642A97CF295C4459830A9A89F974E4702C08DBEE3@BLACKPEARL.pearl-network.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
acceptlanguage: en-US
Content-Type: multipart/related;
      boundary="_004_F642A97CF295C4459830A9A89F974E4702C08DBEE3BLACKPEARLpea_";
      type="multipart/alternative"
MIME-Version: 1.0
0
 
LVL 23

Expert Comment

by:debuggerau
Comment Utility
It is still appearing..

Looks like your getting blocked, however, do you even have a public MX record for that domain?
Some systems check..

usually, you would plug your MX name or IP in here for a query..
http://www.mxtoolbox.com/blacklists.aspx
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now