How to input chinese characters on Sybase 15 using Coldfusion 8 ?

I'm having problems to input chinese characters on sybase database when using Coldfusion 8 as front-end (using the default connection driver which comes with coldfusion).
The database has charset working well, since i can insert/search/view the characters when using other tools. On Coldfusion, i can view the characters... just can not insert/update chinese chars.
On application.cfm, i've included the script setEncoding for form/url scope to encode as utf-8, included also the tag <cfcontent type="text/html; charset=utf-8">, and on all my pages i've included the tag <cfprocessingdirective pageencoding="utf-8">.
I've searched i think all topics of coldfusion+languages on this site, but i think all of them were related to My SQL database, and not helpfull to me.

Any help on this issue ?
Who is Participating?
jackdaniel_chinaConnect With a Mentor Author Commented:

The problem was solved by using the jdbc driver provided by Sybase (jConnect) instead of the one shipped with Coldfusion, and adding  below parameters to the jdbc url:

jackdaniel_chinaAuthor Commented:
Hi Shru,

I've checked the link, but it didn't help.. I don't get any error on CF neither on Sybase..
I've tried also creating a new datasource with a Sybase jdbc driver and passing the parameters useUnicode=true&characterEncoding=utf-8 on the jdbc url, but didn't work..

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.