Solved

Terminal Services refusing connections.

Posted on 2009-07-15
12
1,623 Views
Last Modified: 2013-11-21
We have an SBS2003 Premium machine that is running as DC, Exchange and SQL Server and ISA. We are preparing to upgrade to SBS2008 so i have had to reconfigure the network topology, we used to have a dual WAN setup with ISA, but yesterday i removed ISA and reconfigured the server to use a single NIC for Net access and Network. The second NIC is disabled within network connection on the server.

All was fine until i rebooted the server to complete the uninstall of ISA, the server has come back up fine, but i cannot get an RDP connection to the system. Any attempt is immediately rejected by the server, this is from both Mac OSX and WinXP client machines.

I can ping the machine fine by both IP and Hostname, so DNS seems to be functioning correctly. I can also browse shares e.t.c and access to the SQL database is fine.

I have done a port scan and 3389 reports open and reports ms-wbt-server is listening. I have also done a netstat on the server and it shows the something is listening on 3389.

I have tried initiating and RDP connection directly on the server to localhost/127.0.0.1 as well as ip and that also fails.

Interestingly all the Terminal Service controls in Services on the server seem to be grayed out, so i am unable to restart the service.

Help please!!!!

Thanks

Gareth
0
Comment
Question by:gazzer1982
  • 6
  • 5
12 Comments
 
LVL 12

Expert Comment

by:marcustech
ID: 24858357
Is administrative tools > services > terminal services started?
0
 

Author Comment

by:gazzer1982
ID: 24858488
Yes it does say it is started. However weirdly when i check it's properties it is set to start manually. I will set it to automatic start and give the server a reboot later once everyone has gone for the day.

Can't believe i didn't notice that before, thanks for the memory jog!
0
 
LVL 12

Expert Comment

by:marcustech
ID: 24858627
Funnily enough, on my SBS server, it's also set to Manual, I believe the service is set to start on demand rather than automatically with the OS. I'm not terribly convinced this will fix your issue.

Try disable the windows firewall on the server and see if it then allows the connection, it may need RDP added as an expection.

In administrative tools > terminal services configuration > connections > "your RDP connection"

under network adapter tab, is "all network adapaters configured with this protocol" selected? and in remote control tab is "use remote control with the following settings" selected? (I suggest in the level of control box below selecting "interact with the session" as well.

let me know,

-js
0
 

Author Comment

by:gazzer1982
ID: 24858746
Thanks for that, i am running as a single NIC setup so windows firewall is disabled.

I have taken a look at the settings you suggested and they are all correct.

Any other ideas, i think it's still worth a reboot later, especially as you cannot manually restart the Terminal Services service without rebooting the server. Dull!
0
 
LVL 12

Expert Comment

by:marcustech
ID: 24858793
No problem mate, and dispite being on a single NIC the server will still be running a standard (xp like) firewall on the network connection.

You can see if this is switch on by going to start > control panel > windows firewall. It may well be switched off, but still none the less it's worth checking.

And yeah I await to see how you get on with the reboot later :)
0
 

Author Comment

by:gazzer1982
ID: 24858845
I guess there may be a firewall running there somewhere, but i remember ICW telling me that firewall would be disabled. Also when i go to firewall in Control Panel i get an error telling me that window cannot control the firewall as a program or service is using the network address translation component (Ipnat.sys).
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 12

Expert Comment

by:marcustech
ID: 24858893
Try stopping the routing and remote access service (since it won't be needed in 1NIC mode) and then try to access the firewall. Also at this point try the RDP again.
0
 

Author Comment

by:gazzer1982
ID: 24859269
Isn't routing and remote access required for VPN access?
0
 
LVL 12

Accepted Solution

by:
marcustech earned 400 total points
ID: 24859363
Yes it is, it might be worth re-running through the wizard with the new setup, to set it up though if you're using VPN.

Sorry I over looked the fact your using VPN, on our server we're forwarding the RDP ports rather than PPTP.
0
 

Author Comment

by:gazzer1982
ID: 24859982
As i see, yeah we don't expose the RDP ports externally, connections are via PPTP passed through a pfSense firewall.

I was forced to re-run the ICW at the end of the ISA uninstall. But it can't hurt to run it again, i will do so before i reboot, hopefully one will sort it out.

Cheers

Gareth
0
 
LVL 31

Assisted Solution

by:Henrik Johansson
Henrik Johansson earned 100 total points
ID: 24863790
Is the checkbox for allowing RDP-connection ticked under System Properties -> Remote ?

If it's ticked, untick the checkbox, click apply and tick the checkbox again to re-enable RDP and close the dialog with ok. I've seen on one of our TS that the RDP-permissions get corrupt sometimes and nead to be reset by temporary disabling RDP-access to fix some stuff in registry.
0
 

Author Comment

by:gazzer1982
ID: 24864922
Well i re-ran the ICW and restarted the server, and it is now working again so something seems to have sorted it. Hopefully it's now fixed permanently and i can start my SBS 2008 migration .i performed a live image of the system to our new Esxi server tonight, and it seems have gone without a hitch. So i can now take a snapshot incase it all goes tits. Not that i don't trust Microsofts online migration or anything . . .
0

Featured Post

New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SBS 2011 6 42
Is there a monitoring tool to see network usage per user? 5 56
Configure SBS 2008 monitoring 4 45
2003 File Server upgrade 11 54
I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now