Solved

can connect to web server using remote desktop but not with filezilla

Posted on 2009-07-15
27
952 Views
Last Modified: 2013-12-09
hi EE,
I need to log into a server using FileZilla although I get 'could not connect to server'.
I am able to login using remote desktop with the same credentials.  

do I need to setup an account to login using FileZilla?  

please advise, thanks!!
0
Comment
Question by:jimbona27
  • 15
  • 8
  • 4
27 Comments
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 24858204
Hi jimbona27,

well, FTP and RDP are completely different things. A bit more information would be great. For example:

- How are this machines connected? LAN? WAN?
- Is there a firewall in between?
- Is there a FTP server running on the server at all?

I assume you run FTP on IIS because you chose this topic. So:

Make sure the FTP service is running on the server. Make sure that port 21 is not blocked either on a firewall between or on the server itself.

So much for a start...
0
 
LVL 6

Accepted Solution

by:
MikeGGG earned 150 total points
ID: 24858209
Remote Desktop uses RDP service
Filezilla is a FTP client and uses FTP service.
In order to use FTP services, you have to setup and configure it first.
0
 

Author Comment

by:jimbona27
ID: 24858225
thanks for the reponse.
where should I look on the server?
how can I use filezilla to download the files?
0
 
LVL 16

Assisted Solution

by:The_Kirschi
The_Kirschi earned 350 total points
ID: 24858251
First go to Start -> Control Panel -> Administrative Tools -> Services and see if a FTP service is present and running. Do you know if it installed at all?

When the server is running you can connect to the server by putting the correct ip, username and password in FileZilla.
0
 

Author Comment

by:jimbona27
ID: 24858271
"ftp publishing service" is running.

when I try and login using filezilla, using the same details as when I connect using remote desktop I cant connect to server.

??
0
 

Author Comment

by:jimbona27
ID: 24858306
it doesnt appear to connect to the server??
status: connection attempted failed with etimedout - connection attempt time out

any why of identifying why the server is not connecting?
Thanks,
0
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 24858443
Is the Firewall/ICS service running on the server? Maybe you must open port 21.

You did still not mention if there is a firewall in between the client and server. Can you try to install FileZilla locally on the server and connect?
0
 

Author Comment

by:jimbona27
ID: 24858505
if i download and install on the server, do I install the server or client version of filezilla?
0
 
LVL 6

Expert Comment

by:MikeGGG
ID: 24858518
Client.
0
 

Author Comment

by:jimbona27
ID: 24858543
ok installed, it did say reboot but i cant do that as its the live server.  what details do I provide, localhost, then username and password as I have for remote desktop?
0
 

Author Comment

by:jimbona27
ID: 24858567
i can connect locally using those details...

so any ideas what that means in terms of my machine connecting?
0
 
LVL 6

Expert Comment

by:MikeGGG
ID: 24858589
0
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 24858612
If you can connect locally it is very, very likely that port 21 is blocked somewhere between your Filezilla client and the IIS FTP Server. I guess I did mention that before... :-/
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 6

Expert Comment

by:MikeGGG
ID: 24858637
It could be also misconfigured FTP server, for example, bound to wrong IP
0
 

Author Comment

by:jimbona27
ID: 24858704
ok before making loads of changes on a live server I am aware that other people log onto this server regularly using filezilla...

i cant ask them unfortunately so I must be doing something wrong within filezilla.

is there any settings within the connection window within filezilla I could be getting wrong?  can you suggest what I should try?  i.e. ftp, sftp, normal or prompt for password type settings?

thanks,
0
 
LVL 16

Assisted Solution

by:The_Kirschi
The_Kirschi earned 350 total points
ID: 24858740
Ok, if you would have told us before that others can connect....

Have a look at the firewall and proxy settings especially:

http://filezilla.sourceforge.net/documentation/configuration.htm
0
 

Author Comment

by:jimbona27
ID: 24858987
i dont know the significance of the settings..!
untitled.JPG
0
 

Author Comment

by:jimbona27
ID: 24858993
why or when would i use user@host, site, open....??
0
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 24859048
Are your client and the server in the same LAN? Then it is likely that you do not have a proxy server, so select None here. Also try to switch between active and passive mode. Also look at the General proxy setting. Don't you have a person from IT that can tell you what to configure? And may I ask why you cannot ask one of the others who's connection is fine?
0
 

Author Comment

by:jimbona27
ID: 24859196
in the site manager dialog I have changed the transfer settings to default, active and passive although I get  'could not connect to server.'

dev is outsourced.
0
 

Author Comment

by:jimbona27
ID: 24859204
i've also checked and unchecked the bypass proxy which still causes the same error message.
0
 

Author Comment

by:jimbona27
ID: 24859227
answering your LAN question.  I am at home whilst trying to connect to a remote server which could be anywhere.. all I know is that I can connect using remote desktop.
0
 

Author Comment

by:jimbona27
ID: 24859245
what should the server type be?  i assume ftp?
0
 

Author Comment

by:jimbona27
ID: 24859366
is it possible to make filezilla use the same credentials and protocols as remote desktop?

thanks,
0
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 24859374
ok, if you are sitting at home, it is very likely that there is a firewall somewhere between you and the ftp server that does not let you connect because the FTP port 21 is closed

I would verify at first that the port is open. you can use a tool like angry ip scanner where you can specify to check for open ports. it does not make sense to investigate further until we know that the port is open.
0
 

Author Comment

by:jimbona27
ID: 24859460
ok i have downloaded and opened the program..

i have added the server ip into the hostname field. the ip range and to value are already preset.

is this everything i need to set?
thanks,
scan.JPG
0
 
LVL 16

Assisted Solution

by:The_Kirschi
The_Kirschi earned 350 total points
ID: 24867060
The ip that is filled in automatically is your own. Please replace it with the ftp server ip. You do not have to specify ip and hostname. One of both is sufficient. To check for the ftp port click the little tools icon at the right next to the IP range dropdownlist. In the ports tab type 21 in the port selection field. Then click OK and on the main screen click the Start button.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Here are the symptoms: You start receiving calls from users that one of your legacy web apps isn't coming up, so you log into your IIS 5 server to check it out.  When you pull up the services, you notice that the WWW Publishing service isn't runn…
Over the past decade, as Internet security has become a chief concern of IT professionals, one of the most common questions administrators and users ask is, “Which is more secure, SFTP or FTPS?” In short, both file transfer protocols offer a high…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now