OSPF: Cannot see ourself in hello, state INIT

Hi All,

I have three Cisco routers (1 x 1841 2 x 877) running ina DMVPN / Multipoint tunnel config as suggested in the Cisco text http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a008019d6f7.shtml

The Tunnels are up, and I have no problems pinging to either side (my Internal addresses are 172.16.0.1/24 for the master and 172.16.0.2-3/24 for the branch offices).

I have configured OSPF on the router at our head office and ahve been able to peer both 877's in hte brances using ospf as well. I am using Area 0 for all the Head office subnets and Areas 2+3 for the branches.

On the surface everything looks really good, however at random intravals when viewing a "debug ip ospf adj", I see the error OSPF: Cannot see ourself in hello from 210.23.138.41 on Tunnel1, state INIT

this causes the routers to regnotiate their ospf relationship which is causing all sorts of problems because for a few moments my routing tables are missing the learned routes.

Can anyone shed any light on this error?
mgordon-spiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Istvan KalmarHead of IT Security Division Commented:
Hi,

Did you configured correctly the hello times?

If the hello interval command is configured at the interface configuration level, then use the interface configured value, else

If the hello interval command is configured at the area configuration level, then use the area configured value, else

If the hello interval command is configured at the router ospf configuration level, then use the router ospf configured value, else

0
mgordon-spiAuthor Commented:

I havent changed default hello times, however I understand that if routers have two different timer settings then ospf will not allow them to form an adjacency.

 I have tested this and found it to be the case, so I can confirm that both routers are operating with the same hello timers.
0
mgordon-spiAuthor Commented:
Discovered that I was required to MAP multicast traffic as well as unicast traffic using NHRP. Issue Resolved.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.