Solved

Exchange 2007 attachment limit size

Posted on 2009-07-15
25
698 Views
Last Modified: 2012-05-07
We have Exchange 2007 and I am having some issues regarding attachment limit sizes.  This appears to be only affecting some users and not others.

I have used the Exchange command shell  to modify the following:

get-receiveconnector | fl fqdn, maxmessagesize
get-receiveconnector | set-recieveconnector -maxmessagesize 100MB

Get-Sendconnector | fl fqdn,maxmessagesize
Set this to unlimited

get-transportconfig | fl maxrecievesize,maxsendsize
Set this to unlimited

I then restarted the Transport service and System Attendant service.

There are no size limits on any individual mailbox that I can see.

Are there any other places I have missed making a change?  Wouldn't the changes I have already made have been global?
0
Comment
Question by:Cicio1412
  • 12
  • 10
  • 2
  • +1
25 Comments
 
LVL 6

Expert Comment

by:muzzi_in
Comment Utility
you cannot set different level of size limit, it has to be same everywhere,

get-receiveconnector | fl fqdn, maxmessagesize
get-receiveconnector | set-recieveconnector -maxmessagesize 100MB

Get-Sendconnector | fl fqdn,maxmessagesize
Set this to 100MB

get-transportconfig | fl maxrecievesize,maxsendsize
Set this to 100MB

then restart information store service & transport service, it should work.
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
Global setting:
---------------
   The systemwide default is held in Active Directory and is set to 10MB by default (this is 10240 K, the setting is just a number but is in K)

   Using ADSIedit, navigate to:
CN=Message Delivery,CN=Global Settings,
CN=Assocaited Network Solutions PLC,
CN=Microsoft Exchange,CN=Services,CN=Configuration,
DC=xansplc,DC=com

the arguments you want are:
msExchRecipLimit     (default 5000)
submissionContLength (default 10240)
delivContLength      (default 10240)

Transport Setting
-----------------
Site Default is set in powershell; use Get-TransportConfig to get current settings, then:

Set-TransportConfig -MaxRecipientEnvelopeLimit <nn> -MaxReceiveSize <nn>MB -MaxSendSize <nn>MB

current setting:

Set-TransportConfig -MaxRecipientEnvelopeLimit 5000 -MaxReceiveSize 20MB -MaxSendSize 20MB
0
 

Author Comment

by:Cicio1412
Comment Utility
These are my Transport Settings:

ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : unlimited
MaxRecipientEnvelopeLimit      : 5000
MaxSendSize                    : unlimited
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True

Restarted the store and transport service and folks are still receiving the attachment limitation error.
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
What is the attachment limitation error? Can you post the whole thing here (removing any domain specifics)

Did you review the Global limits in AD? If they are empty, set them to 100MB as well. I've seen a previous post where this was the fix.

Shaun
0
 

Author Comment

by:Cicio1412
Comment Utility
The error some are receiving is"

The file was not attached because the file exceeded the max limitation of 5MB.

0
 

Assisted Solution

by:ryt2asim
ryt2asim earned 100 total points
Comment Utility
Check the global limit in active directory whats the limit set too.
0
 

Author Comment

by:Cicio1412
Comment Utility
I have looked at my Exchange console | Organization Configuration | Hub Transport | Global Settings tab | Transport Settings | properties.

The Global tab has no limits.  They are blank.  And yet I am still receiving the limitation error.
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
There are three places where Message size is set in Exchange 2007 RTM
There are two places where Message size is set in Exchange 2007 SP1
Global Setting (RTM Only. Transport setting will change this automatically in SP1)
--------------
Global Settings stored in Active Directory (access using ADSIEdit)
Configuration --> Services --> Microsoft Exchange --> [DOMAINNAME] --> Global Settings --> right client
Message Delivery -->
Check the settings below. They are in KB
submissionContLength (default 10240) (MaxSendSize)
delivContLength      (default 10240) (MaxReceiveSize)

Transport Setting
-----------------
To show current settings:
Get-TransportConfig | fl Max*Size
To Alter:
Set-TransportConfig -MaxReceiveSize <nn>MB -MaxSendSize <nn>MB

Receive and Send Connectors
---------------------------
To Get current settings:
Get-ReceiveConnector | ft Name, Max*Size
Get-SendConnector | ft Name, Max*Size
To Alter:
Set-ReceiveConnector "<connector name>" -MaxMessageSize <nn>MB
Set-SendConnector "<connector name>" -MaxMessageSize <nn>MB

http://technet.microsoft.com/en-us/library/bb124345.aspx

This is how to set Transport level message limits, but you should also ensure that there are no 'more
restrictive' limits set on Mail enabled objects such as mailbox users, distribution groups, public
folders etc that are causing a fail.
0
 

Author Comment

by:Cicio1412
Comment Utility
Here are my new settings:
ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : unlimited
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : unlimited
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
Note that if you are using RTM, you need to manually use ADSIEdit to alter the Global settings. Global transport settings will not suffice.

Better still update to SP1.

Shaun
0
 

Author Comment

by:Cicio1412
Comment Utility
I am running Exchange 2007 SP2
0
 

Author Comment

by:Cicio1412
Comment Utility
The settings I shared were all set with ADSIEdit.
0
Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

 

Author Comment

by:Cicio1412
Comment Utility
My new settings after changing the AD global limits to 100MB

ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 100MB
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : 100MB
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
Exchange 2007 SP2 is not publically available yet.

The settings you are showing are from a powershell command. This is not showing values in CN=Message Delivery using ADSIEdit.

Shaun
0
 

Author Comment

by:Cicio1412
Comment Utility
My apologies when you SP1 I thought you were refering to Service Pack 1.  I am running Service Pack 2.

CN=Message Delivery Properties
delivContLength 102400
msExchRecipLimit <not set>
SubmissionContLength 102400
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
I'm a little confused now, are you referring to the Operating System pack level?

It looks as if you are running Exchange 2007 SP1, because when you have set Global Transport settings to 100MB it appears to have correctly edited the Global settings in AD as well as you have attached.

So I think we can safely say it is not a Transport size limit.

Are you using OWA when trying to attach the attachment to an email message or a bounce back when you send a message with a large attachment? If it is when trying to attach the attachment, particularly using OWA (but would probably be same with Outlook) there may be other settings to consider as outlined below:

http://msexchangeteam.com/archive/2006/11/14/431477.aspx

Shaun


0
 

Author Comment

by:Cicio1412
Comment Utility
Again my apologies, the 2 should have been a 1.  I am running Exchange SP1 :)

I receive the attachment limitation error from within Outlook.  
0
 
LVL 6

Assisted Solution

by:muzzi_in
muzzi_in earned 100 total points
Comment Utility
Hey let me know are you trying to attach file using OWA, ? if yes
whats the size of the file which your attaching,???
have u tried to attach with OL????

if the issue is only with OWA, please refer

http://msexchangeteam.com/archive/2006/11/14/431477.aspx

Note:
You can not set different values on transport config, send / receive connector , it has to be same as 100 MB.
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
It is fine to have different values on the Send/Receive connectors and Global settings, but note that the most restrictive value will take precedence.

It's starting to sound more like a mailbox or user specific limit now. Review User settings in this article http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html as well as the OWA article I attached above but you are using Outlook so perhaps this article first.

Shaun
0
 

Author Comment

by:Cicio1412
Comment Utility
Does anyone know the original file association foe web.config in the OWA folder on exchange?
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
There is no association by default. The file can be viewed / edited using any text editor. Notepad / wordpad / word etc.

Shaun
0
 

Author Comment

by:Cicio1412
Comment Utility
Well. I made the change to the OWA file web.config.  I made the mistake of associating the file with wordpad.  I finally was able to clear this association, but now when I go to OWA via the web, I am getting a runtime error with error screen.
0
 

Author Comment

by:Cicio1412
Comment Utility
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

0
 
LVL 27

Accepted Solution

by:
shauncroucher earned 300 total points
Comment Utility
You must have made a type in your changes to the web.config. Double check all the changes you made.

You might be able to get more info by change customErrors to RemoteOnly so that if you try to access OWA from the server you will get a more customised error page, rather than this non helpful generic error.

Shaun
0
 
LVL 27

Expert Comment

by:shauncroucher
Comment Utility
What was it in the end?

Shaun
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now