How to deal with spam where both sender and reception are the same?

I have notice an increase of spam in my exchange tracker where both the sender and reception are the same.  i.e.:  aaaaaaaaa@domain.com.  I'm wondering if there is a way of having the system ignore these?  I only see these items in the "Message tracking Center" and they are not being populated to my mail system as I have "Send copy of Non-Delivery Report to" turn off.  I have run a number of "Open Relay" tests and have confirmed that I am not expose this way.  i.e.: http://www.checkor.com/

Thanks

James
thumper631Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
If you have Exchange SP2 installed - configure Sender Filtering and add *@yourdomain.com as the sender.
This will block all messages that claim to come from your domain from external sources.
If you have users that access your server via SMTP / POP3, then you will have to add your other users to the sender filtering one by one.
This problem bugged me for ages until I discovered this new feature in SP2.
Open up Exchange System Manager, Expand Global Settings, Right-Click Message Delivery and chose properties.
On the Sender Filtering Tab add *@yourdomain.com (obviously change the domain name to match your domain;-))
You may as well Check 'filter messages with Blank Sender' and 'Drop connection of address matches filter'
On the Recipient Filtering Tab - Check Filter recipients who are not in the Directory
Setup Tarpitting - http://support.microsoft.com/kb/842851 to slow down Directory Harvesting
And then  enable the filtering on the SMTP Virtual Server (Expand Servers, Your Server, Protocols, SMTP)
Right Click the default SMTP Virtual Server and choose properties.  Click on the Advanced Tab - then the Edit Button. Tick everything and then close the windows.
Restart the Simple Mail Transfer Protocol (SMTP) service - Start, Run, Services.msc (enter) and then relish the lack of spam from your own domain name in your inbox!
 
 
0
 
grandebobCommented:
You need to create an SPF record for your domain and enforce sender ID on your server.
http://www.openspf.org/ has great information on how to do it.
0
 
E2KXCommented:
Is the spam  Sender & recipient Domain, your own domain and emails are coming from out side or its another internet sender and recipient domain address
0
 
tmeunierCommented:
Use Sender ID filtering (requires Exchange 2003 SP2), after publishing an SPF record in your own internal and external DNS.   Make sure that you add any web applications or marketing partners that send email purporting to be from your own domain.
http://technet.microsoft.com/en-us/library/aa995992%28EXCHG.65%29.aspx

Do you have any anti-spam tool in place?  Even if you use Vamsoft ORF Enterprise (vamsoft.com) it provides many highly advanced spam fighting techniques, for a very very very inexpensive price.

-tom
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.