Solved

Access Solaris GUI Remotely

Posted on 2009-07-15
5
1,752 Views
Last Modified: 2013-12-27
Have installed Solaris 10 into a Sun E4500 machine.  Am able to Telnet just fine as regular user and as root.

Now trying to use Attachmate Reflection X to connect to the server  but keep receiving following error:
"Connection Refused RX2443" <-- this message is from Reflection X interface.

I have several other Solaris servers that I can access just fine from Reflection.  This client session is defined exactly the same in Reflection so I don't think it's the software.  Likely I'm missing something in Solaris itself.

Could anyone assist me in figuring out what I'm missing?
Thank you.
0
Comment
Question by:vocogov
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 40

Expert Comment

by:omarfarid
ID: 24861876
Do you have a firewall in the middle between the two systems?

try to run

/etc/init.d/dtlogin start

om solaris
0
 
LVL 1

Author Comment

by:vocogov
ID: 24861952
To further explain:
I am running the Reflection X software from a Windows Server 2003 to connect to the Solaris machine.  The goal being to be able to start up Solaris GUI applications such as SMC from the session started on the Windows box.

omarfarid:
Here is the result from the command you asked for:

# /etc/init.d/dtlogin start
/etc/init.d/dtlogin: svcadm: not found

Here's output from ps command looking for dtlogin:
# ps -ef | grep dtlogin
    root   494   437   0 16:18:05 ?           0:00 /usr/dt/bin/dtlogin -daemon - udpPort 0
    root   437     1   0 16:18:02 ?           0:00 /usr/dt/bin/dtlogin -daemon - udpPort 0

Thanks.
0
 
LVL 1

Author Comment

by:vocogov
ID: 24861995
Oh... and there's no firewall.  Both servers are inside.  This is working fine between this same Windows servers and my other two Solaris servers.  Just not with this new install.
0
 
LVL 1

Accepted Solution

by:
vocogov earned 0 total points
ID: 24863626
I got it now.

Had to enable 'rlogin' from Solaris command line.

#svcadm enable rlogin

I feel silly.
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 24863635
very good :)
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question