Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Block Inter-VLAN Access on Cisco Router

Posted on 2009-07-15
3
Medium Priority
?
1,076 Views
Last Modified: 2012-05-07
I have VLANS (5,6,7,8,9,10) configured on my Cisco Switch C2950 connected to router C2651. All VLANs can ping to each other but I want the users in VLAN 5 should be able to access all the VLANs but all other VLANs should not access each other. They should access our default gateway 172.23.200.1. Please see a piece of my code below:

Cisco2651XM#sh run
Building configuration...

Current configuration : 1623 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
!
interface FastEthernet0/0
 ip address 172.23.200.185 255.255.254.0
 ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1.5
 encapsulation dot1Q 5
 ip address 192.168.5.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/1.6
 encapsulation dot1Q 6
 ip address 192.168.6.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/1.7
 encapsulation dot1Q 7
 ip address 192.168.7.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/1.8
 encapsulation dot1Q 8
 ip address 192.168.8.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/1.9
 encapsulation dot1Q 9
 ip address 192.168.9.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
!
ip default-gateway 172.23.200.1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 192.168.0.0 255.255.0.0 FastEthernet0/1
!
no ip http server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 192.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
control-plane
!
0
Comment
Question by:sg2009
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 7

Accepted Solution

by:
clonga13 earned 2000 total points
ID: 24862681
Use access-lists to block traffic between the ports. An example would be:

access-list 101 deny ip 192.168.9.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 101 permit ip 192.168.9.0 0.0.0.255 any

and use ip access-group 101 in on the appropriate interface. This way you decide what traffic can go between the VLANs and still allow traffic to the Internet.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 24863265
Hi,

In my opinion you must use VRF routing!
IT is more secured than access-list

Please read the following:
http://www.cisco.com/en/US/docs/ios/sec_secure_connectivity/configuration/guide/sec_vrf_aware_ipsec_ps6922_TSD_Products_Configuration_Guide_Chapter.html

Best regards,
Istvan
0
 

Author Closing Comment

by:sg2009
ID: 31603895
It worked.
0

Featured Post

Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question