exchange 2007 the attachment size exceeds the allowable limits

I am trying to set up Exchange 2007 to allow for all users to be able to send & receive messages of up to 40 Mb. I finally found a setting in powershell that was set to 10 Mb. I changes this to 40 Mb but it still isn't working.

I am totally stumped on where the setting resides that I need. Here is the PS output:
[PS] C:\>get-transportconfig


ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {127.0.0.1}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 100MB
MaxRecipientEnvelopeLimit      : 5000
MaxSendSize                    : 100MB
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True

Is there a way to force update the Transport Config? Is this an instant Change? does the user need to restart outlook to test?
Are there other settings that I need to verify?
LVL 1
LostInWindowsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shauncroucherCommented:
There are three places where Message size is set in Exchange 2007 RTM
There are two places where Message size is set in Exchange 2007 SP1
Global Setting (RTM Only. Transport setting will change this automatically in SP1)
--------------
Global Settings stored in Active Directory (access using ADSIEdit)
Configuration --> Services --> Microsoft Exchange --> [DOMAINNAME] --> Global Settings --> right client
Message Delivery -->
Check the settings below. They are in KB
msExchRecipLimit     (default 5000)
submissionContLength (default 10240) (MaxSendSize)
delivContLength      (default 10240) (MaxReceiveSize)

Transport Setting
-----------------
To show current settings:
Get-TransportConfig | fl Max*Size
To Alter:
Set-TransportConfig -MaxRecipientEnvelopeLimit <nn> -MaxReceiveSize <nn>MB -MaxSendSize <nn>MB

Receive and Send Connectors
---------------------------
To Get current settings:
Get-ReceiveConnector | ft Name, Max*Size
Get-SendConnector | ft Name, Max*Size
To Alter:
Set-ReceiveConnector "<connector name>" -MaxMessageSize <nn>MB
Set-SendConnector "<connector name>" -MaxMessageSize <nn>MB
http://technet.microsoft.com/en-us/library/bb124345.aspx
This is how to set Transport level message limits, but you should also ensure that there are no 'more
restrictive' limits set on Mail enabled objects such as mailbox users, distribution groups, public
folders etc that are causing a fail.
 
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shauncroucherCommented:
Restart MS Transport service after changes
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.