Solved

samba not sharing according to permissions

Posted on 2009-07-15
7
4,905 Views
Last Modified: 2013-12-09
samba is not sharing according to file permission shares

example

-rwxrwx---   1 user1 everybody 130K Jun 17 11:47 notes1.pdf
-rwxrwx---+  1 user2  everybody  32K Jul 15 15:32 notes2.xls
-rwxrwx---+  1 user1 everybody  44K Jul 15 14:17 notes3.doc

everyone can access notes1
only user2 can access notes2
only user1 can access notes3

I am not exactly sure what that plus symbol means, but I suspect it is a part of the issue.

heres the samba config

[global]
        netbios name = FILE SERVER
        server string = FILE SERVER
        socket options = TCP_NODELAY
        unix password sync = yes
        workgroup = SERVER01
        os level = 20
        encrypt passwords = yes
        wins support = true
        domain master = yes
        map to guest = Bad User
        printcap name = /etc/printcap
        load printers = no
        printing =


[public]
        delete readonly = yes
        writeable = yes
        comment = public
        path = /sharedfolders/public
        force directory mode = 0770
        force group = everybody
        force create mode = 0770
        valid users = @everybody
        create mode = 0770
        directory mode = 0770

0
Comment
Question by:koffea
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 23

Expert Comment

by:savone
ID: 24864782
The plus sign in Solaris and other UNIX systems means there is an ACL on the file.  
0
 
LVL 23

Expert Comment

by:savone
ID: 24864788
Try getfacl notes.xls on the command line and see what you get.
0
 
LVL 23

Expert Comment

by:savone
ID: 24864796
Sorry for the multiple posts:

man pages for getfacl and setfacl

GET:
http://pwet.fr/man/linux/commandes/getfacl

SET:
http://pwet.fr/man/linux/commandes/setfacl
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:koffea
ID: 24864895
this is what i get:

# file: notes2.xls
# owner: user2
# group: everybody
user::rwx
user:user3:rwx
group::---
mask::rwx
other::---

so it is not setting the acl correctly to allow the group?
0
 

Author Comment

by:koffea
ID: 24870645
so basically i have two options?

i could run the following command every 5 minutes:
setfacl -R -m g:everybody:rwx /sharedfolders/public/
 
or i could disable facl.  How do you disable facl?
0
 
LVL 23

Accepted Solution

by:
savone earned 500 total points
ID: 24870710
I am not well versed in ACLs, but I would assume you should be able to remove the ACL on the file and fix your problem.
0
 

Author Closing Comment

by:koffea
ID: 31604019
savone got me on the right track by explaining what the + symbol was, but did not offer a complete solution.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
rDNS on single IP and multiple domains 11 51
Need a podcast plan 3 98
Assess most serious Linux privilege escalation bug 17 192
Use CRON to save a copy of an open file 1 76
Creating a Samba server for a small office. Ubuntu Linux and Samba can breathe new life into a retired PC and save an office money on new hardware/software. Our example server will have two hard disks, one exclusively for storing shared data. …
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question