lpadmin -m and foomatic

Posted on 2009-07-15
Last Modified: 2013-11-15
Hi i'm a newbie in linux and need help installing network printer. Trying to install an HP Laser Jet 5.

I tried to look for the available ppd files using lpadmin -m | grep " HP LaserJet 5" and got the following output:

gutenprint.5.2://pcl-5/expert HP LaserJet 5 - CUPS+Gutenprint v5.2.3
gutenprint.5.2://pcl-5/simple HP LaserJet 5 - CUPS+Gutenprint v5.2.3 Simplified
foomatic:HP-LaserJet_5-lj4dith.ppd HP LaserJet 5 Foomatic/lj4dith
foomatic:HP-LaserJet_5-lj5gray.ppd HP LaserJet 5 Foomatic/lj5gray
foomatic:HP-LaserJet_5-ljet4.ppd HP LaserJet 5 Foomatic/ljet4
foomatic:HP-LaserJet_5-pxlmono.ppd HP LaserJet 5 Foomatic/pxlmono

Can someone point me in the right direction on what to do next? I tried to locate the ppd files listed under foomatic, but I cannot find any files with those names.

Question by:ShadowColossus
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
LVL 14

Expert Comment

ID: 24867430
Have you tried with System-Administration->Printers, and let the system install recommended drivers?

Author Comment

ID: 24870904
how would I do this from the command line?
LVL 14

Expert Comment

ID: 24870973
Are you running a server?. You didn't say that in your first post.
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

LVL 14

Expert Comment

ID: 24871003
You can run cups administrator from a browser on another PC:


Author Comment

ID: 24872193
Sorry I wasn't mentioning I was using Ubuntu server. Thanks for the advice, I wanted to check if I could do it from command line. The browser was going to be my last recourse.I was curious about the foomatic output from "lpadmin -m" command. I know that command is used to view the available drivers, but I cannot locate the .ppd files listed with foomatic.
LVL 14

Expert Comment

ID: 24872216
So i have misunderstood. You are not trying to configure the printer, but just to exercise the terminal?

Author Comment

ID: 24872911
Yes..sorry again....I was thinking "lpinfo -m" and "not lpadmin -m"

I was using lpinfo -m to view available drivers, lpinfo -v  to locate the network printer and "lpadmin p printer-name options" to configure the printer.

It was the lpinfo -v where I was getting the foomatic lines and didn't know where the ppd files are located from foomatic. I hope this clears any confusion with my problem.

LVL 14

Accepted Solution

fmarzocca earned 125 total points
ID: 24876375
The ppd files should be in /usr/share/ppd

Author Closing Comment

ID: 31604068
thanks for your help, i download the necessary ppd files and move it to that location.

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
CentOS User Audit 3 89
can't umount nfs share after server goes offline... 4 96
Expand a partition in Centos 7 Linux with Virtualmin 1 74
rsyslog raw message 4 35
This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question