Solved

Cisco IPSEC VPN not passing traffic

Posted on 2009-07-15
4
1,042 Views
Last Modified: 2012-06-27
Hi,

we have changed ISP's for our wireless broadband cards, but we have an issue where once connected to the net, i can connect to the vpn fine, but no data is passed through the tunnel.

If i ping from my machine on the 192.168.1.x network and have wireshark running on the remote machine, i can see the icmp packet get to the laptop, but the reply doesnt get back.

I have contacted our isp about it and they use public routable addresses when the wireless cards connect, therefore NAT Traversal doesnt get used (which fixed this issue when i have a similar issue before)

Attached is my scrubbed code.


Thanks
ASA Version 8.0(4) 

!

hostname GroupFirewall

domain-name X.X.X.X

enable password M28DC8GpviqlPXJP encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name X.X.X.X FTP_ARN

name 192.168.1.90 James

name 192.168.1.99 Justin

name 192.168.1.97 System-Status

name 192.168.5.51 Berlin description X.X.X.X Mail Server

name X.X.X.X X.X.X.X

name X.X.X.X X.X.X.X

name 192.168.5.54 MIAMI

dns-guard

!

interface GigabitEthernet0/0

 nameif WAN

 security-level 0

 ip address X.X.X.X 255.255.255.0 standby X.X.X.X

!

interface GigabitEthernet0/1

 nameif DMZ

 security-level 50

 ip address 192.168.100.1 255.255.255.0 standby 192.168.100.4 

!

interface GigabitEthernet0/2

 nameif Lonsyd

 security-level 100

 ip address 192.168.1.1 255.255.255.0 standby 192.168.1.4 

!

interface GigabitEthernet0/3

 nameif Idscomms

 security-level 100

 ip address 192.168.5.1 255.255.255.0 standby 192.168.5.4 

!

interface Management0/0

 nameif Failover

 security-level 100

 ip address 192.168.7.95 255.255.255.0 

!

boot system disk0:/asa804-k8.bin

ftp mode passive

clock timezone EST 10

clock summer-time EDT recurring last Sun Oct 2:00 last Sun Mar 3:00

dns domain-lookup WAN

dns server-group DefaultDNS

 domain-name X.X.X.X

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

object-group network NZ

 network-object 192.168.2.0 255.255.255.0

object-group protocol TCPUDP

 protocol-object udp

 protocol-object tcp

object-group service RealVNC tcp

 port-object eq 5900

object-group service Sql tcp

 port-object range 1433 1434

object-group service Blackberry tcp-udp

 port-object eq 3101

object-group service RTP tcp-udp

 port-object eq 8000

object-group service X.X.X.X tcp

 port-object eq 7979

object-group service CiscoVPN tcp

 port-object eq 10000

object-group network DNS

 network-object host 192.168.100.40

 network-object host 192.168.100.41

object-group service X.X.X.X tcp

 description X.X.X.X port to send MO traffic

 port-object eq 1667

object-group network X.X.X.X

 network-object host 192.168.100.30

 network-object host 192.168.100.31

object-group network WebCluster

 description Web Cluster Servers

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

object-group network DBCluster

 description Db Cluster

 network-object host 192.168.100.70

 network-object host 192.168.100.71

 network-object host 192.168.100.80

object-group network X.X.X.X

 description X.X.X.X connections for X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

object-group network UCA

 network-object host X.X.X.X

object-group service SMPP tcp

 port-object eq 4444

 port-object eq 5555

 port-object eq 5556

 port-object eq 5557

 port-object eq 5566

 port-object eq 5567

object-group network X.X.X.X

 description X.X.X.X connection IP's

 network-object host X.X.X.X

object-group network IT

 description IT

 network-object host James

 network-object host 192.168.1.91

 network-object host 192.168.1.92

 network-object host 192.168.1.93

 network-object host 192.168.1.94

 network-object host 192.168.1.95

 network-object host System-Status

 network-object host 192.168.1.98

 network-object host Justin

object-group service MSDTC tcp

 description Microsoft Distributed Transaction Coordinator Ports for SQL Replication

 port-object range 1024 5000

 port-object eq 135

object-group service Gmail-Pop3SMTP tcp

 port-object eq 587

 port-object eq 995

object-group service 7004 tcp

 port-object eq 7004

object-group service X.X.X.X tcp-udp

 port-object eq 5555

object-group service Test tcp

 port-object eq 1851

 port-object eq 1852

object-group network X.X.X.X

 network-object host X.X.X.X

 network-object host X.X.X.X

object-group service DM_INLINE_TCP_1 tcp

 port-object eq ftp

 port-object eq ftp-data

object-group service TCP_Port_73 tcp

 port-object eq 73

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 10.0.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 X.X.X.X 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.9.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 10.0.1.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 10.0.1.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 10.0.1.0 255.255.255.0 192.168.100.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.9.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 X.X.X.X 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 10.0.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.100.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list WAN_access_in remark Allow VPN Users through Firewall

access-list WAN_access_in extended permit ip 192.168.20.0 255.255.255.0 any 

access-list WAN_access_in remark Allow HTTPS access to Berlin for Web Outlook

access-list WAN_access_in extended permit tcp any host Berlin eq https 

access-list WAN_access_in remark Allow PING through Firewall

access-list WAN_access_in extended permit icmp any any log debugging 

access-list WAN_access_in remark Allow SIP through Firewall

access-list WAN_access_in extended permit object-group TCPUDP any any eq sip 

access-list WAN_access_in remark Allow Blackberry through Firewall

access-list WAN_access_in extended permit object-group TCPUDP any any object-group Blackberry 

access-list WAN_access_in remark Allow RTP (VOIP) through Firewall

access-list WAN_access_in extended permit object-group TCPUDP any any object-group RTP 

access-list WAN_access_in remark Allow POP3 through Firewall

access-list WAN_access_in extended permit tcp any any eq pop3 

access-list WAN_access_in remark Allow SSH through Firewall

access-list WAN_access_in extended permit tcp any any eq ssh 

access-list WAN_access_in remark Allow CiscoVPN through Firewall

access-list WAN_access_in extended permit tcp any any eq 10000 

access-list WAN_access_in remark Allow RealVNC through Firewall

access-list WAN_access_in extended deny tcp any any object-group RealVNC 

access-list WAN_access_in remark Allow DNS requests from WAN to DNS Servers

access-list WAN_access_in extended permit object-group TCPUDP any any eq domain 

access-list WAN_access_in remark Allow SMTP from WAN to X.X.X.X Mail

access-list WAN_access_in extended permit tcp any host X.X.X.X eq smtp 

access-list WAN_access_in remark Allow X.X.X.X from WAN to Website on Web Cluster

access-list WAN_access_in extended permit tcp any host X.X.X.X object-group X.X.X.X

access-list WAN_access_in remark Allow SMTP to Berlin

access-list WAN_access_in extended permit tcp any any eq smtp 

access-list WAN_access_in remark Allow IMAP4 to Berlin

access-list WAN_access_in extended permit tcp any host Berlin eq imap4 

access-list WAN_access_in remark Allow HTTP to Berlin

access-list WAN_access_in extended permit object-group TCPUDP any host Berlin eq www 

access-list WAN_access_in remark Allow SMTP from X.X.X.X to Berlin

access-list WAN_access_in extended permit tcp object-group X.X.X.X host Berlin eq smtp 

access-list WAN_access_in remark Allow SMTP to X.X.X.X from WAN

access-list WAN_access_in extended permit tcp X.X.X.X 255.255.255.0 object-group X.X.X.X eq smtp 

access-list WAN_access_in remark Allow HTTP from WAN to Web Cluster

access-list WAN_access_in extended permit tcp any object-group WebCluster eq www 

access-list WAN_access_in remark Allow HTTPS from WAN to Web Cluster

access-list WAN_access_in extended permit tcp any object-group WebCluster eq https 

access-list WAN_access_in extended permit tcp any object-group WebCluster object-group TCP_Port_73 

access-list WAN_access_in remark Allow SMTP from WebCluster to Berlin

access-list WAN_access_in extended permit tcp object-group WebCluster host Berlin eq smtp 

access-list WAN_access_in remark Allow SMPP from X.X.X.X to UCA

access-list WAN_access_in remark Allow SMTP from DBCluster to Berlin

access-list WAN_access_in extended permit tcp object-group DBCluster host Berlin eq smtp 

access-list WAN_access_in remark Allow FTP from X.X.X.X to LENNY

access-list WAN_access_in extended permit tcp host X.X.X.X host X.X.X.X object-group DM_INLINE_TCP_1 

access-list WAN_access_in remark Allow SMPP from X.X.X.X to UCA

access-list WAN_access_in extended permit tcp object-group X.X.X.X object-group UCA object-group SMPP 

access-list WAN_access_in remark Allow Gmail POP3  from ANY to ANY

access-list WAN_access_in extended permit tcp any any object-group Gmail-Pop3SMTP 

access-list WAN_access_in extended permit ip object-group X.X.X.X any 

access-list WAN_access_in extended permit ip object-group X.X.X.X any 

access-list WAN_access_in extended permit ip any object-group DNS 

access-list WAN_access_in remark Allow ANY from WAN to NS

access-list WAN_access_in extended permit ip any host X.X.X.X

access-list WAN_access_in remark Allow HTTP from WAN to XIAM

access-list WAN_access_in extended permit tcp any host X.X.X.X eq www 

access-list WAN_access_in remark Allow HTTPS from X.X.X.X to XIAM

access-list WAN_access_in extended permit tcp host X.X.X.X host X.X.X.X eq https 

access-list WAN_access_in extended permit ip host X.X.X.X any 

access-list WAN_access_in remark X.X.X.X from test environment XIR

access-list WAN_access_in extended permit ip host X.X.X.X any 

access-list Lonsyd_splitTunnelAcl extended permit ip 192.168.1.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list Lonsyd_splitTunnelAcl extended permit ip 192.168.7.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list Lonsyd_splitTunnelAcl extended permit ip 192.168.5.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list Lonsyd_splitTunnelAcl extended permit ip 10.0.1.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list Lonsyd_splitTunnelAcl extended permit ip 192.168.20.0 255.255.255.0 any 

access-list Lonsyd_splitTunnelAcl extended permit ip 192.168.2.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list Lonsyd_splitTunnelAcl extended permit ip 192.168.100.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list WAN_nat0_outbound extended permit ip any any 

access-list pingtraffic extended permit icmp any any echo-reply 

access-list Local_LAN_Access standard permit 192.168.7.0 255.255.255.0 

access-list Local_LAN_Access standard permit 192.168.1.0 255.255.255.0 

access-list Local_LAN_Access standard permit X.X.X.X 255.255.255.0 

access-list Local_LAN_Access standard permit 192.168.2.0 255.255.255.0 

access-list Local_LAN_Access standard permit 10.0.1.0 255.255.255.0 

access-list Local_LAN_Access standard permit 192.168.5.0 255.255.255.0 

access-list WAN_access_out extended permit ip any any 

access-list WAN_access_out_1 extended permit ip any any 

access-list Lonsyd_access_in extended permit ip any any 

access-list Lonsyd_access_in_1 extended permit tcp 192.168.100.0 255.255.255.0 192.168.1.0 255.255.255.0 eq smtp 

access-list Lonsyd_access_in_1 extended permit tcp 192.168.100.0 255.255.255.0 host Berlin eq smtp 

access-list Lonsyd_access_in_1 extended permit ip X.X.X.X 255.255.255.0 192.168.1.0 255.255.255.0 

access-list Lonsyd_access_in_1 extended permit icmp 192.168.100.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list Lonsyd_access_in_1 extended permit ip 192.168.5.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list Lonsyd_access_in_1 extended permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list Lonsyd_access_in_1 extended permit ip 10.0.1.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list Lonsyd_access_in_1 extended permit ip 192.168.20.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list Lonsyd_access_out extended permit ip any any 

access-list Lonsyd_nat0_outbound extended permit ip X.X.X.X 255.255.255.0 192.168.20.0 255.255.255.0 

access-list DMZ_access_out extended permit tcp 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 object-group Sql 

access-list DMZ_access_out extended permit tcp 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 object-group MSDTC 

access-list DMZ_access_out extended permit tcp 192.168.100.0 255.255.255.0 192.168.1.0 255.255.255.0 eq smtp 

access-list DMZ_access_out extended permit tcp 192.168.100.0 255.255.255.0 host Berlin eq smtp 

access-list DMZ_access_out remark Allow All traffic out

access-list DMZ_access_out extended permit ip 192.168.100.0 255.255.255.0 X.X.X.X 255.255.255.0 

access-list DMZ_access_out extended permit object-group TCPUDP any any eq domain 

access-list DMZ_access_out extended permit tcp 192.168.100.0 255.255.255.0 192.168.1.0 255.255.255.0 object-group RealVNC 

access-list DMZ_access_out extended permit tcp 192.168.100.0 255.255.255.0 192.168.1.0 255.255.255.0 eq www 

access-list DMZ_access_out extended permit ip 192.168.100.0 255.255.255.0 host MIAMI 

access-list DMZ_access_out extended permit ip 192.168.100.0 255.255.255.0 10.0.1.0 255.255.255.0 

access-list DMZ_access_out extended permit ip 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list DMZ_access_out extended permit ip 192.168.100.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list DMZ_access_in remark Allow All traffic in

access-list DMZ_access_in extended permit ip any any 

access-list Idscomms_access_in extended permit tcp 192.168.100.0 255.255.255.0 host Berlin eq smtp 

access-list Idscomms_access_in extended permit tcp 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 object-group MSDTC 

access-list Idscomms_access_in extended permit tcp 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 object-group Sql 

access-list Idscomms_access_in extended permit tcp host Berlin 192.168.5.0 255.255.255.0 eq smtp 

access-list Idscomms_access_in extended permit ip object-group IT 192.168.5.0 255.255.255.0 

access-list Idscomms_access_in extended permit ip 192.168.1.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list Idscomms_access_in extended permit ip X.X.X.X 255.255.255.0 192.168.5.0 255.255.255.0 

access-list Idscomms_access_in extended permit ip 192.168.100.0 255.255.255.0 host MIAMI 

access-list Idscomms_access_in extended permit ip 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list Idscomms_access_in extended permit ip 192.168.20.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list Idscomms_access_out extended permit ip any any 

access-list Idscomms_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list Idscomms_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.100.0 255.255.255.0 

access-list Idscomms_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 10.0.1.0 255.255.255.0 

access-list Idscomms_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.9.0 255.255.255.0 

access-list Idscomms_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.2.0 255.255.255.0 

access-list Idscomms_nat0_outbound extended permit ip 192.168.2.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list Idscomms_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list DMZ_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.5.0 255.255.255.0 

access-list DMZ_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.1.0 255.255.255.0 

access-list DMZ_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 10.0.1.0 255.255.255.0 

access-list DMZ_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.20.0 255.255.255.0 

access-list DMZ_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.0 

access-list DMZ_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.100.0 255.255.255.0 

pager lines 24

logging enable

logging monitor informational

logging asdm informational

mtu WAN 1500

mtu DMZ 1500

mtu Lonsyd 1500

mtu Idscomms 1500

mtu Failover 1500

ip local pool Lonsyd 192.168.20.220-192.168.20.239 mask 255.255.255.0

no failover

icmp unreachable rate-limit 1 burst-size 1

icmp permit any WAN

asdm image disk0:/asdm-61551.bin

no asdm history enable

arp timeout 14400

global (WAN) 101 interface

nat (WAN) 0 access-list WAN_nat0_outbound

nat (WAN) 101 192.168.1.0 255.255.255.0

nat (WAN) 101 192.168.5.0 255.255.255.0

nat (WAN) 101 192.168.20.0 255.255.255.0

nat (DMZ) 0 access-list DMZ_nat0_outbound

nat (Lonsyd) 0 access-list inside_nat0_outbound

nat (Lonsyd) 0 access-list Lonsyd_nat0_outbound outside

nat (Lonsyd) 101 10.0.1.0 255.255.255.0

nat (Lonsyd) 101 192.168.1.0 255.255.255.0

nat (Lonsyd) 101 192.168.5.0 255.255.255.0

nat (Lonsyd) 101 192.168.9.0 255.255.255.0

nat (Idscomms) 0 access-list Idscomms_nat0_outbound

nat (Idscomms) 101 192.168.5.0 255.255.255.0

static (Lonsyd,WAN) tcp interface smtp Berlin smtp netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.10 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.11 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.30 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.31 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.40 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.41 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.50 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.51 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.60 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.61 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.70 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.71 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.80 netmask 255.255.255.255 

static (DMZ,WAN)X.X.X.X 192.168.100.100 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.102 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.103 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.104 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.62 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X 192.168.100.81 netmask 255.255.255.255 

static (DMZ,WAN) X.X.X.X5 192.168.100.82 netmask 255.255.255.255 

static (Lonsyd,WAN) X.X.X.X 192.168.1.60 netmask 255.255.255.255 

access-group WAN_access_in in interface WAN

access-group WAN_access_out_1 out interface WAN

access-group DMZ_access_in in interface DMZ

access-group DMZ_access_out out interface DMZ

access-group Lonsyd_access_in_1 in interface Lonsyd

access-group Lonsyd_access_out out interface Lonsyd

access-group Idscomms_access_in in interface Idscomms

access-group Idscomms_access_out out interface Idscomms

route WAN 0.0.0.0 0.0.0.0 61.88.220.230 1

route Lonsyd 10.0.1.0 255.255.255.0 192.168.1.9 1

route Lonsyd 192.168.2.0 255.255.255.0 192.168.1.254 1

route Lonsyd 192.168.5.0 255.255.255.0 192.168.5.1 1

route Lonsyd 192.168.9.0 255.255.255.0 192.168.1.9 1

route Lonsyd 192.168.20.0 255.255.255.0 192.168.1.1 1

route Lonsyd 192.168.254.0 255.255.255.0 192.168.1.254 1

route WAN X.X.X.X 255.255.255.255 X.X.X.X 1

route WAN X.X.X.X 255.255.255.255 X.X.X.X 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.96 255.255.255.255 Lonsyd

http 192.168.7.96 255.255.255.255 Failover

http James 255.255.255.255 Lonsyd

http Justin 255.255.255.255 Lonsyd

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 

crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac 

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map WAN_dyn_map 20 set pfs 

crypto dynamic-map WAN_dyn_map 20 set transform-set ESP-3DES-SHA TRANS_ESP_3DES_SHA

crypto dynamic-map WAN_dyn_map 20 set security-association lifetime seconds 28800

crypto dynamic-map WAN_dyn_map 20 set security-association lifetime kilobytes 4608000

crypto dynamic-map WAN_dyn_map 40 set transform-set ESP-3DES-SHA

crypto dynamic-map WAN_dyn_map 40 set security-association lifetime seconds 28800

crypto dynamic-map WAN_dyn_map 40 set security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000

crypto map WAN_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map WAN_map interface WAN

crypto isakmp identity hostname 

crypto isakmp enable WAN

crypto isakmp policy 5

 authentication pre-share

 encryption 3des

 hash sha

 group 2

 lifetime 86400

crypto isakmp policy 10

 authentication pre-share

 encryption des

 hash sha

 group 2

 lifetime 86400

telnet Justin 255.255.255.255 Lonsyd

telnet 192.168.1.96 255.255.255.255 Lonsyd

telnet timeout 5

ssh 192.168.1.96 255.255.255.255 Lonsyd

ssh Justin 255.255.255.255 Lonsyd

ssh timeout 5

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

group-policy DfltGrpPolicy attributes

 vpn-simultaneous-logins 20

 vpn-idle-timeout none

 vpn-tunnel-protocol IPSec webvpn

 split-tunnel-network-list value Lonsyd_splitTunnelAcl

group-policy Lonsyd internal

group-policy Lonsyd attributes

 wins-server value 192.168.1.50

 dns-server value 192.168.1.50 192.168.1.51

 vpn-tunnel-protocol IPSec l2tp-ipsec webvpn

 split-tunnel-policy tunnelall

 split-tunnel-network-list value Lonsyd_splitTunnelAcl

 default-domain value X.X.X.X

group-policy IT internal

group-policy IT attributes

 wins-server value 192.168.1.50

 dns-server value 192.168.1.51 192.168.100.40

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value Lonsyd_splitTunnelAcl

group-policy IDS internal

group-policy IDS attributes

 wins-server value 192.168.1.50

 dns-server value 192.168.1.51

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value Lonsyd_splitTunnelAcl

 default-domain value X.X.X.X

username Bridget.Holland password muXnmHa1vFgxrC05 encrypted

username Bridget.Holland attributes

 vpn-group-policy IDS

username Brad.Cobbin password RB0OF.tZV3D9KWW5 encrypted

username Brad.Cobbin attributes

 vpn-group-policy Lonsyd

username Craig.Menzies password YAqVYzhw9k3slcvE encrypted

username Craig.Menzies attributes

 vpn-group-policy Lonsyd

username Paul.Willer password BOdoxbepVYaAXKwU encrypted

username Paul.Willer attributes

 vpn-group-policy Lonsyd

username Xiam password a2a.eAtEuRm2IOjO encrypted

username Xiam attributes

 vpn-group-policy Lonsyd

username Ralph.Silverman password KTIHccImQjL2zYUn encrypted

username Ralph.Silverman attributes

 vpn-group-policy IDS

username Jodie.Rose password FO4LjvrtgMiCkIRO encrypted

username Jodie.Rose attributes

 vpn-group-policy Lonsyd

username Adept password bNlTeqIeRzb.c4rw encrypted

username Adept attributes

 vpn-group-policy Lonsyd

username David.Hayes password jBAiXLr7okstop2/ encrypted

username David.Hayes attributes

 vpn-group-policy IDS

username Peter.Ryba password 4HZvv11vhoaixIIH encrypted

username Peter.Ryba attributes

 vpn-group-policy Lonsyd

username David.Simpson password akZqb9XlPtri1BRi encrypted

username David.Simpson attributes

 vpn-group-policy Lonsyd

username John.Gillett password 3bSGCpYt644Rs2Qm encrypted

username John.Gillett attributes

 vpn-group-policy Lonsyd

username WAIndustrial password jo6rw/AuhYAuocB/ encrypted

username WAIndustrial attributes

 vpn-group-policy Lonsyd

username Gary.Fitzhenry password 56MERiOzxp9CV0pl encrypted

username Gary.Fitzhenry attributes

 vpn-group-policy Lonsyd

username Mervette.Jalloul password .L.u9UfoUoxxfJxY encrypted

username Mervette.Jalloul attributes

 vpn-group-policy IDS

username Elizabeth.Fepuleai password 7NWXzQx5jjWjkDQp encrypted

username Elizabeth.Fepuleai attributes

 vpn-group-policy IDS

username Leon.Chilcott password EZDoMKQd4LXkoh1p encrypted

username Leon.Chilcott attributes

 vpn-group-policy Lonsyd

username Lee.Lynch password .o5DKQIM2S5woOJM encrypted

username Lee.Lynch attributes

 vpn-group-policy Lonsyd

username Elisa.Everett-Spring password 8qLyPpBKdTkUs87/ encrypted

username Elisa.Everett-Spring attributes

 vpn-group-policy IDS

username James.Delfino password Qfp6vLZ7NXi7kx7i encrypted

username James.Delfino attributes

 vpn-group-policy IDS

username Tony.Jones password 3bL0qpOmP75HnbUk encrypted

username Tony.Jones attributes

 vpn-group-policy Lonsyd

username Topo.Kristyono password h.ntWhe/paLTg0Ep encrypted

username Topo.Kristyono attributes

 vpn-group-policy IDS

username Tony.Ryba password EP5yMeRDMqilhC3o encrypted

username Tony.Ryba attributes

 vpn-group-policy Lonsyd

username Martin.Davies password .QOlx.Z8ayUpWdX0 encrypted

username Martin.Davies attributes

 vpn-group-policy Lonsyd

username Theepan.Thevathasan password UjVAPKJ3QWC/bsD9 encrypted

username Theepan.Thevathasan attributes

 vpn-group-policy IDS

username Con.Livissianis password 8MUjNAeem88nOs3N encrypted

username Con.Livissianis attributes

 vpn-group-policy Lonsyd

username Bob.Armstrong password EskyLNdq1v/YEdKp encrypted

username Bob.Armstrong attributes

 vpn-group-policy IDS

username Anthony.Rose password fGOe2lYYuPrrKOMw encrypted privilege 15

username Anthony.Rose attributes

 vpn-group-policy IT

 vpn-tunnel-protocol IPSec 

 vpn-framed-ip-address 192.168.20.69 255.255.255.0

username Optus password MBje5IxQQjoaQg3T encrypted

username Optus attributes

 vpn-group-policy Lonsyd

username Vicky.Levi password BXw0kdggerWbW4fs encrypted

username Vicky.Levi attributes

 vpn-group-policy Lonsyd

username Justin.Smith password jDKA.fCgomyvvxKS encrypted privilege 15

username Justin.Smith attributes

 vpn-group-policy IT

 vpn-framed-ip-address 192.168.20.13 255.255.255.0

username Julian.Sinclair password l9qao0bZGmiKr18G encrypted

username Julian.Sinclair attributes

 vpn-group-policy IDS

tunnel-group DefaultRAGroup general-attributes

 address-pool Lonsyd

tunnel-group DefaultRAGroup ipsec-attributes

 pre-shared-key *

tunnel-group Lonsyd type remote-access

tunnel-group Lonsyd general-attributes

 address-pool Lonsyd

 authorization-server-group LOCAL

 default-group-policy Lonsyd

tunnel-group Lonsyd ipsec-attributes

 pre-shared-key *

tunnel-group Lonsyd ppp-attributes

 authentication ms-chap-v2

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map global_policy

 class inspection_default

  inspect ftp 

  inspect h323 h225 

  inspect h323 ras 

  inspect rsh 

  inspect rtsp 

  inspect esmtp 

  inspect sqlnet 

  inspect skinny  

  inspect sunrpc 

  inspect xdmcp 

  inspect sip  

  inspect netbios 

  inspect tftp 

!

service-policy global_policy global

prompt hostname context 

Cryptochecksum:e03a1c6f594a7bbc0fd62edc1d71ed87

: end

Open in new window

0
Comment
Question by:justin_smith
  • 3
4 Comments
 
LVL 15

Accepted Solution

by:
bignewf earned 500 total points
ID: 24869583
Have you tried using IPSec over TCP  using port 10000?
you need to enable this on the asa:
asa(config)# isakmp ipsec-over-tcp port 10000

then on the vpn client under the transport tab check IPSEC over tcp

UDP port 500 is not used for IKE negotiations as it is in NAT-traversal, but TCP port 10000 is used instead

also try IPSEC over UDP anyway, which might work

you can disable NAT-T on the asa globally also



0
 

Author Comment

by:justin_smith
ID: 24874767
It looks like my ISP blocks UDP ports.

I enabled IPSEC over TCP and it worked. Thanks bignewf!

I did try that before but just on the client, i didnt know it needed to be enabled on the ASA.

What ports would IPSEC over UDP used? only 500?
0
 
LVL 15

Expert Comment

by:bignewf
ID: 24875285
UDP port 500 is used for IKE negotiations. Once the vpn client and asa discover they are capable of NAT - traversal and acknowledge NAT devices are between ASA and client, port 45000 UDP is used to complete tunnel SA negotiations

0
 
LVL 15

Expert Comment

by:bignewf
ID: 24875289
correction to above:  UDP 4500
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
Juniper VPN devices are a popular alternative to using Cisco products. Last year I needed to set up an international site-to-site VPN over the Internet, but the client had high security requirements -- FIPS 140. What and Why of FIPS 140 Federa…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now