Citrix HTTP to HTTPS Redirection

Hi guys, I have enabled HTTP to HTTPS redirection on my Citrix Web Interface servers.  Everything is ok when users connect from our internal network.  However, there's an issue when they try to connect from the internet.  An error message saying "Error: None of the configured Secure Gateway for Metaframe Presentation Server STAs are available".  Any idea?
dnomyar_2006Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amichaellCommented:
Have you configured your STA servers through Secure Gateway?
0
dnomyar_2006Author Commented:
Hi, I didn't do any change on STA.  In the DMZ Settings -> Secure Gateway Support, the STA list is set to the http://servername/scripts/CtxSTA.dll.  Should I set it to https://servername/scripts/CtxSTA.dll?
0
dnomyar_2006Author Commented:
Hello guys, any ideas? Thank you!
0
amichaellCommented:
STA runs over 80 (by default), so you'll want to keep to http rather than https for your STA settings.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.