Solved

Do the proxy exceptions work by IP address or URL?

Posted on 2009-07-16
3
1,719 Views
Last Modified: 2013-12-08
I'm having an issue in that using just the IP address (or subnet) in the proxy exceptions (Tools, Internet Options, Connections, LAN Settings) does not appear to work.
I've added the specific IP address, AND subnet but the traffic still goes to the proxy when I use the FQDN http://site.com instead. It's fine when I use the IP address in the address bar OR the site name in the exceptions.

The problem is that the full site name is huge and I'm concerned about the 255 character limit being hit too quickly. I am aware of the hack to up it to 1000 characters but I'm also aware of the performance hit this entails.

Could someone confirm for me that you MUST use the exact / wildcard of the address used in the address bar, and can't just put in the IP address?

I know it is not name resolution as I have put the site IP address in the HOSTS file and ensured that the correct IP is used.
0
Comment
Question by:Kieran_Burns
  • 2
3 Comments
 
LVL 29

Accepted Solution

by:
pwindell earned 500 total points
ID: 24869016
IE has always been a disaster in the way it chooses to (or chooses not to) send requests to a proxy
The exceptions box is not for URLs,...the SIte Name is not going to be "huge" because the URL is not part of the site name.
Use the FQDN or the IP#.  You may have to use both.
You're probably better off forgetting the whole idea and place the FQDN in the Intranet Zone (Advanced button).   For FQDNs use this format *.mysite.com.  For IP#s you might have to include the http:// or https://, but I would try it without that first.
At our place I throw the whole idea out and go with Proxy Autodetection via WPAD.  By using WPAD and including the Firewall Client on the workstations (no FWC on servers) the browser only requires the first checkbox to be enabled in the LAN Settings,..everything else can be blank.  I never have any of these types of problems anymore.
0
 
LVL 10

Author Comment

by:Kieran_Burns
ID: 24949735
Ultimately we've had to use partial names (with wildcards) it seems that IE will only accept what it sees in the address bar not what is sent.
Tried the suggested solution of using the zones - that didn't work either and WPAD is a non-starter as we have no access to the ISA Server.
0
 
LVL 10

Author Closing Comment

by:Kieran_Burns
ID: 31604148
Thanks for the help. You confirmed my worst fears :)
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now