GBIC Interface problem after IOS upgrade

Hi,

I have a 3560G Cisco switch that was running IOS version 'c3560-ipbase-mz.12.2-(35).SE5'. I wanted to use the IP SLA feature but this wasn't available in this version so last night I upgraded to version 'c3560-ipservicesk9-mz.12.2-(46).SE'.

This is where the problem is......in one of the GBIC ports I have a fibre link to another device and this was working fine prior to the upgrade. After the upgrade the link light on the port is not showing up. I have checked the fibre end-to-end and it is 100% OK, I have rebooted both devices, checked all the interfaces are configured correctly and changed ports however there is still no link.

I can see the red laser coming through the fibre so that is definately OK. I'm thinking this newer IOS version doesn't seem to like the GBIC's for some reason.

One other thing to note that may be relevant or not. I had a telnet session open to the switch with terminal monitor enabled and when I returned from rebooting the remote device and checking the fibre I had this message:

000061: *Mar  1 03:41:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface Gigabi
tEthernet0/27, changed state to up

indicating that the switch must have recognised something on the line

Any ideas what might be happening?

Thanks

Ally

ally0000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Istvan KalmarHead of IT Security Division Commented:
Hi,

what showng the following

show diag
sh inventory
sh env all
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ally0000Author Commented:
Got it sorted, I enabled auto-negotiation on the remote device (A wireless microwave link)

Cheers all
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.