Solved

Computer GPO not being applied to computers

Posted on 2009-07-16
11
408 Views
Last Modified: 2012-05-07
I am having problems applying computer based GPO's to computers in my domain. I want to set the setting on all computers when they boot up to wait for network connections before allowing user to log on. I have done it through a reg key which works fine, but through the GPO I have set this, along with slow link detection, and allow the different GPO's to run over slow link if detected.

I am looking for suggestions on how to get my gpo to apply to my computers at their each startup.  I have my GPO listed under my top level domain not on an OU, I also have the filtering set to authenticated users/& Domain Computers.

Any suggestions would be great.

Thanks


0
Comment
Question by:HRSBTech
11 Comments
 
LVL 7

Accepted Solution

by:
kumarnirmal earned 250 total points
ID: 24868190
You can try adding the startup script with the following command.

gpupdate /force

This will force to apply the GPO every time the computer reboot.

0
 
LVL 10

Expert Comment

by:Alan_White
ID: 24868205
0
 

Author Comment

by:HRSBTech
ID: 24868211
I have run gpudate /force 100 times and no luck at all, I can put this in my computer logon scrip?

Thanks
0
 
LVL 7

Expert Comment

by:kumarnirmal
ID: 24868232
Logon script only run when a user log on to a computer you have to add the script in the startup script in the "Computer Configuration ->Windows Settings -Scripts - Startup"
0
 

Author Comment

by:HRSBTech
ID: 24868253
I just created a script in the startup called update.bat this is what it looks like.
gpudate /force

Open in new window

0
 
LVL 7

Expert Comment

by:kumarnirmal
ID: 24868269
Add this script to the startup script of GPO and link the GPO where computers located. check the result using rsop.msc
0
 

Author Comment

by:HRSBTech
ID: 24868314
I did this and the update.bat file is listed in the rsop.msc startup scrip. When I turn on the computers it should say waiting for network connections, and will force process all GPO's even if network is not completed setting up, it will wait and finisht he GPO's until they are done. All my settings are listed in the rsop.msc

We use deepfreeze here meaning when I restart the computer it goes back to the previous setup I have created for that computer, you can change whatever and restart it's back to normal. I have made many gpo's in the past that have worked this one doens't seemto be working.

Is there a way that I can run a reg key when the computer turns on. I have the registry settings I need for this to work as well.

0
 
LVL 7

Expert Comment

by:kumarnirmal
ID: 24868340
0
 
LVL 7

Expert Comment

by:kumarnirmal
ID: 24868452
0
 
LVL 10

Expert Comment

by:remmett70
ID: 24868848
How many GPO's are assigned to the OU you are implementing this policy on.  Is there a chance that there is another policy with priority that has conflicting settings?
0
 
LVL 27

Assisted Solution

by:bluntTony
bluntTony earned 250 total points
ID: 24868931
SO you have some software which reverts your PC back to it's original config before the GPO was applied? I think that's your problem.

Your trying to set a policy to force the machine to wait for the network and apply all policies, but on your first reboot that setting isn't applied, meaning that it isn't applying all policies on this reboot. Unfortunately, the setting you are actually trying to apply is one of those settings that cannot immediately refreshed in the background.

(I assume you mean : Computer Config | Admin Templates | System | Logon | "Always wait for the network at computer startup and logon")

For this setting to take it hold it can actually take a couple of reboots, because this setting could being applied in the background, and applied on the next refresh. The problem is that you're reverting the machine back to it's original config when you next reboot putting you back to square one (I hope that makes sense!)

This is also why I think GPUPDATE isn't working - because the policy can't be applied during a user session and has to wait for the next reboot (which effectively never happens).

If what I'm saying is correct, I'm afraid there is not a lot you can do about this. You could write a startup script to set the relevant reg key, but I don't think even this would necessarily force all GPOs to apply on that same startup cycle.

You can use vbscript to write a reg value write easily (http://msdn.microsoft.com/en-us/library/yfdfhz1b(VS.85).aspx)


0

Join & Write a Comment

Mapping Drives using Group policy preferences Are you still using old scripts to map your network drives if so this article will show you how to get away for old scripts and move toward Group Policy Preference for mapping them. First things f…
Introduction You may have a need to setup a group of users to allow local administrative access on workstations.  In a domain environment this can easily be achieved with Restricted Groups and Group Policies. This article will demonstrate how to…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now