Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1633
  • Last Modified:

Unable to ping Windows XP SP3 machine

I have Windows XP machine with Service Pack 3 on my domain that I'm not able to ping by DNS name or IP address, however it is connected and able to access domain resources.

The firewall is not enabled. There are no network security protocols such as NAC in place either.

We need to be able connect via name or IP for our remote administration needs.

I have searched but have not been able to find any similar kind of issue. I'm leaving this at 500 points.
0
lffit
Asked:
lffit
  • 10
  • 3
  • 3
  • +4
1 Solution
 
soodsunilCommented:
just disable your windows firewal in services.msc will solve your query
0
 
flob9Commented:
soodsunil> he said firewall was not enabled

Is TCP/IP working ? ("telnet theip 135" or other open port)
0
 
Ninjaguy900Commented:
Are they on the same subnet ??
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
lffitAuthor Commented:
Flob9> Does telnet need to be enabled on the remote system for this to work? If not, then I did not get a response on port 135.
If telnet needs to be enabled, I may have to wait until this evening or tomorrow to start the service to avoid interrupting the user.
0
 
flob9Commented:
port 135 is usually opened on windows box, did you get "connect failed" after 1/2 secondes or something else ?
0
 
lffitAuthor Commented:
It seemed to take that standard telnet timeout - 10 to 15 seconds
0
 
lffitAuthor Commented:
Ninjaguy900> They are on different subnets but routing is working correctly between subnets for other systems. I can connect to other systems on the same subnet even though my subnet is different.
0
 
flob9Commented:
This really looks like a firewall problem. Did you check third party firewall applications on this computer ?
You can also try a ping from a machine on the same subnet.
0
 
Ninjaguy900Commented:
As flob9
try ping from a machine on the same subnet

have you tried ipconfig /flushdns on your machine?
Can the machine ping yours OK ?

0
 
lffitAuthor Commented:
flob9, ninjaguy99>
I am not able to ping from another machine on the same subnet either. I am able to ping my machine from the problem machine.
On the problem machine I did
ipconfig /renew
ipconfig /flushdns
ipconfig /registerdns
Verified the firewall service is not running.
As I mentioned this is Windows Xp Pro SP3
0
 
Bobby_Q_DoeCommented:
I have this same issue - it happened after installing service pack 3. prior to the install i was able to rdp, ping, etc. now i can not connect in anyway. the system has no problems accessing rescources. the windows firewall service is disabled, there is no third party firewall software.
0
 
mohanarangamCommented:

what is the error message you are getting for ping. check the eventlogs and security logs for more information


have a look at this..

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_24453125.html?sfQueryTermInfo=1+24323148
0
 
lffitAuthor Commented:
It just times out. No host unreachable errors. No security errors on the problem computer.
0
 
mohanarangamCommented:
Try Tracert command. If the machine is connected via a Managed switch, then try to ping the machine from the network switch. If possible move the machine physically to different network switch without any VLAN and try.
0
 
lffitAuthor Commented:
mohanarangham>
Tracert resolves the name correctly though the responses actually time out. We don't have an option of moving this system to an unmanaged or switch without a VLAN. As stated earlier I am able to ping other computers on the same segment without issue, even other machines with service pack 3. The switch detects the connection, but there is no ping response. Is there a local IMCP setting in Windows (even with the firewall disabled) that I can check?
0
 
mohanarangamCommented:
In order to disable/enable ICMP redirect on Windows computers, you need to alter the following key: HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Services\\Tcpip\\Parameters - by setting the EnableICMPRedirect entry to 0 (in most cases it will set to active - 1 by default). You can use remote registry to check this settings
0
 
lffitAuthor Commented:
mohanarangham>
Sorry for delayed response. We are shorter handed than usual. I checked the registry (remote registry doesn't work either) and ICMP is enabled as you describe above. I'm beginning to think we may need to reimage this machine is which is otherwise ok.
0
 
xpertoPCCommented:
Try this reg file and reboot, you are using Remote Desktop, Radmin or what program?

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService]
"DisplayName"="Servicios de Terminal Server"
"Start"=dword:00000003

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Terminal Server]
"fDenyTSConnections"=dword:00000000

rem Habilitar escritorio remoto en propiedades de mi PC
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server]
"fDenyTSConnections"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp]
"PortNumber"=dword:00000d3d

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server]
"fSingleSessionPerUser"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SharedAccess\Epoch]
"Epoch"=dword:00000072

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch]
"Epoch"=dword:00000072

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts\List]
"3389:TCP"="3389:TCP:*:Enabled:@xpsp2res.dll,-22009"
0
 
lffitAuthor Commented:
xpert0PC>
I will try this after hours. We use Remote Desktop, SMS Remote Tools and Radmin.
0
 
xpertoPCCommented:
The computers are on the same network?, i mean if they are not you should check your router port forwarding settings for that computer and that ip or mac address.
0
 
xpertoPCCommented:
Hello lffit did it work?
0
 
lffitAuthor Commented:
xpertoPC> I imported your registry changes with the first key change removed "DisplayName"="Servicios de Terminal Server", (since we're an english install and we don't really use TS or RDP on desktops) and it worked!. I am marking this as the solution. Thank you so much!
0
 
lffitAuthor Commented:
This worked first time. Warning: you need to reboot before it takes affect.  I am going to save it with my other registry hacks in case it happens on another system
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 10
  • 3
  • 3
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now