ePO Agent 3.6.0 to 4.0.0 Upgrade Across Network

I have recently upgraded our ePolicy server from Version 3.6.0 to version 4.0.0 (Build 1298). The majority of our XP clients have McAfee 8.0 installed with ePO agent 3.6. These clients are no longer updating, so I want to upgrade the ePO agent from version 3.6.0 to version 4.0.0 (Build 1444), but I coming across a number of issues:

- ePO is no longer syncing correctly with active directory (The AD sync jobs complete successfully, but when browsing the ePO AD tree copy, the correct machines are not in each OU.
- I've created the ePO 4.0.0 framepkg.exe, and attempted to roll this out via a >>Computer Configuration>>Windows settings>>Scripts>>Startup>framepkg_Rollout_Batch_File.bat

:EPO4
IF EXIST C:\EPO4 THEN GOTO EOF
MD c:\EPO4
xcopy \\MyAVServer\ePOAgentShare\framepkg_UPD.exe c:\EPO4
cd c:\EPO4
framepkg_UPD.exe /FORCEINSTALL /INSTALL=AGENT /SILENT
:EOF

BUT this script fails to upgrade the current ePO agents on our XP client machines...


Event Type:	Error
Event Source:	MsiInstaller
Event Category:	None
Event ID:	1013
Date:		15/07/2009
Time:		16:20:54
User:		NT AUTHORITY\SYSTEM
Computer:	IT146
Description:
Product: McAfee Agent -- The specified sitelist is invalid. McAfee Agent Setup will not continue.
 
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 7b 46 42 38 32 44 45 46   {FB82DEF
0008: 37 2d 37 38 31 46 2d 34   7-781F-4
0010: 46 34 35 2d 39 42 36 44   F45-9B6D
0018: 2d 31 42 36 37 44 46 33   -1B67DF3
0020: 30 34 41 44 41 7d         04ADA}

Open in new window

LVL 1
cpadmAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

younghvCommented:
I used to use "PSEXEC" from SysInternals (now on the MS site) for remote work when ePO failed.

I don't think you need to use xcopy, but I'm going to ask our resident McAfee dude to check this out.
0
legalsrlCommented:
Sorry I'm late guys, but it's the Summer Holidays here.....

Firstly, you really don't want to be rolling out the client this way.....

You want to be deploying the agent from within the AD Synch Task.....you need to establish what's going on here btw

Also, you need to create an ePO report that shows all the machines that have not checked in within 72 hours

Once you've done that, you can create a server automation task to run every day that will run the report (above) and then deploy agents to the machines that haven't checked in.....

I know I've made it sound incredibly easy, and I appreciate that it might not be, but let me know what else you need and I'll guide you in the right way

Cheers
Si

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.