Insufficient Resources to satisfy HA failover on cluster

Hi All,

I've been using ESXi 3.5 for a while now and have recently purchased vCentre Server for management using HA, DRS, etc

I have the following error on my cluster with three hosts:
Insufficient resources to satisfy HA fallover level on cluster
Unable to contact a primary HA agent in cluster

Can I assume this is down to memory in the hosts?

vCentre server is new to me and I'm doing my training in two weeks but in the meantime I would like to try and fix this problem.

HOST 1: (used for testing)

4 CPU's x 2.133Ghz
4GB Ram
1 Virtual machine

HOST 2: (Secondary host)
4 CPU's x 2.204Ghz
8GB Ram
1 Virtual machine

HOST 3: (Primary host)
8 CPU's x 2Ghz
20GB Ram
5 Virtual machines

Any help appreciated with regards to my existing setup. The plan is to upgrade the secondary host with more memory and storage so can vmotion between the two hosts.
Mr_OCDAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

65tdRetiredCommented:
I suspect you've nailed it, memory resources are short on the other nodes.
Could try reducing the number of guests that are to included in the HA policy.
Edit settings of the cluster.
0
Mr_OCDAuthor Commented:
Ok more memory is on the way for the secondary host to bump it up to 16GB. But I have added a secondary management console and this seems to have resolved the problem on two of the hosts.

What I want to do next is use Vmotion to move a couple of VM's on to the secondary host so my eggs arent all in one basket so to speak!

If I go to migrate it says: 'vmotion is not enabled on this host' ... the license section says 'not used'?

Cheers for help!



0
TRFryeCommented:
Are you using memory reservations?  You may want to reduce  the  the amount of memory reserved for the VM's until you get the extra memory installed.

What hardware platform are you running the on?  Stand alone servers, blade center, etc? Verify that your bios level can support the additional memory.  If stand alone, shouldn't be a problem.  If bladecenter, you may need to update.

What version of ESX server are you on?  Might be a good time to go to 3.5 release 4.

Have you setup the vKernel switch port for vMotion?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Mr_OCDAuthor Commented:
No we arent using memory reservations. How would I do this? - the new memory is sat on my desk now so will be done this evening.

We are using HP Proliant DL360 / DL385 standalone servers.. the test / lab host is a DELL Poweredge.

We are using ESXi 3.5 release 4.

I'm still experimenting with the setup for vmotion but both hosts that say HA configured correctly have the following:

vswitch0
Internal LAN
Management Network

vswitch1
Vmotion
Management Network 2

0
Mr_OCDAuthor Commented:
Ok updated:

HOST 1: (used for testing)

4 CPU's x 2.133Ghz
4GB Ram
1 Virtual machine

HOST 2: (Secondary host)
4 CPU's x 2.204Ghz
16GB Ram
1 Virtual machine

HOST 3: (Primary host)
8 CPU's x 2Ghz
20GB Ram
5 Virtual machines

I'm currently going through the VM's as I've been a bit generous with memory on some of them.
0
65tdRetiredCommented:
To enable vmotion, select the vmkernal vswitch properties under the host -> networking, select  the vmkrnal, edit select the enable vmotion check box.
Needs to be done on each host.
0
Mr_OCDAuthor Commented:
Great stuff - thanks!!

I have got rid of the error message now for insufficient resources.... and now have one last message to kill off:

Host currently has no management network redundacy?
0
65tdRetiredCommented:
Need a second nic on the service console vswitch or or second connection to the network.


network.JPG
0
Mr_OCDAuthor Commented:
The host giving trouble has three nics...

Two are connected to the network to the same LAN and one is for DMZ (external)


NIC.docx
0
Mr_OCDAuthor Commented:
All sorted :) - Thanks for help people...

You need to assign spare NIC to Management / Vmotion network switch
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.