Exchange Error 414

I have been working on a Blackberry problem where we have been getting errors replying and forwarding emails for over 2 weeks now where after countless hours RIM finally got back to me and said that they checked their server log files and our server is sending them an Error 414 URI is too long.  Does anyone have any idea what this error is and how to correct it.  This is on a SBS 2003 server WITHOUT Blackberry Enterprise Server, just BIS.
LVL 1
waytronAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fnichelsonCommented:
0
waytronAuthor Commented:
Thanks fnichelson, I ran across this same link.  But I don't understand what it means or how or what is causing it or how to correct it?
0
fnichelsonCommented:
Can you provide more info as to what your doing thats producing the error.  Who is doing the rely/forwarding, whats its being forward to?  

A little bit of background info would be helpful.

Thanks,
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

waytronAuthor Commented:
We have six blackberry users using 3 different cell phone carriers (ATT, Verizon and Sprint).  We also have different Blackberry Models.  We can all send and receive emails just fine.  We are all getting Red X errors (Message Included and Invalid Address) almost all of the time when replying and forwarding emails from our Blackberry.  Not every time but most of the time and it is most often when forwarding an email with an attachment. (any size).  Blackberry support has reset accounts, deleted Service books, replaced handheld units, updated software and then they think they have it fixed for about an hour and then the problem just comes back again.  Finally after more than 2  weeks of this, they came back to me and said the problem was on our server and their server logs have reported this error.

Logs from serevr: LOG_SEARCHED__ /var/bis/log/bda/bdaproxy.20090712_1900.gz [bis-na-bda329] __LOG_SEARCHED__ /var/bis/log/bda/bdaproxy [bis-na-bda329] 19:20:03.679 07/12 [ERR] [BJT[244];bda4730633] PassThruResourc Received unexpected response from server: 414 [bis-na-bda329]  
 
 
Resolution
 
Error Message: HTTP 414 - Request - URI Too Long
http://support.microsoft.com/kb/248061

 
Everything had been working just fine for months until a few weeks ago.  I  have installed all updates on the server, scan for viruses and malware and Uninstalled Norton Corporate Antivirus.  Error logs do not show any problems.
0
fnichelsonCommented:
thanks, thats most helpful.  Its my understanding that Blackberry Enterprise Server is free up to a limited number of cell users.  Something to look at which I feel you may already have but I thought I would bring it up.

Do you use the Blackberry Desktop Manager?

Try this if you can

Delete the Desktop [CMIME] service book on the BlackBerry smartphone.
Connect the BlackBerry smartphone to the BlackBerry Desktop Manager.
When prompted, generate a new encryption key.
Try to forward the email message again.

Can you test this, copy the original email message body and paste it into a newly created email message to be sent.

0
waytronAuthor Commented:
I am contemplating the Blackberry Enterprise Server router however I am not sure if it will run on SBS 2003.  Also, I did not see anything about a free version?
No, none of use use Blackberry Desktop Manager.  However the service books have been deleted several times now over the past few weeks by BB Support.
0
fnichelsonCommented:
You didnt have to create any security groups for BIS?  

Are you seeing any errors in your Exchange servers event logs?

If you do go with BES, look at this.
http://www.blackberryforums.com.au/forums/microsoft-exchange/281-bes-sbs-2003-a.html

I think your right about BES being free now.  I think we were getting it free when we buy the Blackberrys from Sprint.  I'll ask our engineer next week.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
waytronAuthor Commented:
We did not change anything on the server at anytime for the Blackberries.  Just setup email on the Balckberry by giving it the email address and password and nothing else (no server or pop info).  The Blackberry just did the rest.  I do not see anything in the Log files that relates or corrosponds to the errors on the Blackberry.
I am starting to think that BES is the only way to go at this point????
0
waytronAuthor Commented:
We have decided to go to outside hosting with someone who offers BES.  Thanks for all your help.
0
waytronAuthor Commented:
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.