Solved

cannot access xp share folders through vista

Posted on 2009-07-16
52
552 Views
Last Modified: 2012-05-07
hi,

i'm trying to setup a network between 2 home computers, an xp machine and vista machine.  in the xp machine, the d drive is set to allow sharing.  both computers are in same network (eg. 192.168.3.xxx).  the vista machine can see the d drive of xp machine but when trying to open the xp d drive gives this error message:

\\...\... Files is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access  permissions.  

What am i doing wrong that i can't access the files in xp drive?  thx.
0
Comment
Question by:skip1000
  • 20
  • 16
  • 5
  • +3
52 Comments
 
LVL 59

Assisted Solution

by:LeeTutor
LeeTutor earned 50 total points
ID: 24870452
Have you downloaded and installed the LLTD (Link Layer Topology Discovery Responder) on the XP machines?  Without that, the Vista machines will not see the XP machines in the View full map link of Network & Sharing Center:

http://www.microsoft.com/downloads/details.aspx?familyid=4F01A31D-EE46-481E-BA11-37F485FA34EA&displaylang=en

Same workgroup for all pcs?  Actually sharing something, rather than just file sharing turned on?  Same users and passwords entered on all pcs?  Network discovery on?

You might be interested in looking at this question which I asked not long ago, when I was having trouble setting up my home network with XP machines and Vista in it.  It mentions all of the things needed for a wireless network with XP and Vista in it:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_Vista/Q_22772074.html

In setting up my home network, I found I had to turn off the firewalls temporarily before trying to see the Vista machine in the XP My Network Places, then turn the firewall back on once it succeeded.  See this page:

http://www.lockergnome.com/nexus/blade/2007/04/09/vista-networking-problems-try-this/

The following page has a quite good treatment of File and Printer Sharing in Vista, complete with screenshots:

http://www.microsoft.com/technet/network/evaluate/vista_fp.mspx
File and Printer Sharing in Windows Vista

Another good article:

http://www.howtonetworking.com/vista/sharingfolders.htm
How to share files from a folder on Windows Vista


0
 

Author Comment

by:skip1000
ID: 24870473
interestingly, i can set up the c drive on vista machine to share and the xp machine could see the files on vista machine, but not vice versa.  i even turned off anti-virus, firewalls on xp machine and still can't share files.
0
 
LVL 5

Assisted Solution

by:Honez
Honez earned 25 total points
ID: 24870526
on the XP machine check the share permissions
click on the permissions button.  You will see the everyone group in the share permissions group.  Often times the Anonomous group is not included in the everyone group, so, since this is not a domain, add the Anonomous group and grant the read permission.

or if you are trying to map the drive, choose to use a different credential (username and password)  Use the username and password of the XP machine when promted to connect to the share.
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24870877
Hi, you may have to disable simple file sharing on the XP box so you can give everyone full control (or modify, read, etc) for the security on the files for the everyone group to work.  

On the XP box, open my computer, click Tool, folder options, click the view tab, scroll to the bottom and uncheck Use simple file sharing.  Click ok all the way out.  Now, goto the share on XP, click on the security tab and add in the everyone group and the anonymous user.  See if this helps you out.

Another thing you can do is setup IDENTICAL user accounts (username and password) on BOTH computers, login as that user on both machines (this can be automatic if it is the only user setup in control panel, user accounts) and add that user account to the share or just leave it as everyone.

HTH
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 24871813
Do you have FAT32 or NTFS
in the XP services section, do you enable sharing, network connections, RPC
Make sure that these services are running also on XP
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24871821
Yes, forgot to mention that.  Thanks HB!
0
 
LVL 3

Expert Comment

by:mojopojo
ID: 24874324
On the Vista PC: Control Pannel > Network Sharing Center

Is "Network Discovery" and "File Sharing" turned on?


Untitled.jpg
0
 
LVL 3

Expert Comment

by:mojopojo
ID: 24874328
If they are in the same work group, that should do it.

-MP
0
 
LVL 3

Expert Comment

by:mojopojo
ID: 24874334
Oh yea... also turn on "Public Folder Sharing" as that is what you are tryiing to share.

0
 
LVL 20

Expert Comment

by:MightySW
ID: 24874362
Lee covered all of that.
0
 
LVL 3

Expert Comment

by:mojopojo
ID: 24874445
Sorry I rushed in. It's been a long week. Yea, I just read it all.
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24874467
I feel your pain bro.
0
 

Author Comment

by:skip1000
ID: 24875945
none of the stuff above works for me.  reiterating my question:
vista CANNOT access xp shared drive.
xp CAN access vista shared drive.

i don't believe i need to make any adjustments w/ the vista machine if xp machine can already access vista drive.

was going to add LLTD from the link above but was told that i already have it.
added anonymous logon user w/ read permission
xp machine has rpc running.
both machine has same user name and password.
they both belong to same workgroup.

one machine is address 192.168.3.1(xp) and other one is 192.168.3.2(vista) and to access xp machine, i just type \\192.168.3.1.  vista can see the name of the xp shares, but can't access (or get dir info) the share drive.  vista can ping the xp computer.

thx.

0
 

Author Comment

by:skip1000
ID: 24877638
btw, both machines are ntfs
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 24877703
in the share folder for the XP , do you have permissions for users?!~
0
 

Author Comment

by:skip1000
ID: 24877787
granted read acces for the users:
anonymous logon
everyone
guest
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 24878778
give the write access also and try
0
 

Author Comment

by:skip1000
ID: 24878885
nope, didn't work.  gave full control to all 3 users from above.
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 24878944
try this:
go to  my documents, >tools> Folder Options > Then scroll down and use Simple File Sharing
0
 

Author Comment

by:skip1000
ID: 24878999
started w/ simple when i opened tix, so that didn't work either.
0
 
LVL 17

Expert Comment

by:houssam_ballout
ID: 24879110
Do you have windows enabled firewall running?
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879252
No he doesn't have the FW enabled.

Did you try what I recommended?
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879334
Hi, goto the XP machine and enable Netbios over TCP/IP by right clicking on my network places, right click on your adapter and click properties, double click on TCP/IP and select the WINS tab.  Select Enable NetBIONS over TCP/IP.

HTH
0
 

Author Comment

by:skip1000
ID: 24879335
hi mightysw,
tried ur part too, w/ simple sharing disabled and both machines have same user name.
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879341
see post above, just above your last
0
 

Author Comment

by:skip1000
ID: 24879401
the netbios over tcpip didn't work either. thx.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 20

Expert Comment

by:MightySW
ID: 24879420
Do you have norton or something else running on EITHER machine?
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879442
The reason that I am asking is that other software on either machine may be blocking responses on ports: 137, 138, 139, and 445
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879478
I know that you already said that you were told that LLTD installed, by who or what did you see this?

Was it when you tried to install it?

If not then install it:

http://www.microsoft.com/downloads/details.aspx?familyid=4F01A31D-EE46-481E-BA11-37F485FA34EA&displaylang=en

0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879572
zone alarm on either PC????
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879573
Norton?
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879595
What type of switch are you using?  Is it a broadband router? Are you handing out IP's via DHCP?  Can you stop DHCP and make the IP's static?  
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24879626
Ok, if none of the above has sparked ANY ideas.  See if you can share a folder on the XP box RIGHT under the root of C:  So like C:\Temp with everyone, full control.  Can you see it with the Vista box?

If you can't then reboot both.  

See if you can see anything.
0
 
LVL 5

Expert Comment

by:Honez
ID: 24884421
You can share XP files to vista.

Try mapping the drive, BUT in the map drive wizard before you press enter, click the "different user name link"  At first, you can try just the username and password of a user account found on the XP box, if that doesnt work try the username is the format: XPCOMPUTERNAME\XPUSERNAME then enter the password and see if the map will connect.  I think that it is defaulting to the guest account credentials to connect the share.

either/or, I feel this is a permissions issue.
0
 

Author Comment

by:skip1000
ID: 24900060
tried granting permission on c b4 and didn't work.  no norton or zone alarm.  addresses are static, assigned by me.  network is wired 10bt cable from pc to pc.  tried to install lltd and was told that i already have it on machine.  what is name of service called and i'll check to see if it's running.  does lltd need to be running on vista machine? thx.
0
 

Author Comment

by:skip1000
ID: 24900063
btw, no switch is involved
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 24903428
LLTD is already on Vista; there is no service connected with it, as far as I know.  Also, LLTD really only ensures that the XP machine shows up in the Vista "view full map".
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24905262
Hi, you said, "network is wired 10bt cable from pc to pc"

Is it a cross over cable?
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24905317
How long is the drop?  Is it a 'straight through cable' (Pin to Pin) or one that you bought from the store... Pins 1&2, 3&6 are pairs?  (this would be the correct way).  If you are running a straight through (pin to pin, 1to1, 2to2, 3to3 etc) then your distance, if over 15 feet could be an issue.  You can test this by dropping the speed on the NIC's down to 10 Mbps Half Duplex on both machines and get a link.  BTW, you do not need a gateway on either PC if all you are doing is communicating between them.  

Also get rid of IPv6 from the Vista machine.
0
 

Author Comment

by:skip1000
ID: 24908552
cable not crossover.  length of cable 2m.  got rid of ipv6 from vista.  removed all gateways and still did not work.  how do i drop nics to 10mbps?  thx.
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24909170
If there is NO switch or hub then the cable HAS to be a cross over cable.  I don't see how it is even working in one direction without links on the NICs.  Do you have link lights on the NIC's?

Also, to slow down the speed (in XP, and similar in Vista), goto network properties, NIC properties, click configure and then click the advanced tab, click on Link Speed and Duplex and set both of the machines to the same speed.  Try 10 full and then bump it up to 100 full if 10 works.

HTH
0
 
LVL 5

Expert Comment

by:Honez
ID: 24913935
Add the guest account to the share permission.
0
 

Author Comment

by:skip1000
ID: 24914801
already added guest and gave full control
0
 
LVL 5

Expert Comment

by:Honez
ID: 24916255
I know this has already been mentioned I just want to ensure we are all on the same page:

Open Mycomputer....Tools...FOLDER OPTIONS...VIEW.Scroll down and Click on Use simple file sharing.

My main concern is that we all are interpreting this the same.
0
 
LVL 20

Expert Comment

by:MightySW
ID: 24916274
This has already been discussed.  

Skip, could you please answer the subsequent questions to your 'how do I drop Nics speed' post.

Thanks
0
 

Author Comment

by:skip1000
ID: 24928878
hi mightysw,

used crossover and dropped to 10Mbps and still same issue.  can't see link lights bc they're laptops.  but ping looked normal.  i've used normal cables (as well as crossover) for this type of 2 xp computer network in the past and they've both worked.  seemed xp can determine from cable.  thx.
0
 
LVL 20

Assisted Solution

by:MightySW
MightySW earned 175 total points
ID: 24928983
Do you have the power settings on the laptops set so that if they are unplugged that the links on the network interfaces disable themselves?  This will be somewhere in the control panel, either under power options or under the NIC controller/driver/application that the laptop has installed.  Something like Broadcom network utilities.  

Also, have you tried to connect these guys up to a switch or a hub to see if they worked that way?  I would beg, borrow to get one and see if that allows links and shows connectivity from laptop to laptop.  

If pings work, how about start, and then run, and then then \\IP_of_remote computer  Hit enter.

Does it show a share at all on the XP and Vista machines?  If so then we are definitely looking at a compatibility issue.

Also, this may seem silly, but are we certain that the IP's are different on both computers (the subnet mask is the same), and the gateway (if you have one) is correct?  You really don't need a gateway for machine to machine.  Also, the computer names are different?

Thanks
0
 
LVL 5

Expert Comment

by:Honez
ID: 24929555
On the XP machine, is the server service started?
0
 
LVL 20

Expert Comment

by:MightySW
ID: 25079830
Hi, Any Status on this?


Thanks
0
 

Author Comment

by:skip1000
ID: 25088639
sorry on holidays overseas atm.

i don't believe that the nics are disabled since xp can have read write on vista machine.  running \\IP_of_remote computer (from vista to xp) will only show the share name on the xp but no further access is allowed. ping works normally from both machines.  no gateways and same subnet (192.168.3.x). computer names are different.  i won't be able to try the hub part until i get back from my holidays about a week later.  thx.
0
 

Accepted Solution

by:
skip1000 earned 0 total points
ID: 25141289
Ok, finally it works now.  Mainly it's my bad bc I omitted one part of the original error msg:

\\...\... Files is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access  permissions.
Note the following line that was omitted:
"not enough server storage is available to process this command"

I finally caught on that the part I posted originally is a general error msg used in Vista for all network errors (i'm still new to Vista).  It's the next sentence that really matters (eg. "The specified network name is no longer available).

So looking up this error, I got this page:
http://www.intelliadmin.com/blog/2007/04/not-enough-server-storage-is-available.html

Quoting this link:
-----------------------------------------------------------------------------------------------------------
"A registry change needs to be made to accommodate bad behaving programs. It all comes down to a registry key named IRPStackSize.

In Windows 2000 and in Windows Server 2003, the default value of the IRPStackSize parameter is 15. The range is from 11 (0xb hexadecimal) through 32 (0x20 hexadecimal).

If the subkey is not present, you can use Registry Editor to add the subkey. To do this, follow these steps:

1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
3. Click Edit, point to New, and then click DWORD Value.
4. Type IRPStackSize, and then press ENTER to name the value.

Note Type IRPStackSize exactly as it is displayed. This is case sensitive.

5. Click Edit, and then click Modify.
6. In the Data Value box, type 30, and then click OK.

You are probably going to need a reboot for this to take effect."
-----------------------------------------------------------------------------------------------------

anyway, i added an IRPStackSize and set value to 18 hex (randomly), reboot and it worked.  also, netbios wasn't needed and both straight thru and crossover cable worked from pc to pc (no switch necessary).

thx for all the help.:)
0
 

Author Comment

by:skip1000
ID: 25141468
btw, only user everyone in xp share is adequate for sharing.  guest and anonymous weren't required in my XP share setup.
0

Featured Post

Are end users causing IT problems again?

You’ve taken the time to design and update all your end user’s email signatures, only to find out they’re messing up the HTML, changing the font and ruining the imagery. What can you do to prevent this? Find out how you can save your signatures from end users today.

Join & Write a Comment

I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now