Solved

Mulitple public IPs on ASA5505

Posted on 2009-07-16
20
607 Views
Last Modified: 2012-05-07
I have a ASA 5505 (Base License) with a web server behind it and it's working great with a single IP one the WAN interface. Now I have a need to add an additional IP to the WAN in order to accomadate a second secure certificate needed for this web server. The webserver is hosting mulitple domains and previously only one domain needed a ssl certificate. Now another one does :(  I've been told that a each SSL certificate needs it own external IP so...
Will my 5505 with the base license allow me to add another external IP to my wan interface and forward the  appropropiate traffic to this webserver?
0
Comment
Question by:huntleyj
  • 10
  • 6
  • 3
  • +1
20 Comments
 
LVL 7

Expert Comment

by:clonga13
ID: 24872364
Do you need the ASA to have a second WAN address or does the server just need another public IP? If you have multiple public IPs in the same subnet, you would just need to NAT between the internal address and the public address. The ASA would only need one address.
0
 
LVL 25

Accepted Solution

by:
Ron M earned 500 total points
ID: 24872395
There's a configuration example here....
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a00804708b4.shtml

Backup your config before making any changes.
0
 
LVL 5

Expert Comment

by:yashinchalad
ID: 24872516
you need to have cisco asa 5500 security plus license if you need it to support multiple ISP's

as far as same subnet from same ISP is concerned you must need to do another NAT with private->public appropriately


0
 
LVL 3

Author Comment

by:huntleyj
ID: 24872533
Well first let me apolagise as this is all new to me so I'll give you all a bit more info to help. I have 8 public IPs for our ISP to draw from on the same subnet
currently domain1.com and domain2.com are pointing to the same IP in the NS records. Domain1.com already has a ssl cert and now domain2.com wants one. I have been told that I will have to change domain2.com's NS records to a another one of my IPs in order to have two SSL certs on the same server.
Am I being fed BS? I don't know as I mentioned it's all new to me
0
 
LVL 3

Author Comment

by:huntleyj
ID: 24872598
below is my sh run

Result of the command: "sh run"
 

: Saved

:

ASA Version 8.0(3)6 

!

hostname ciscoasa

domain-name domain.ca

enable password rB1zdBSeYOLPaxEO encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 192.168.113.15 PGWEB description Web Server

name 10.2.0.0 Exchange

name 192.168.113.243 Honeywell description Building Maintenance system

name 192.168.113.4 InterfaceProcessor

name 192.168.113.239 RemoteV1 description Remote V1 PC

name 192.168.113.240 TelecostPC description Call Accounting PC

name 192.168.113.1 PGServer1 description SQL server

name 192.168.113.242 CaptureDVR description Capture DVR

name 192.168.113.241 PanasonicDVR description Panasonic DVR
 

!

interface Vlan1

 nameif inside

 security-level 100

 ip address 192.168.113.2 255.255.255.0 

!

interface Vlan2

 nameif outside

 security-level 0

 ip address xxx.xxx.84.146 255.255.255.240 

!

interface Ethernet0/0

 switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

ftp mode passive

clock timezone AST -4

clock summer-time ADT recurring

dns server-group DefaultDNS

 domain-name domain.ca

same-security-traffic permit intra-interface

object-group protocol TCPUDP

 protocol-object udp

 protocol-object tcp

object-group network DM_INLINE_NETWORK_1

 network-object host Verb

 network-object host CSH

 network-object host tricon

 network-object host CSS

 network-object host CST

 network-object host cstguest

 network-object host Phil

object-group service DM_INLINE_TCP_1 tcp

 port-object eq ftp

 port-object eq ftp-data

object-group service DM_INLINE_SERVICE_1

 service-object icmp 

 service-object icmp echo

 service-object icmp echo-reply

 service-object tcp-udp eq echo 

object-group service AVG tcp

 description AVG Update Manager

 port-object eq 4157

object-group network DM_INLINE_NETWORK_2

 network-object host CSH

 network-object 192.168.114.0 255.255.255.0

object-group network DM_INLINE_NETWORK_3

 network-object host tricon

 network-object host Verb

 network-object host CSH

 network-object 192.168.114.0 255.255.255.0

 network-object host clicktracks

 network-object host CSS

 network-object host CST

 network-object host Phil

object-group network Centennial

 description Centennial Network

 network-object 192.168.1.0 255.255.255.0

object-group service RDP tcp-udp

 description RDP

 port-object eq 3389

object-group network DM_INLINE_NETWORK_4

 network-object host tricon

 network-object host temp

access-list outside_1_cryptomap extended permit ip 192.168.113.0 255.255.255.0 Exchange 255.255.0.0 

access-list outside_access_in extended permit tcp any interface outside eq www 

access-list outside_access_in extended permit tcp any interface outside eq https 

access-list outside_access_in remark Remote Desktop connection to PGWEB

access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_4 interface outside eq 3389 

access-list outside_access_in remark SQL access

access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_1 interface outside eq 1433 

access-list outside_access_in remark PCAnywhere access to Interface Processor

access-list outside_access_in extended permit tcp any interface outside eq pcanywhere-data 

access-list outside_access_in remark PCAnywhere to Interface Processor

access-list outside_access_in extended permit tcp any interface outside eq 5632 

access-list outside_access_in remark Telecost VNC

access-list outside_access_in extended deny tcp any interface outside eq 5800 

access-list outside_access_in remark Maintenance VNC

access-list outside_access_in extended deny tcp any interface outside eq 5900 

access-list outside_access_in remark Remote V1 VNC

access-list outside_access_in extended deny tcp any interface outside eq 5901 

access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_3 interface outside object-group DM_INLINE_TCP_1 

access-list outside_access_in extended deny object-group DM_INLINE_SERVICE_1 any xxx.xxx.84.144 255.255.255.240 

access-list outside_access_in extended deny tcp any interface outside eq 4157 

access-list inside_nat0_outbound extended permit ip any Exchange 255.255.0.0 

access-list inside_nat0_outbound extended permit ip 192.168.113.0 255.255.255.0 192.168.113.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip any object-group DM_INLINE_NETWORK_2 

access-list inside_nat0_outbound extended permit ip 192.168.113.0 255.255.255.0 object-group Centennial 

access-list PGHRemote_splitTunnelAcl standard permit 192.168.113.0 255.255.255.0 

access-list PGHRemote_splitTunnelAcl standard permit Exchange 255.255.0.0 

access-list outside_2_cryptomap extended permit ip any 192.168.114.0 255.255.255.0 

access-list outside_3_cryptomap extended permit ip 192.168.113.0 255.255.255.0 object-group Centennial 

pager lines 24

logging enable

logging timestamp

logging monitor emergencies

logging trap informational

logging asdm informational

logging queue 10

mtu inside 1500

mtu outside 1500

ip local pool vpn 192.168.113.151-192.168.113.160 mask 255.255.255.0

ip verify reverse-path interface inside

ip verify reverse-path interface outside

icmp unreachable rate-limit 1 burst-size 1

icmp deny xxx.xxx.84.144 255.255.255.240 outside

asdm image disk0:/asdm-602.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

static (inside,outside) tcp interface www PGWEB www netmask 255.255.255.255  dns 

static (inside,outside) tcp interface https PGWEB https netmask 255.255.255.255  dns 

static (inside,outside) tcp interface 3389 PGWEB 3389 netmask 255.255.255.255 

static (inside,outside) udp interface www PGWEB www netmask 255.255.255.255  dns 

static (inside,outside) tcp interface 1433 pghsql-08 1433 netmask 255.255.255.255 

static (inside,outside) tcp interface pcanywhere-data InterfaceProcessor pcanywhere-data netmask 255.255.255.255 

static (inside,outside) tcp interface 5632 InterfaceProcessor 5632 netmask 255.255.255.255 

static (inside,outside) tcp interface 5800 TelecostPC 5800 netmask 255.255.255.255 

static (inside,outside) tcp interface 5900 Honeywell 5900 netmask 255.255.255.255 

static (inside,outside) tcp interface 5901 RemoteV1 5901 netmask 255.255.255.255 

static (inside,outside) tcp interface 87 PanasonicDVR 87 netmask 255.255.255.255 

static (inside,outside) tcp interface 88 CaptureDVR 88 netmask 255.255.255.255 

static (inside,outside) tcp interface ftp PGWEB ftp netmask 255.255.255.255  dns 

static (inside,outside) tcp interface ftp-data PGWEB ftp-data netmask 255.255.255.255  dns 

static (inside,outside) tcp interface 4157 pghsql-08 4157 netmask 255.255.255.255  dns 

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 xxx.xxx.84.145 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

aaa-server PGHRemote protocol radius

aaa-server PGHRemote (inside) host pghsql-08

 key laserjet

http server enable

http 192.168.113.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs 

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set peer xxx.xxx.87.114 

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map 2 match address outside_2_cryptomap

crypto map outside_map 2 set peer CSH 

crypto map outside_map 2 set transform-set ESP-3DES-SHA

crypto map outside_map 3 match address outside_3_cryptomap

crypto map outside_map 3 set peer xxx.xxx.145.178 

crypto map outside_map 3 set transform-set ESP-3DES-MD5

crypto map outside_map 3 set security-association lifetime seconds 86400

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 5

 authentication pre-share

 encryption 3des

 hash sha

 group 2

 lifetime 86400

crypto isakmp policy 10

 authentication pre-share

 encryption des

 hash sha

 group 2

 lifetime 86400

crypto isakmp policy 30

 authentication pre-share

 encryption 3des

 hash sha

 group 1

 lifetime 86400

crypto isakmp policy 50

 authentication pre-share

 encryption 3des

 hash md5

 group 1

 lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

management-access inside

dhcpd auto_config outside

!

dhcpd address pghsql-08-192.168.113.254 inside

dhcpd dns xxx.xxx.1.2 xxx.xxx.129.11 interface inside

!
 

threat-detection basic-threat

threat-detection scanning-threat shun except ip-address Exchange 255.255.0.0

threat-detection scanning-threat shun except ip-address tricon 255.255.255.255

threat-detection scanning-threat shun except ip-address CSH 255.255.255.255

threat-detection scanning-threat shun except ip-address 192.168.1.0 255.255.255.0

threat-detection scanning-threat shun except ip-address 192.168.114.0 255.255.255.0

threat-detection scanning-threat shun except ip-address JimSaunders 255.255.255.255

threat-detection statistics

ntp authenticate

ntp server pghsql-08 source inside prefer

group-policy PGHRemote internal

group-policy PGHRemote attributes

 dns-server value 192.168.113.3 xxx.xxx.1.2

 vpn-tunnel-protocol IPSec l2tp-ipsec 

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value PGHRemote_splitTunnelAcl

 default-domain value domain.ca

tunnel-group xxx.xxx.87.114 type ipsec-l2l

tunnel-group xxx.xxx.87.114 ipsec-attributes

 pre-shared-key *

 isakmp keepalive disable

tunnel-group PGHRemote type remote-access

tunnel-group PGHRemote general-attributes

 address-pool vpn

 authentication-server-group PGHRemote

 default-group-policy PGHRemote

 authorization-required

tunnel-group PGHRemote ipsec-attributes

 pre-shared-key *

tunnel-group xxx.xxx.79.235 type ipsec-l2l

tunnel-group xxx.xxx.79.235 ipsec-attributes

 pre-shared-key *

 isakmp keepalive disable

tunnel-group xxx.xxx.145.178 type ipsec-l2l

tunnel-group xxx.xxx.145.178 ipsec-attributes

 pre-shared-key *

 isakmp keepalive disable

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

 parameters

  message-length maximum 512

policy-map global_policy

 class inspection_default

  inspect dns preset_dns_map 

  inspect ftp 

  inspect h323 h225 

  inspect h323 ras 

  inspect rsh 

  inspect rtsp 

  inspect esmtp 

  inspect sqlnet 

  inspect skinny  

  inspect sunrpc 

  inspect xdmcp 

  inspect sip  

  inspect netbios 

  inspect tftp 

!

service-policy global_policy global

prompt hostname context 

Cryptochecksum:edcbb50dc4a465d3cda913dda8f97d09

: end

Open in new window

0
 
LVL 7

Expert Comment

by:clonga13
ID: 24872628
No, its not a bunch of BS. You would need to give your website a unique internal address. Then on the ASA you would use NAT the public IP address to the new internal IP address. Then you would change your DNS records.
0
 
LVL 25

Expert Comment

by:Ron M
ID: 24872640
Review the above configuration example...
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a00804708b4.shtml#t11

The device will only have one IP address....meaning it will only respond on one ip address publicly..... for example "pings"......but it will route any public IP's in the global pool if configured to do so.



0
 
LVL 3

Author Comment

by:huntleyj
ID: 24872727
reading now
0
 
LVL 3

Author Comment

by:huntleyj
ID: 24873476
confused a bit by reading the link xuserx2000. Probably only becasue the screen shots and layout are different in my version of adsm.
0
 
LVL 7

Expert Comment

by:clonga13
ID: 24873647
Its really not very hard. From ASDM, click on NAT and create a static mapping between the public IP address you want to use and the internal IP address you want to use. After that, go to the security section and allow port 80 and 443 to access the public IP address. Give your website the new internal IP address and change your DNS record to point to the new public IP address.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 3

Author Comment

by:huntleyj
ID: 24873816
think I got it. sh run below.
Anyway to test it before I start the NS change proceedure?
 
 

Result of the command: "sh run"
 

: Saved

:

ASA Version 8.0(3)6 

!

hostname ciscoasa

domain-name domain.ca

enable password rB1zdBSeYOLPaxEO encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 192.168.113.15 PGWEB description Web Server

name 10.2.0.0 Exchange

name 192.168.113.243 Honeywell description Building Maintenance system

name 192.168.113.4 InterfaceProcessor

name 192.168.113.239 RemoteV1 description Remote V1 PC

name 192.168.113.240 TelecostPC description Call Accounting PC

name 192.168.113.1 PGServer1 description SQL server

name 192.168.113.242 CaptureDVR description Capture DVR

name 192.168.113.241 PanasonicDVR description Panasonic DVR

name 24.222.206.154 Verb description Verb to SQL

name xxx.xxx.164.68 tricon

name xxx.xxx.79.235 CSH

name 192.168.113.3 pghsql-08

name xxx.xxx.84.243 CSS description for cash cards
 

interface Vlan1

 nameif inside

 security-level 100

 ip address 192.168.113.2 255.255.255.0 

!

interface Vlan2

 nameif outside

 security-level 0

 ip address xxx.xxx.84.146 255.255.255.240 

!

interface Ethernet0/0

 switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

ftp mode passive

clock timezone AST -4

clock summer-time ADT recurring

dns server-group DefaultDNS

 domain-name domain.ca

same-security-traffic permit intra-interface

object-group protocol TCPUDP

 protocol-object udp

 protocol-object tcp

object-group network DM_INLINE_NETWORK_1

 network-object host Verb

 network-object host CSH

 network-object host tricon

 network-object host CSS

 network-object host CST

 network-object host cstguest

 network-object host Phil

object-group service DM_INLINE_TCP_1 tcp

 port-object eq ftp

 port-object eq ftp-data

object-group service DM_INLINE_SERVICE_1

 service-object icmp 

 service-object icmp echo

 service-object icmp echo-reply

 service-object tcp-udp eq echo 

object-group service AVG tcp

 description AVG Update Manager

 port-object eq 4157

object-group network DM_INLINE_NETWORK_2

 network-object host CSH

 network-object 192.168.114.0 255.255.255.0

object-group network DM_INLINE_NETWORK_3

 network-object host tricon

 network-object host Verb

 network-object host CSH

 network-object 192.168.114.0 255.255.255.0

 network-object host clicktracks

 network-object host CSS

 network-object host CST

 network-object host Phil

object-group network Centennial

 description Centennial Network

 network-object 192.168.1.0 255.255.255.0

object-group service RDP tcp-udp

 description RDP

 port-object eq 3389

object-group network DM_INLINE_NETWORK_4

 network-object host tricon

 network-object host temp

object-group network CSH

 description CSH

 network-object 192.168.114.0 255.255.255.0

access-list outside_1_cryptomap extended permit ip 192.168.113.0 255.255.255.0 Exchange 255.255.0.0 

access-list outside_access_in extended permit tcp any interface outside eq www 

access-list outside_access_in extended permit tcp any interface outside eq https 

access-list outside_access_in remark Remote Desktop connection to PGWEB

access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_4 interface outside eq 3389 

access-list outside_access_in remark SQL access

access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_1 interface outside eq 1433 

access-list outside_access_in remark PCAnywhere access to Interface Processor

access-list outside_access_in extended permit tcp any interface outside eq pcanywhere-data 

access-list outside_access_in remark PCAnywhere to Interface Processor

access-list outside_access_in extended permit tcp any interface outside eq 5632 

access-list outside_access_in remark Telecost VNC

access-list outside_access_in extended deny tcp any interface outside eq 5800 

access-list outside_access_in remark Maintenance VNC

access-list outside_access_in extended deny tcp any interface outside eq 5900 

access-list outside_access_in remark Remote V1 VNC

access-list outside_access_in extended deny tcp any interface outside eq 5901 

access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_3 interface outside object-group DM_INLINE_TCP_1 

access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_1 any xxx.xxx.84.144 255.255.255.240 

access-list outside_access_in extended deny tcp any interface outside eq 4157 

access-list inside_nat0_outbound extended permit ip any Exchange 255.255.0.0 

access-list inside_nat0_outbound extended permit ip 192.168.113.0 255.255.255.0 192.168.113.0 255.255.255.0 

access-list inside_nat0_outbound extended permit ip any object-group DM_INLINE_NETWORK_2 

access-list inside_nat0_outbound extended permit ip 192.168.113.0 255.255.255.0 object-group Centennial 

access-list PGHRemote_splitTunnelAcl standard permit 192.168.113.0 255.255.255.0 

access-list PGHRemote_splitTunnelAcl standard permit Exchange 255.255.0.0 

access-list outside_2_cryptomap extended permit ip any 192.168.114.0 255.255.255.0 

access-list outside_3_cryptomap extended permit ip 192.168.113.0 255.255.255.0 object-group Centennial 

access-list inside_nat_outbound extended permit tcp host PGWEB eq https any eq https 

pager lines 24

logging enable

logging timestamp

logging monitor emergencies

logging trap informational

logging asdm informational

logging queue 10

mtu inside 1500

mtu outside 1500

ip local pool vpn 192.168.113.151-192.168.113.160 mask 255.255.255.0

ip verify reverse-path interface inside

ip verify reverse-path interface outside

icmp unreachable rate-limit 1 burst-size 1

icmp deny xxx.xxx.84.144 255.255.255.240 outside

asdm image disk0:/asdm-602.bin

no asdm history enable

arp timeout 14400

nat-control

global (outside) 1 interface

global (outside) 1 xxx.xxx.84.147 netmask 255.255.0.0

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 access-list inside_nat_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

static (inside,outside) tcp interface www PGWEB www netmask 255.255.255.255  dns 

static (inside,outside) tcp interface https PGWEB https netmask 255.255.255.255  dns 

static (inside,outside) tcp interface 3389 PGWEB 3389 netmask 255.255.255.255 

static (inside,outside) udp interface www PGWEB www netmask 255.255.255.255  dns 

static (inside,outside) tcp interface 1433 pghsql-08 1433 netmask 255.255.255.255 

static (inside,outside) tcp interface pcanywhere-data InterfaceProcessor pcanywhere-data netmask 255.255.255.255 

static (inside,outside) tcp interface 5632 InterfaceProcessor 5632 netmask 255.255.255.255 

static (inside,outside) tcp interface 5800 TelecostPC 5800 netmask 255.255.255.255 

static (inside,outside) tcp interface 5900 Honeywell 5900 netmask 255.255.255.255 

static (inside,outside) tcp interface 5901 RemoteV1 5901 netmask 255.255.255.255 

static (inside,outside) tcp interface 87 PanasonicDVR 87 netmask 255.255.255.255 

static (inside,outside) tcp interface 88 CaptureDVR 88 netmask 255.255.255.255 

static (inside,outside) tcp interface ftp PGWEB ftp netmask 255.255.255.255  dns 

static (inside,outside) tcp interface ftp-data PGWEB ftp-data netmask 255.255.255.255  dns 

static (inside,outside) tcp interface 4157 pghsql-08 4157 netmask 255.255.255.255  dns 

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 xxx.xxx.84.145 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

aaa-server PGHRemote protocol radius

aaa-server PGHRemote (inside) host pghsql-08

 key laserjet

http server enable

http 192.168.113.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs 

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set peer xxx.xxx.87.114 

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map 2 match address outside_2_cryptomap

crypto map outside_map 2 set peer CSH 

crypto map outside_map 2 set transform-set ESP-3DES-SHA

crypto map outside_map 3 match address outside_3_cryptomap

crypto map outside_map 3 set peer xxx.xxx.145.178 

crypto map outside_map 3 set transform-set ESP-3DES-MD5

crypto map outside_map 3 set security-association lifetime seconds 86400

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 5

 authentication pre-share

 encryption 3des

 hash sha

 group 2

 lifetime 86400

crypto isakmp policy 10

 authentication pre-share

 encryption des

 hash sha

 group 2

 lifetime 86400

crypto isakmp policy 30

 authentication pre-share

 encryption 3des

 hash sha

 group 1

 lifetime 86400

crypto isakmp policy 50

 authentication pre-share

 encryption 3des

 hash md5

 group 1

 lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

management-access inside

dhcpd auto_config outside

!

dhcpd address pghsql-08-192.168.113.254 inside

dhcpd dns xxx.xxx.1.2 xxx.xxx.129.11 interface inside

!
 

threat-detection basic-threat

threat-detection scanning-threat shun except ip-address Exchange 255.255.0.0

threat-detection scanning-threat shun except ip-address tricon 255.255.255.255

threat-detection scanning-threat shun except ip-address CSH 255.255.255.255

threat-detection scanning-threat shun except ip-address 192.168.1.0 255.255.255.0

threat-detection scanning-threat shun except ip-address 192.168.114.0 255.255.255.0

threat-detection scanning-threat shun except ip-address JimSaunders 255.255.255.255

no threat-detection statistics access-list

ntp authenticate

ntp server pghsql-08 source inside prefer

group-policy PGHRemote internal

group-policy PGHRemote attributes

 dns-server value 192.168.113.3 xxx.xxx.1.2

 vpn-tunnel-protocol IPSec l2tp-ipsec 

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value PGHRemote_splitTunnelAcl

 default-domain value domain.ca

tunnel-group xxx.xxx.87.114 type ipsec-l2l

tunnel-group xxx.xxx.87.114 ipsec-attributes

 pre-shared-key *

 isakmp keepalive disable

tunnel-group PGHRemote type remote-access

tunnel-group PGHRemote general-attributes

 address-pool vpn

 authentication-server-group PGHRemote

 default-group-policy PGHRemote

 authorization-required

tunnel-group PGHRemote ipsec-attributes

 pre-shared-key *

tunnel-group xxx.xxx.79.235 type ipsec-l2l

tunnel-group xxx.xxx.79.235 ipsec-attributes

 pre-shared-key *

 isakmp keepalive disable

tunnel-group xxx.xxx.145.178 type ipsec-l2l

tunnel-group xxx.xxx.145.178 ipsec-attributes

 pre-shared-key *

 isakmp keepalive disable

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

 parameters

  message-length maximum 512

policy-map global_policy

 class inspection_default

  inspect dns preset_dns_map 

  inspect ftp 

  inspect h323 h225 

  inspect h323 ras 

  inspect rsh 

  inspect rtsp 

  inspect esmtp 

  inspect sqlnet 

  inspect skinny  

  inspect sunrpc 

  inspect xdmcp 

  inspect sip  

  inspect netbios 

  inspect tftp 

!

service-policy global_policy global

prompt hostname context 

Cryptochecksum:2c80a9cd9a3b99c9baa20f42ceacceb1

: end

Open in new window

0
 
LVL 7

Expert Comment

by:clonga13
ID: 24873848
You can test by using just the IP address or creating a fake DNS name and using that to test. Nothing says you can't have two names pointing at the same IP address.
0
 
LVL 25

Expert Comment

by:Ron M
ID: 24873943
I don't see any *new ..static mappings in the second config.

Also....this looks redundant....and wrong if you say you have 8 ip's...
global (outside) 1 interface
global (outside) 1 xxx.xxx.84.147 netmask 255.255.0.0
-----------------------------------
should only need this> global (outside) 1 interface


Then a static mapping...
static (inside,outside) tcp xxx.xxx.84.147 https 192.168.113.xxx https netmask 255.255.255.255

Not sure if you need to adjust your access-list...
0
 
LVL 3

Author Comment

by:huntleyj
ID: 24874831
gone for the night.  will look at it again in the morn
0
 
LVL 3

Author Comment

by:huntleyj
ID: 24880788
good news is that I received a VM this morning saying that they no longer need the SSL Cert. But I would still like to add the xxx.xxx.84.147 to our ASA.
Everytime I go to config... NAT Rules... Add Static NAT Rule... Inside (webserver) Outside (xxx.xxx.84.147)  and save I get an overlap error on the outside interface
 
 

overlap-error.doc
0
 
LVL 7

Expert Comment

by:clonga13
ID: 24880917
Make sure your not using that IP address in your global NAT pool.
0
 
LVL 3

Author Comment

by:huntleyj
ID: 24881034
the only ip I have ever placed on the outside interface is the 84.176.
 
 

outside-interface.jpg
Global-address-pool.jpg
0
 
LVL 7

Expert Comment

by:clonga13
ID: 24881067
What's the outside IP address and subnet mask? What's the new public address your trying to use?
0
 
LVL 3

Author Comment

by:huntleyj
ID: 24881089
current outside IP is xxx.xxx.84.146 subnet 255.255.255.240
wish to add  xxx.xxx.84.147 subnet 255.255.255.240
0
 
LVL 3

Author Comment

by:huntleyj
ID: 24881106
GW from the ISP is xxx.xxx.84.145
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now