Solved

2005 DB Mail Agent Job " NOTE: Failed to notify 'sqlinfo' via email."

Posted on 2009-07-16
4
714 Views
Last Modified: 2012-05-07
I have set up db Mail for this server, Defined the account and a profile.  I have that account as an operator as well.

I have the Agent set to use this profile and it is enabled.

Yet when I run a job and expect a completion message the job just puts that nasty little stub on the end of the history.  

 NOTE: Failed to notify 'sqlinfo' via email.

Anyone think of something that I have done wrong?  

I can send a test email as well one via an SP.  It is just from Agent that I am lost.

TIA

__Stephen
0
Comment
Question by:srussell705
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 16

Accepted Solution

by:
SQL_SERVER_DBA earned 500 total points
ID: 24878949
0
 
LVL 1

Author Comment

by:srussell705
ID: 24896302
I have everything done just as you do.  I can SP mail outbound or via the "test."

It is from the AGENT that my messages are not sent.  For testing purposes I have set the log shipping to message upon completion.  This will be altered to When Fails after it works.  


Message
The job succeeded.  The Job was invoked by Schedule 14 (LSBackupSchedule_infomempdb1).  The last step to run was step 1 (Log shipping backup log job step.).  NOTE: Failed to notify 'sqlinfo' via email.

Yet I my mail I can receive these:
Sql Info [sqlinfo@informed.md]
This is a test e-mail sent from Database Mail on MEMPDB.

I have gone into the Agent and Enabled the Mail Profile, DataBase Mail and the Profile that lists SqlInfo.

In the Job I have listed SQLInfo as the end recipient.  

When I look at SqlInfo in the Operator listing I see that They should "Always" see the the Log Shipping job.

This was a new user in AD, SqlInfo, for SSMS 2005 job messaging.  

They are only working with one server out of 12 and all are set up the same way.

I have restared the Agent on all of the servers as well.

Any ideas?

TIA  
0
 
LVL 1

Author Comment

by:srussell705
ID: 24897903
This may be a rights issue on my inability to restart the Agent Service.  

The SA only has that right as of 2 + weeks ago in a new security policy.

So it looks like I am restarting in the Configuration manager, but I am not.  

mmmmm

 
0
 
LVL 1

Author Comment

by:srussell705
ID: 24899243
Yes it was a rights issue.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
sql Audit table 3 84
Get row count of current SQL query 8 64
Table create permissions on SQL Server 2005 9 45
SQL works but want to get the XML node data separately 11 29
Introduction: When running hybrid database environments, you often need to query some data from a remote db of any type, while being connected to your MS SQL Server database. Problems start when you try to combine that with some "user input" pass…
In this article I will describe the Copy Database Wizard method as one possible migration process and I will add the extra tasks needed for an upgrade when and where is applied so it will cover all.
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question