Second (nested) RDP session fails/hangs.

FixerMonkey
FixerMonkey used Ask the Experts™
on
I was able to use remote desktop to remote control a 2003 Server, then from "inside" that 2003 Server, remote any other box on my network, jumping to anything on my network I wanted XP/2003/2008 - then something changed.  Within the last few months, it fails.  The first session is fine to the 2003 server, then the second (nested) session hangs (shows not responding) - Event Viewer States "Event ID 1002 Application Hang - "Hanging application MSTSC.exe" - others have posted the same issue in some forums, but I don't see any solutions.  I assume it was a Service Pack "Fix" that has broken me.  Anyone else see this?  Solved it yet?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Hi, I have verifed this as well and looked for a fix.  Found nothing.  

try using remote desktop instead of mstsc.

You can find it under administrative tools, and Remote Desktops. This is using TSMMC rather than MSTSC.  You can establish a true console connection with TSMMC rather than another terminal server session.  

The only thing that I can think of is that the latest round crippled the sessions per connection per user or something.  However, I have gotten it working with Remote Desktops under admin tools.

HTH

Author

Commented:
More test have resulted in the following findings --Only happens with XP clients or 2003 Terminal Servers.  If I remote a Vista box, I can double-hop, and triple hop if I go to another machine (running Vista or 2008 Server).  Interesting, can't seem to find a "legacy" RDP/TS client that works.  Tried re-installing RDP using both WindowsServer2003-KB925876-v2-x86-ENU.exe on the server and WindowsXP-KB925876-x86-ENU.exe on the XP test machines.  Both still have the same issue.  It connects, but times out, perhaps when sending the information "back" to the host?

Commented:
Well version 6 will work fine with Vista and supposedly (although, like you, I never got it to work) version 5.2 can be reinstalled and it will work as advertised.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Commented:
So, right now your 2k3 server's are running 5.2 or 6.0?  Also, same question with XP...

2k3 box, Display properties -> settings -> advanced -> troubleshoot, and set the hardware acceleration to full.  It may be set to the left a bit by default.


Commented:
And you tried the /console and /admin switches from the 2k3 box?  In particular the /admin switch for the Vista boxes from the 2k3 box.

Author

Commented:
Thanks for the great tips, but still not working.  The W2003 Server is running 5.2 when I look at properties of the Term Server Manager, but the W2003 server's client (mstsc.exe)  I am then using to try to remote another box is 6.0 (MSTSC.exe)

My XP's client mstsc.exe is 6.0, it is what I use to remote to the W2003 server.

If I run mstsc /admin on the 2K3 server, it complains (not valid usage) - but if I do it from my XP client to the W2K3 server with the /admin switch, all is well., so there is clearly a version mismatch, and I would expect that since we're talking about XP vs. 2003.  Can't successfully connect via /console from my 2003 server to 2008 server (still hangs due to "double hop")

What I have noticed is there are some differences in the MSTSC.exe "about" results.  

W2003 server = 6.0 Build 6000 Control version 6.0.600 then Max encryption strength:128 bits.
XP client = Shell 6.0.6001 Control version 6.0.6001 RDP 6.1 supported

Yeah, hardware acceleration is already on FULL.

Did I mention that if I get on the console of the 2003 server (NOT mstsc.exe / console -- but literally on the console) I can RDP to 2008 box (but alas, that's only a single hop) - so... it's not like the box won't remote a 2008 box, just not the double hop from my XP client.  There must be a version mismatch or Term Server simply gets confused when double-hopping, it is just annoying because it used to work for me & now something changed.  My easiest solution might be to create a 2008 Term Server and close this bug and unsolved?
Commented:
You said: If I run mstsc /admin on the 2K3 server, it complains (not valid usage)

This is because /admin is for Vista/2008 only and will only work on 6.0 client.  You said that your 2k3 box is running 6.0.

I think that you have run into the same EXACT wall that I ran into now.

Here is the problem in a nutshell: the 6.1 client is not compatible with 2003 server,  but it will work with XP and 2008 and Vista.

Here is a blog entry from msdn:
http://blogs.msdn.com/rds/archive/2008/06/25/remote-desktop-connection-terminal-services-client-6-1-for-windows-xp-sp2-x86-platforms.aspx

BUT,

Check this out:

http://www.pubforum.info/welcome/BLOG/tabid/78/EntryID/6/Default.aspx

Author

Commented:
You're right on, thanks so much for pointing me towards the compatibility option, had no idea that existed.  Thanks again, you're a wizard!

Commented:
LOL nope, just a Guru.

Thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial