Drive disappeared from RAID0 array

zefyxftw
zefyxftw used Ask the Experts™
on
I came home earlier to try to extract a archive on my 4.5TB RAID0 array (powered by Intel's ICH9 chipset) to be greeted by WinRAR saying the archive couldn't be extracted as the disk might be full. After trying a few times I decided to reboot the computer, which I tried 3 times & received the same message. I tried then tried switching in my bios from RAID to IDE to run Seagate's SeaTools to test the drives, SeaTools would not run & gave me & error which wouldn't allow it to run. I then rebooted the PC & switched my drives back to RAID. PC shut off & turned back on. At this point, Intel's RAID boot-up told me my array named 4.5TB had failed & that one of my disks was no longer listed as a member of the array. I'm basically panicking at this point. Windows is taking quite awhile to boot, I'm unable to test the drive that was kicked from the array in SeaTools (SeaTools says Test Unavailable). I've tried testing in DOS, apparently SeaTools doesn't support GPT. DiskMgmt takes along time to connect to logical disk manager.

Some information:
Windows XP  Professional 64-bit Edition
(3) 1.5TB Seagate HDDs
GPT formatted disks
Intel ICH9 RAID0
(3) drives no older than 1 month
(2) drives with CC1H firmware
(1) drive with CC71
Drive that is missing does NOT make any strange noises

The worst part of all of this is I have another 1.5TB drive that is supposed to be delivered tomorrow, I ordered this drive so that I may convert my RAID0 array to RAID5 for redundancy.

What do I do? "Some" data was written to the array which presumably was during the time one of the disks left the array, however the data that might have been written at that time is unimportant to me, I simply don't want to loose the other 3TB that were on these disks. Please help!

If you need any other information, please let me know.
DiskMgmt.JPG
Matrix.JPG
SeaTools.JPG
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Doesn't look good. You could try forcing the missing drive on-line back into the array, but if the drive has turned its toes up, that simply won't work. As your fall-back, have a look at RAID Reconstructor from http://www.runtime.org/raid.htm - you may be able to recover some of your data with it.

Author

Commented:
Thanks for the reply, how would I go about forcing the drive on-line? I've tried initializing the drive in diskmgmt.msc, that failed.
Lucky it failed. That would have wiped out your data...

Have a look at this from the Intel support site: http://www.intel.com/support/chipsets/imsm/sb/CS-020992.htm

11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

So what you could try is:
1. power down the system
2. Disconnect the failed drive
3. Power up the system
4. Shut down the system
5. Re-connect the missing drive
6. Power up the system and see if the system can now see the drive

If that fails, go into the RAID BIOS and see if the controller can see all the 1.5TB drives. If one is missing, I'm afraid that it's likely that the dead drive is unrecoverable without assistance from a data recovery company.

Author

Commented:
Alright, I disconnected the drive & powered the system up. After loading Windows I powered down & reconnected. Upon further investigation I found that the drive in question does make a 10 second noise upon power up that none of my other drives make. The weird thing is, I've never heard this noise with hard drives before. It's something along the lines of.. long... click click long... click click & then it disappears.

I've updated the original post with a screenshot of HDTune in regards to this drive.

Author

Commented:
Actually, it doesn't look like I was able to edit my original posting, here is a link to the screen shot of HDTune stating that this drive is OK.

http://i26.tinypic.com/15i4zft.jpg
Clicking from a Hard Drive is usually very bad. I've had it happen when the controller on the Drive fails or a part inside the drive fails. The clicking is usually the arm snaping back and forth. I've had a drive make the sounds you describe when the Arm hardware fails and the head hits the physical disc and scratches it (essentially Destroying it)

It is not sounding good for you. Can you use the raid reconstructor to rebuild the array with the other 2 drives to attempt to read data?
>The clicking is usually the arm snaping back and forth.

The drive is performing a re-zero. It can't find sector addresses, so the controller firmware loses track of where it is on the disk platter, so it has to reset itself to home position and try again. The reset to home position is what causes the clicking noise.

Author

Commented:
I ended up dealing with the data loss, its obvious my data is gone. Thanks anyway.
This question should remain in the EE knowledgebase, not deleted. Please accept an answer.

Commented:
Question PAQ'd, 225 points refunded, and stored in the solution database.
Commented:
Question PAQ'd, 225 points refunded, and stored in the solution database.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial