HTTP Error 500.0 - Internal Server Error- Calling LoadLibraryEx on ISAPI filter "C:\Program Files\Microsoft\Exchange Server\ClientAccess\sync\bin\AirFilter.dll" failed

NRTCF
NRTCF used Ask the Experts™
on
Hi all, I keep getting the following error when I try to access OWA internally and externally. I also get this message when accessing the default site.
HTTP Error 500.0 - Internal Server Error
Calling LoadLibraryEx on ISAPI filter "C:\Program Files\Microsoft\Exchange Server\ClientAccess\sync\bin\AirFilter.dll" failed
Detailed Error Information
Module      IIS Web Core
Notification      Unknown
Handler      StaticFile
Error Code      0x8007007e
Requested URL      https://xxxx.xxxx.local:443/owa
Physical Path      C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa
Logon Method      Not yet determined
Logon User      Not yet determined
I am currently running Exchange 2007 sp1 on server 2008 64bit edition. I have tried the steps in these articles:  http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/94c812b5-4bd5-41eb-8396-462e03295201

Error message when you visit a Web site that is hosted on IIS 7.0: "HTTP Error 500.19  Internal Server Error"
http://support.microsoft.com/kb/942055/en-us

How to switch between the 32-bit versions of ASP.NET 1.1 and the 64-bit version of ASP.NET 2.0 on a 64-bit version of Windows
http://support.microsoft.com/default.aspx?scid=kb;EN-US;894435

Also tried this: http://forums.iis.net/t/1149050.aspx

And did not get this to work. I have not tried reinstalling client access role and rebinding to mailboxes. Does anybody have a solution to this problem?

If I remove the ISAPI filters from the default site, everything seems to work ok, but I am assuming those filters are there for a reason.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
I tried the solution but got his erros instead:
HTTP Error 503. The service is unavailable.
And i got this in the event log
The Module DLL C:\Windows\system32\RpcProxy\RpcProxy.dll failed to load.  The data is the error.
Commented:
I called Microsft and here is the resolution to this problem.

Removed Exchange Rollup 8, restarted server, downloaded Rollup 8 from Microsoft website, do not use windows update. Reinstalled rollup and restarted server. IIS was now working but OWA would not connect. Ran the following from Exchange cmd:

Remove-OwaVirtualDirectory "owa (default web site)"


New-OwaVirtualDirectory -name "owa" -OwaVersion Exchange2007 -WebSiteName "Default Web Site"

According to MS, rollup a lot of the times does not install correctly using auto updates or windows updates. This causes coruption in OWA.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial