DHCP renewal issue after disabling APIPA

asifyoucare
asifyoucare used Ask the Experts™
on
My original problem was that all my clients (XP/SP2) failed to connect to the network if they rebooted when their DHCP server was down (even if their lease had not expired).  Instead of just keeping their unexpired leases, the clients insisted on using 169.154.*.* APIPA addresses.  This meant that a single server failure could result in hundreds of PCs failing, and this was a major issue.

I disabled APIPA on every PC by setting IPAutoconfigurationEnabled=0 in the registry.  That worked a treat, and now I am immune from massive failure if a DHCP server is down.  But I have a new problem ...

When some laptop users go home and connect to their home LAN they get a new address.  That's fine and expected.  But, when they come back into the office they RETAIN THAT ADDRESS from their home LAN.  Packet sniffing showed that such clients sent out three DHCP requests on the work LAN, but the server just ignored them.

So, the clients successfully get a new address form their home LANs but not from their work LAN?  It looks like a Windows 2003 DHCP server issue - why is it ignoring the requests?

Has anyone seen this or got any ideas?

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Regarding to http://connect.microsoft.com/WindowsServerFeedback/feedback/ViewFeedback.aspx?FeedbackID=311626 and http://technet.microsoft.com/en-us/library/cc938253.aspx and maybe some other article, this registry setting is NOT RELIABLE.
Citate from Microsoft:
"Caution! Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable."

You may try setting up redundant STANDBY DHCP server following instructions and code here http://www.c64gg.com/dhcp-redundancy/
In case anyone else has the same problem, here is the issue.

The APIPA registry change had a side effect of speeding up the DHCP process, and this unmasked an incompatibility between DHCP and the Spanning Tree Protocol on our switches.  STP blocks traffic from newly connected devices for 15 seconds, and now our DHCP process was completing in the 15 second period - so no requests were ever reaching the server.

The solution is to configure all your switches to use STP Fast Mode, assuming you want STP.  For very small networks with a single switch you could just disable STP.

I expect others will have this same problem.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial