My Lenovo T61 won't connect to WPA-secured networks

Infolink_Denmark
Infolink_Denmark used Ask the Experts™
on
Hi!
See, I have this problem that I have to fix very soon. I'm working as an IT-technician in a small business.
Yesterdays (and todays) problem is that I must fix a laptop which can't connect to WPA-secured wireless networks.
The laptop is a Lenovo T61 with an Intel Pro wireless adapter.
It connects without any problems to WEP networks, for example a so called 'hotspot' at the neighbouring gasstation.
But when I connect to our own Cisco wireless switch, i just says "Acquirering Network Adress" and repeats about 5 times, until it gives up and stands as "Automatic".
I've been trying to use Intels software to administrate the wireless connection on the laptop, still the same.
The laptop is running Windows XP SP3 with all new updates. Also fully updated from Lenovo System Update. Also tried reinstalling the drivers, but it's all the same.

What to do?

- Sorry for bad spelling, I'm not english.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
DexIT >

Sorry, the drivers you've linked to is not Intel PROset drivers, but Lenovos own driver for a mini-PCI wireless device. Tried that, doesn't work.

The other link to Microsoft support, is for Windows XP SP2, but the laptop is running SP3 which already  should include security updates for wireless devices.

Any help is appreciated.
Problem solved!

Apperently our client has installed some kind of network protocols called
"Wireless Intermediate Driver" and "Teefer2 Driver". Unchecked those two in
the network properties box for the wireless adapter, and now it works without any problems.

Fantastic :o)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial