Mac OSX to SBS 2008 FIle Access

oasistechnical
oasistechnical used Ask the Experts™
on
Hi
I need to permanently set that a MAC can have access to a shared folder on SBS 2008.

The registry keys that need to be changed are below. I need to change them to 0 in order for it to work.
requiresecuritysignature = 1
enablesecuritysignature = 1

How can i make this change permanently through the GPO or on the local server its self.
What would i need to change?

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Increased points
Systems engineer
Top Expert 2008
Commented:
SMB signing requirement is configured in the following policy settings
Computer Configuration\Windows Configuration\Security Settings\Local Policies\Security Options
* Microsoft Network Client: Digitally sign communications (always)
* Microsoft Network Client: Digitally sign communications (if server agrees)
* Microsoft Network Server: Digitally sign communications (always)
* Microsoft Network Server: Digitally sign communications (if client agrees)

You have SMB-signing setting on both client and server side of communication.
To make it possibly for Mac that doesn't support SMB-signing to connect, you nead to disable the require setting "...(always)" on the server side of communication. To make it possibly for WindowsServer to access shares on other systems that doesn't support SMB-signing, you nead to disable the client sides require/always setting.
Set the respond/agree setting on for both client and server sections to enabled to make it possibly to communicate with other systems that require that SMB-signing is supported.

Author

Commented:
Thanks for your help

Commented:
You say above that I need to "disable the require setting "...(always)" on the server side of communication".  I can't see any "require setting" in my group policy editor.  I see the following items under "Microsoft network server:" in SBS 2008:
Amount of idle time required before suspending session
Digitally sign communications (always)
Digitally sign communications (if client agrees)
Disconnect clients when logon hours expire

I'll try setting the "Digitally sign communications" to 'disable'. If I don't write another comment, chances are this is the answer!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial