Cannot browse sub directories of IIS web server by ip address

tribeca2007
tribeca2007 used Ask the Experts™
on
Hi There,

We are having problems with a web server that is primarily used for internal hosting of an intranet.

IIS 6.0  is installed on a windows XP Pro machine x64 edition Version 2003 Service pack 2

The issue we have is we would like to publish some pages to the internet. This should be straight forward although we are having problems with some of the pages.

We can browse to the default web site by IP address and by FQDN however when we try to browse to a virtual directory of the default site we have problems.

The default web site source is in

C:\Inetpub\wwwroot

The virtual directory source files are in

C:\another folder

The Virtual directory has anonymous access disabled and integrated windows authentication as we want to password protect the pages in the virtual directory.

When browsing to this virtual directory internally from another machine we can pick it up fine e.g

http://webserver/virtualdirectory/index.htm

And there is no prompting for password

When we browse by IP address

http://192.168.0.247/virtualdirectory/index.htm

We are prompted for password which is entered before we get the message

Internet Explorer cannot display the webpage

The same result is obtained if we browse externally using IP address/ virtualdirectory/index.htm or FQDN/virtualdirectory/index.htm

For information we are also looking to make the link SSL secure and have installed a certificate although we have not currently got this requirement ticked under secure communications.

Any help would be very much appreciated!

Many thanks in advance Paul
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
I think if I am correct when you try this this link
http://webserver/virtualdirectory/index.htm -- You are not prompted for password but you can see the page content
but when you try
http://192.168.0.247/virtualdirectory/index.htm or using external ip you get a password prompt.

If this is the situation then the key thing is "window authentication"
Is there a windows domain involved ? I think when you are using the FQDN/hostname then it is authenticating you with the account you are logged in. But if you use the internal or external ip it cannot authenticate. When you get the password prompt see the title bar. Is it trying to authenticate to the domain or the local server ? provide the credentials according to that in the standard windows way
like ; domain\usename

Let me know if this helped or not

Author

Commented:
Hi There,

Many thanks for your comments.

I aggree that the most likely scenario is the windows authentication.

I tried adding the domain to the username but even using the domain admin username and password on a machine in the domain still had the same effect.

"internet explorer cannot display the webpage"

I have also tried adding a specific user to folder permissions.

The popup requesting user credentials says that its trying to connect to 192.168.0.247

Many thanks

Paul

Commented:
Create a local user (My Computer - manage - user management) in this 192.168.0.247 then give the user appropriate permission on the VD. Now give it a try, and authenticate with the new user ID.

Author

Commented:
Unfortunately still not working with a local user account.

Does the authentication use a seperate proccess to IIS?
Commented:
Authentication in IIS doesn't use a separate service or process.
Are you sure the permissions are right be sure to check the permission on the folder which is mapped as the VD (web sharing).

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial