Outlook 2007 asks for username and password when connecting to Exchange 2007

mdj1501
mdj1501 used Ask the Experts™
on
Hi,

Keeps promting when opening outlook 2007 connecting to exchange 2007. LAN Based so this should not prompt. Have checked always prompt for logon credentials and this is unticked. Can ping and reoslve name all ok ? Any Ideas ? The logon network security is negotiate authentication where I am wondering if this need to be Kerberos ?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Are clients member of domain?

Shaun

Author

Commented:
yes sure are

Thanks,
Britt ThompsonSr. Systems Engineer
Top Expert 2009

Commented:
This typically relates to an improperly configured SSL certificate.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
If you are using outlook anywhere, or RPC over http, and the on fast networks checkbox is checked, it will always prompt. If it isn't this, then check the SSL.

Tools, account settings, change, more settings, connection, (bottom check box, )Exchange proxy settings...

Author

Commented:
no ssl cert purchased yet but not using outlook anywhere or rpc over http connect via lan only ?

Commented:
chek if this is for you (it has something to do with damaged registry key so remember to backup it):
===================================================================================
Outlook Express keeps prompting for your password

NOTE:  Following this procedure will remove all stored passwords for your user account. Make sure you know what they are before performing this procedure!!

This fix also applies to Outlook, other programs that store passwords in the Protected Storage System Provider  sub branch of the Registry. It also corrects some issues with Internet Explorer and Autocomplete.

This is caused by a damaged Registry key.  To Remove the broken Key in Windows® XP

1) Click Start, click Run, and then type regedt32 in the Open box.

2) Locate the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider

3) Right click the HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider key, and then Select Permissions.

4) In the Permissions for Protected Storage System Provider dialog box, click the Advanced tab. Make sure that the <Username> has Full Control access. Select "Replace permission entries..."

5) Click OK.  

6) Repeat steps 3 through 5 for each subkey that is listed under the Protected Storage System Provider registry key; otherwise, you may receive the following error message when you try to delete the Protected Storage System Provider key:

        Registry editor could not delete the key currently selected. The key or one of its
        subkeys does not give you delete access.

Note: The sub keys under Protected Storage System Provide will look something like this:

    S-1-5-21-1085031214-1202660629-1708537768-1003

7) At this point, you can delete the Protected Storage System Provider key by clicking Delete on the Edit menu. If you prefer, you can first export a copy of this key, and then delete the key. To export the key, right click the Protected Storage System Provider key, and select Export.  The exported file can be re-imported by double clicking on it.

8) When you click Delete, you receive the following message:

        Registry editor will delete the currently selected key and all its subkeys. Do you want to continue
        the operation?

Click Yes to finish the process.

9) Start Outlook Express. When Outlook Express checks your mail account(s) you will be able to re-enter your password(s). This process repopulates the Protected Storage System Provider registry key with the correct information for that computer's SID.

MS Knowledge Base Article: Save password setting not retained in Outlook or Outlook Express (Q290684)"

source:http://www.dougknox.com/xp/tips/xp_oe_passwords.htm

Expert of the Quarter 2009
Expert of the Year 2009
Commented:
If you are not using Outlook Anywhere, SSL certificates are involved. You cannot run Exchange 2007 without them.
Are you sure that the prompt is coming from Exchange? I have seen this a lot where autodiscover.example.com (where example.com is your external name) resolves to a host somewhere on the internet and Outlook attempts to connect to it.

Simon.

Author

Commented:
It is using it's own internel ssl. autodiscover works all ok as I log on as a user and go into outlook and it autocofigures itself ?
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
That wasn't what I meant, because internally autodiscover works in a slightly different way.
However Outlook will make some checks to see if anything has changed, which is when I see these prompts.

You need to ensure that the URLs are set correctly on the virtual directories and that the URLS resolve internally correctly.

The important thing though is finding out what is generating the authenticated prompt, what Outlook is connecting to.

Simon.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial