Microsoft Exchange

PBComputer
PBComputer used Ask the Experts™
on
Hello

I have being asked my a client to take over the installation of a new exchange server, its the first time ive done it and the last person who tried failed to fix the following error message,
--
Reporting-MTA: dns; smtp02.bis.eu.blackberry.com

Final-Recipient: rfc822;grant@clientsdomain.com
Action: failed
Status: 5.0.0 (permanent failure)
Remote-MTA: dns; [85.189.157.249]
Diagnostic-Code: smtp; 5.1.0 - Unknown address error 550-'5.7.1 Unable to relay for grant@clientsdomain.com' (delivery attempts: 0)
--

i have replaced my clients email address with clientsdomain

The hosting company is not every helpful as to mx details and dns, they have gave me only an list of ip address thats it!

There IP address is actually: 85.189.157.249

i can provide the clients domain if needed.

Regards Paul
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Co-Owner
Top Expert 2011
Commented:
Are you running SBS 2003 or SBS 2008 - your question does not advise clearly enough?
You seem to have problems receiving mails from Blackberry.com - is this correct?
Yor IP address does not have a RDNS pointer setup - this could be part of your problem.
You can test your domain on http://www.mxtoolbox.com/diagnostic.aspx and run a DNS report on http://www.dnsstuff.com to see what your DNS configuration is like.
If you would like me to perform the tests and analyze the results, please email me your domain details (via my profile) and I would be happy to see what else I can pick up on.
Alan

Author

Commented:
i have emailed you via your profile.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Thanks - Problems to resolve are:
  1. Setup an RDNS pointer on your IP - call your ISP to get this setup and make sure it is mail.yourdomain.com - Test on http://www.mxtoolbox.com/diagnostic.aspx highlights this problem.
  2. Change the FQDN name of your mail server to be mail.yourcompany.com - it is currently yourcompany.com (see below for details) - test on http://www.dnsstuff.com highlights this problem.
* - Start, Programs, Microsoft Exchange, System Manager.  Expand Servers, Expand Your Server, Expand Protocols, Expand SMTP, right-click on default SMTP virtual Server and choose properties.  Click on the Delivery Tab and then on the Advanced Button.  Change the name to mail.yourcompany.com.  Click OK twice.
Clear up these problems and your mail should flow more smoothly.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Do i take it that RDNS pointer is a setting on the server?

Also how can i discovered the RDNS?

Paul
Alan HardistyCo-Owner
Top Expert 2011

Commented:
RDNS is setup by your Internet Service Provider and converts your IP address to a FQDN which should be mail.yourcompany.com as mail servers will be looking for this when trying to end you mail and may refuse to accept your mail if it is not set properly.
Check your emails :-)

Author

Commented:
Just to check I need to contact my isp for the broadband, not my hosting company?
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Yes - RDNS is set by the ISP as they issue you your IP address and they are the only ones who can add a RDNS pointer.

Author

Commented:
Thanks, just whated to make sure, will email them now
Alan HardistyCo-Owner
Top Expert 2011

Commented:
No worries - better to be sure than fire off an email and get disappointed ;-)

Author

Commented:
just waiting to to hear back from my isp i also discovered the Primart DNS suffix was amw.local not there doamin which i have now chanaged

Author

Commented:
Thank you every much Alan
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Your default domain (Default Recipient Policy) was set to xyz.local which would therefore cause the rejection of all mail coming in to anything other than xyz.local, which of course, nothing ever would!
I changed your default email address policy to yourcompany.com and then tested mailflow.  There was a mail received after I sent a test message and I got a delivery receipt, so that part works.
As far as sending goes, the change to the Recipient Policy will have changed everyones default email address and now mail will be able to leave the building.
Whilst dabbling - I also changed the FQDN of your SMTP Virtual Server to be mail.yourcompany.com.  Your DNS report looks a whole lot happier now.
I also noticed you were missing Exchange Service Pack 2 - so I installed it for you ;-)
Best wishes
Alan

Author

Commented:
Thank You

Paul

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial