You do not have sufficient permission to perform this operation on this object.

art1333
art1333 used Ask the Experts™
on
Hi All,

I'm using Exchange 2003, with a Outlook 2007 client.  I have a user that when she forwards an email w/ a pdf attachment, she gets this, "You do not have sufficient permission to perform this operation on this object. "  I've checked the permissions on the pdf, and no security is set.  Also, if you save the attachment, create a new email message and attach it, it sends out fine.

Any help would be appreciated.....
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Is this something that just began happening where it worked before? It could be a permissions issue in AD.  I would compare to another user who is not having and issue and make sure they are in the same groups.

I have seen where you can promote the user to domain admin.  Have them log on and off to test it.  Then removed them as a domain admin and have them log off and back on and it worked after that switch.  Something you can try just to test if it is a AD permissions issue.

Author

Commented:
Everything worked fine before.  According to the user, it just started happening this week.

Commented:
Double check the permissions for the user and compare to your other users that don't see the problem.  If they are the same you may want to promote them just to verify it's a permissions issue.  Another thing you may want to try is creating a new profile.  Don't delete the profile they currently have but many times the profile can get corrupted.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
I have the same problem.  Did you get a fix for this?  Thanks.

Commented:
I also have this issue, but it's only after the user opens a PDF attachment.

if she tries to forward it with the attachment open, she gets this message.

if she closes it, she needs to wait two minutes, then it forwards OK.

Commented:
In addition, it's like outlook never closes the attachment after you open it.

if i try to close outlook i get prompted if i want to save changes to the message even though the message isn't open.

Commented:
i figured it out for my case.

in my case i had to grant the user rights to edit all items in the public folder.
it seems that outlook assumes you are editing the item when trying to forward it and the item is open either in the foreground or background.

Commented:
I too have had this issue.  
1) Exchange 2007 running on Windows 2003R2 x64 - Outlook 2007
2) Everything was working fine
3) User can open emails from other people without issue
4) One email will give them the error
5) Access via OWA works fine
6) Can open otehr emails from that sender
7) Most of the time this is an email from another domain user with an attachment

What I have found is to change the cached mode to off then back on or just turn it on if it is not.  Once the mailbox loads again, the person can access teh said email with no issue.  It is almost as if the email did not download completely into the mailbox.  This has happened maybe 15 times on this domain.

Like I said, once I make outlook download the entire mailbox, the email will open perfectly.  That said, is there another fix availible?  I hate going through this everytime this happens.

Thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial