activesync errors 401 and 403

tech-olathe
tech-olathe used Ask the Experts™
on
I am troubleshooting activesync.  No phone connected a phone yet.  Using site www.testexchangeconnectivity.com to test connectivity.  Seem to be going from error HTTP 401 to HTTP 403.   Have consulted KB817379 and kb937635.  Have used the CEICW to rebuild the virtual servers, but have obviously missed something. SBS2003 is on service pack 2.
have also used activesync tester by www.accessmylan.com.  in this case I get http 403.  i have checked the user does have mobile permissions per the microsoft website.  

activesync.txt
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
What authentication you have in IIS on below virtual directory and where SSL is enabled ?

/Exchange
/Exchange-oma
/Microsoft-Server-ActiveSync

Author

Commented:
/exchange  anonymous is unchecked,  integrated and basic are both checked, ssl checked
/exchange-oma  anonymous is unchecked,  integrated and basic are both checked, ssl unchecked
/Microsoft-Server-ActiveSync, anonymous and integrated unchecked, basic checked, ssl unchecked

401 problem solved.
From /exchange-oma ....uncheck Basic....and then perform iisreset from comand prompt and then checked
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
unchecked basic,  performed iis reset.  retested vie testexchangeconnectivity.

error http403 persists at the foldersync command test.
Ok do you have SSL checked on Default web site...if yes then removd.....also let me know authentication on it

Author

Commented:
on default web site,  anonymous integrated and basic are all checked, ssl is checked,  when unchecked it brings up a popup of the other virtual sites.  i have unchecked it.  iisreset and retested,

403 error at foldersync
If you are not running anything apart from Exchange under default web site then you need only Anonymous. and SSL should be unchecked....also make sure with below

/exadmin......Windows Integrated....NO SSL
/exchweb....Anonymous....NO SSL
Disable Antivirus and check and also once again follow KB 817379 Method 2
For starters The Default website should only have anonymous and integrated, and ssl enabled.

Author

Commented:
i am running OWA, rpc over http also.  these two last posts seem to conflict?
My post is a typo, it should state with out ssl.

Author

Commented:
thanks, i will try method 2 again.  should i delete the exchange-oma directory mentioned in item 8 since it already exists, or will it be overwritten.  it seems unclear on this point?

Author

Commented:
performed method 2 in detail.  http error 401 has returned.  hard to get past it.  we are using a SBS server and from 817379 the wizard should do the same thing.  either way, activesync still returns an error.
fixed used solution Setup iPhone and Exchange 2003 SP2 ActiveSync (Single Server) from DoDebug.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial