VOIP QOS Cisco 2800 and 1800s - Metro-Ethernet

cathchar
cathchar used Ask the Experts™
on
We have recently added some new Avaya phone systems to our network and are utilizing VOIP to connect our remote sites to our main site.  I have worked with the phone vendor in configuring the QOS in the routers to support this, but I am not sure I like the way it is configured.

We have 9 remote sites connecting to our main site via Metro Ethernet.  Each site has varying CIR from the carrier.  Only 3 of our remote sites have VOIP phones currently, and in the future we will be adding additional sites.

We have 1 policy-map that is applied to the physical interface where all the metro-E subinterfaces are.

I found a link on Cisco that discussed creating a hierarchical policy :
http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a0080114326.shtml

It showed the following example which looks like it might be a better and more flexible way to do this :

policy-map child
class voice
             priority 512

policy-map parent
class class-default
shape average 2000000
              service-policy child

interface ethernet0/0.1
service-policy parent

I like this because I can create a policy-map for each site, and apply them directly to the subinterfaces, rather than the entire physical interface.

Any opinions on this?  Would the hierarchical policy method do what I want? (shape the link to carriers CIR and prioritize voice traffic up to 512kbps)

The code below is an example of what we are currently using.  It is modified from the actual config to be posted here.
class-map match-any Site-B
 match access-group 100
class-map match-any Site-C
 match access-group 101
class-map match-any Site-D
 match access-group 102
class-map match-any VOICE
 match ip dscp ef
 
policy-map VOIP
 class VOICE
  priority 512
 class Site-B
  shape average 2850000 28500
 class Site-C
  shape average 1900000 19000
 class Site-D
  shape average 1900000 19000
  class class-default
  fair-queue
  random-detect dscp-based
 
interface GigabitEthernet0/0
 description To Metro-E
 no ip address
service-policy output VOIP
!
interface GigabitEthernet0/0.1
 description WAN interface to Site-B
  ip address 10.1.1.x 255.255.255.252
 !
interface GigabitEthernet0/0.2
 description WAN interface to Site-C
  ip address 10.1.1.x 255.255.255.252
 !
interface GigabitEthernet0/0.3
 description WAN interface to Site-D
  ip address 10.1.1.x 255.255.255.252

Open in new window

NetworkDiagram1.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Any assistance would be appreciated.  Thank you!  I have been browsing web and Experts-exchange for any similar postings and have yet to locate anything that helps me.  If you have a link to a similar question, that would be very helpful as well.  Thanks!
Timothy EstesSr. Voice Engineer

Commented:
I see you are grabbing EF marked traffig (hopefully RTP) and putting it in your priority queue, what I don't see is any signalling traffig getting handled by this policy. Typically signalling is marked as AF31.
Commented:
Yea I don't have any signalling in there at this time, mostly concerned with the actual VOIP traffic and getting that locked down.

I just really like the idea of setting up the QOS on a per sub-interface setting, rather than on the entire physical interface that houses all the subinterfaces.

I went ahead and applied the hierarchical qos policies last night and from what I can see, it is working as I was hoping.  If anyone can point out any negatives to this method, I'd be glad to hear them! :)

Thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial