I upgraded our system from AIX 5.3.9 to AIX 5.3.10; I have inconsistent filesets.

AIX25
AIX25 used Ask the Experts™
on
I have inconsistent filesets on our box.  I need help to troubleshoot this issue.
OUTPUTS:
# lppchk -vm3
lppchk:  The following filesets need to be installed or corrected to bring
         the system to a consistent state:

  bos.esagent 6.5.10.0                    (usr: COMMITTED, root: not installed)
  csm.server 1.7.1.0                      (not installed; requisite fileset)

lppchk:  The following describes dependencies from installed filesets
         on one or more of the filesets listed above:

Fileset bos.ecc_client.rte 5.3.10.0 requires:
  bos.esagent 6.5.10.0

Fileset csm.gui.websm 1.7.1.0 requires:
  csm.server 1.7.1.0

Fileset csm.hpsnm 1.4.1.0 requires:
  csm.server 1.7.1.0

Fileset csm.hpsnm 1.4.1.18 requires:
  csm.server 1.7.1.0


# lslpp -lcq | grep -i esagent
/usr/lib/objrepos:bos.esagent:6.5.10.0::COMMITTED:I:Electronic Service Agent :

In regards to the csm.server, I would like to remove it because we do not use it on our system.  But for the bos.esagent; with the command above, it looks installed but is not being seen by the system.  Please help troubleshoot this issue.

THanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Kerem ERSOYPresident

Commented:
Hi,

Will you post the output of

instfix -i |grep ML

here please? It seems that your upgrade process had some problems.

Cheers,
K.
Most Valuable Expert 2013
Top Expert 2013
Commented:
Hi again,

did you download the TL package, or did you use CDs?

Sometimes filesets get corrupted during download, but I also saw IBM CDs containing erroneous filesets.
Or was there an error during install?

Anyway, first of all you should try to cleanup the repository using 'installp -C', but I assume that you already did it, and moreover, it helps only in some cases.

Uninstalling the CSM server dependents should be easy -  but check beforehand what it's going to do:

installp -u  -p csm.gui.websm  

(and the other two filesets), where -p means 'preview'. If the preview shows everything OK, omit the -p flag and repeat.

You can of course use smitty as well.

In case of the esagent, you will have to reinstall. The upgrade CDs contain a base level fileset as far as I know, so best use

smitty install_all  

(smitty is easier when it comes to selecting from multi-volume CDs).

Select the base-level fileset of esagent (and the update filesets, should there be any), and, most important,
select "OVERWRITE same or newer versions?" to initiate a forced reinstall.

Should the reinstall not solve your problem, perform a complete uninstall including dependents before reinstalling.

An uninstall including dependents is done via

installp -u -g ...

(or use smitty remove and select  "REMOVE dependent software").

This should solve the issue.

wmp













Author

Commented:
Hello KeremE

# instfix -i |grep ML
    All filesets for 5.3.0.0_AIX_ML were found.
    All filesets for 5300-01_AIX_ML were found.
    All filesets for 5300-02_AIX_ML were found.
    All filesets for 5300-03_AIX_ML were found.
    All filesets for 5300-04_AIX_ML were found.
    All filesets for 5300-05_AIX_ML were found.
    All filesets for 5300-06_AIX_ML were found.
    All filesets for 5300-07_AIX_ML were found.
    All filesets for 5300-08_AIX_ML were found.
    All filesets for 5300-09_AIX_ML were found.
    Not all filesets for 5300-10_AIX_ML were found.
#

Let me know if you need anything else.
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Author

Commented:
Hello woolmilkporc,

I used a TL Package, I downloaded it once and ran the upgrade and it failed.  I thought it could be corrupted filesets, so then I went ahead and downloaded a fresh new copy of the TL package and tried it again and got the same error.

As far as the csm fileset, it has a depend csm.hpsnm 1.4.1.0 in which I will need to remove first. Then I will go ahead and remove csm.gui.websm 1.7.1.0.

I do not have the base install cd for the OS.  Is there a way to get the base install for esagent?

Thanks

Author

Commented:
Also, do you know what the esagent is used for? Is it vital for the OS? Thanks

Author

Commented:
I decided I don't need esagent.  I tried to remove the esagent and I got a fileset dependent error, which was bos.ecc_client.rte. I tried to remove it and recieved this error:

# installp -u  bos.ecc_client.rte
+-----------------------------------------------------------------------------+
                    Pre-deinstall Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...done
Results...

FAILURES
--------
  Filesets listed in this section failed pre-deinstall verification
  and will not be removed.

  Dependency Failures
  (Deinstall Operation)
  ---------------------
  SELECTED FILESETS:  The following is a list of filesets that you asked to
  remove.  They cannot be removed until all of their dependent filesets
  are also removed.  See subsequent lists for details of dependents.

    bos.ecc_client.rte 5.3.10.0               # Electronic Customer Care Run...

  MISCELLANEOUS FAILING DEPENDENTS:  The following filesets depend upon one or
  more of the selected filesets listed above.  As a result, these dependents
  must be removed before or with the selected filesets.  Various problems
  associated with these dependents are preventing the selected filesets from
  being removed.  See the "Dependent Failure Key" for failure reasons and
  possible recovery hints.

    ? bos.esagent 6.5.10.0                    # Electronic Service Agent

  Dependent Failure Key:
  "?" unclear why this fileset failed.  Use the software listing (lslpp
      command) and software verification facilities (lppchk command) to try
      to establish further information on this fileset.

  << End of Failure Section >>

FILESET STATISTICS
------------------
    1  Selected to be deinstalled, of which:
        1  FAILED pre-deinstall verification
  ----
    0  Total to be deinstalled


Pre-installation Failure/Warning Summary
----------------------------------------
Name                      Level           Pre-installation Failure/Warning
-------------------------------------------------------------------------------
bos.ecc_client.rte        5.3.10.0        Requisite failure

# lslpp -l  bos.ecc_client.rte
  Fileset                      Level  State      Description
  ----------------------------------------------------------------------------
Path: /usr/lib/objrepos
  bos.ecc_client.rte        5.3.10.0  COMMITTED  Electronic Customer Care
                                                 Runtime

Path: /etc/objrepos
  bos.ecc_client.rte        5.3.10.0  COMMITTED  Electronic Customer Care
                                                 Runtime

What do you recommend to do?
Most Valuable Expert 2013
Top Expert 2013

Commented:
Did you run 'installp -C' (=cleanup) after the failed attempts? Any output?

You can remove csm.gui.websm.1.7.1.0 using
installp -u -g csm.gui.websm

This will remove dependent filesets as well.

bos.esagent.6.5.10.0 contained in TL 10 should be an install (not upgrade) fileset and thus be installable the way I described it above ("OVERWRITE same or newer versions? -> Yes")

Btw. the kind of problems you describe is a bit strange for an update. Could it be that you used  'all_latest'  instead of  'update_all' ?

As for the incomplete TL 10: Issue after removing the erroneous packages:

oslevel -rl 5300-10

to see if missing or downlevel filesets for TL 10 still exist.

Install the missing ones, if any, from yor TL 10 package.

wmp




Most Valuable Expert 2013
Top Expert 2013

Commented:
OK, we "overlapped" once more.

Try installp -g ... to get rid of the dependencies.

Author

Commented:
Thanks woolmilkporc, I was able to remove bother filesets.  Now I run # lppchk -vm3 and I get no output, which is a good thing.  I run oslevel -s and still get:
# oslevel -s
5300-09-03-0918
I had before,
# oslevel -s
5300-09-02-0849

**It looks like it upgraded the service pack, but not the tech level.  Is it because I removed the csm and esagent filesets?? Do I need to reboot to get it to read the new tech level?

THanks
Most Valuable Expert 2013
Top Expert 2013

Commented:
oslevel -rl 5300-10 will show you what's missing to reach TL 10.
Please post!

wmp

Author

Commented:
# oslevel -rl 5300-10
Fileset                                 Actual Level           Recommended ML
-----------------------------------------------------------------------------
Java14.sdk                              1.4.2.225              1.4.2.250
Kerem ERSOYPresident

Commented:
Ok then just install the Java SDK. It seems that either your insptallp quit before it finished all filesets or there's a problem with Java14.sdk.

Either download it form the site or try to install from your present filesets.

Cheers,
K.

Most Valuable Expert 2013
Top Expert 2013

Commented:
Fine,
that's most probably going to be easy.

First, do you still use Java 1.4? Most people have Java5 or Java6 running.
If you don't need it, uninstall Java14.sdk, Java14.source etc. , but NOT Java14.license!

Should you need it, however - no problem.
Your TL 10 package (if downloaded from IBM) contains Java14 at level 1.4.2.250.
Just install what you're missing.
To perform a complete upgrade (not just sdk), issue
lslpp -l Java14.\*
and install the 1.4.2.250 versions of all the filesets you get listed.

Anyway - your system is technically at TL10, it's just the old 'lpp' thing that upgrading doesn't always work with Java filesets - for what reasons ever.

wmp



Author

Commented:
I tried installing Java14.sdk, but it kept failing...tried to force it.  I will remove java 14 sdk and source.  I have been meaning to upgrade to to Java5 anyways.

I went to remove Java14.sdk it will not allow me do to dependencies.
output:

# installp -u -p Java14.sdk
*******************************************************************************
installp PREVIEW:  deinstall operation will not actually occur.
*******************************************************************************

+-----------------------------------------------------------------------------+
                    Pre-deinstall Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...done
Results...

FAILURES
--------
  Filesets listed in this section failed pre-deinstall verification
  and will not be removed.

  Dependency Failures
  (Deinstall Operation)
  ---------------------
  SELECTED FILESETS:  The following is a list of filesets that you asked to
  remove.  They cannot be removed until all of their dependent filesets
  are also removed.  See subsequent lists for details of dependents.

    Java14.sdk 1.4.2.20                       # Java SDK 32-bit

  INSTALLED DEPENDENTS:  The following filesets are dependents of one or more
  of the selected filesets listed above.  These must be removed before
  or with the filesets that you selected.  To remove these dependents with
  the selected filesets, specify the option to automatically remove dependent
  software (-g flag).
  WARNING:  The fileset updates listed below have created dependencies from
  their filesets to one or more of the filesets that you are trying to
  remove.  If you choose to automatically remove dependent software, the
  entire dependent fileset will be removed (not just the update).  You
  may be able to reject the update to remove the dependency.

    bos.aixpert.cmds 5.3.0.0                  # AIX Security Hardening
    bos.aixpert.websm 5.3.0.0                 # AIX Security Hardening WebSM
    bos.installers.si 5.3.0.0                 # Solution Install software
    csm.gui.dcem 1.7.1.0                      # Distributed Command Executio...
    csm.hc_utils 1.7.1.0                      # Cluster Systems Management H...
    invscout.websm 2.2.0.7                    # Inventory Scout WebSM Firmwa...
    lum.base.gui 5.1.0.0                      # License Use Management Runti...
    lum.msg.en_US.base.gui 5.1.0.0            # LUM Gui Messages - U.S. Engl...
    sysmgt.help.en_US.websm 5.3.8.0           # WebSM Extended Helps - U.S. ...
    sysmgt.help.msg.en_US.websm 5.3.9.0       # WebSM Context Helps - U.S. E...
    sysmgt.msg.en_US.sguide.rte 5.3.0.0       # TaskGuide Viewer Messages - ...
    sysmgt.msg.en_US.websm.apps 5.3.0.10      # WebSM Client Apps. Messages ...
    sysmgt.sguide.rte 5.3.0.0                 # TaskGuide Runtime Environment
    sysmgt.websm.apps 5.3.0.40                # Web-based System Manager App...
    sysmgt.websm.diag 5.3.0.0                 # Web-based System Manager Dia...
    sysmgt.websm.framework 5.3.0.40           # Web-based System Manager Cli...
    sysmgt.websm.framework 5.3.7.0            # Web-based System Manager Cli...
    sysmgt.websm.framework 5.3.10.0           # Web-based System Manager Cli...
    sysmgt.websm.icons 5.3.0.40               # Web-based System Manager Icons
    sysmgt.websm.rte 5.3.0.40                 # Web-based System Manager Run...
    sysmgt.websm.rte 5.3.0.50                 # Web-based System Manager Run...
    sysmgt.websm.rte 5.3.7.0                  # Web-based System Manager Run...
    sysmgt.websm.rte 5.3.9.0                  # Web-based System Manager Run...
    sysmgt.websm.rte 5.3.10.0                 # Web-based System Manager Run...
    sysmgt.websm.webaccess 5.3.0.40           # WebSM Web Access Enablement
    sysmgtlib.framework.core 5.3.0.40         # System Management Service Li...
    sysmgtlib.libraries.apps 5.3.0.40         # System Management Service Li...

  << End of Failure Section >>

FILESET STATISTICS
------------------
    1  Selected to be deinstalled, of which:
        1  FAILED pre-deinstall verification
  ----
    0  Total to be deinstalled


******************************************************************************
End of installp PREVIEW.  No deinstall operation has actually occurred.
******************************************************************************

Will it be ok to remove all these dependencies??? THANKS

Author

Commented:
Please post what you can for today.  My day is at an end...  Hopefully we can finish this up tomorrow morning.
Most Valuable Expert 2013
Top Expert 2013

Commented:
No,

I wouldn't recommend to remove all these.

OK, your system would survive it, but I just don't feel very comfortable with the idea.

We can later revisit that option, but first - why did the upgrade to 1.4.2.250 fail? What error messages did you get?

I can't imagine that there shouldn't be a way to get it done.

wmp



Author

Commented:
smitty install_all output:

geninstall -I "a -cgNqwXY -J"  -Z   -d /tmp/AIX53TL10 -f File 2>&1

File:
    S:Java14.sdk                   1.4.2.0
    S:Java14.sdk                   1.4.2.250


+-----------------------------------------------------------------------------+
                    Pre-installation Verification...
+-----------------------------------------------------------------------------+
Verifying selections...done
Verifying requisites...done
Results...

WARNINGS
--------
  Problems described in this section are not likely to be the source of any
  immediate or serious failures, but further actions may be necessary or
  desired.

  Already Installed
  -----------------
  The number of selected filesets that are either already installed
  or effectively installed through superseding filesets is 1.  See
  the summaries at the end of this installation for details.

  NOTE:  Base level filesets may be reinstalled using the "Force"
  option (-F flag), or they may be removed, using the deinstall or
  "Remove Software Products" facility (-u flag), and then reinstalled.

  << End of Warning Section >>
SUCCESSES
---------
  Filesets listed in this section passed pre-installation verification
  and will be installed.

  Selected Filesets
  -----------------
  Java14.sdk 1.4.2.250                        # Java SDK 32-bit

  << End of Success Section >>

+-----------------------------------------------------------------------------+
                   BUILDDATE Verification ...
+-----------------------------------------------------------------------------+
Verifying build dates...done
FILESET STATISTICS
------------------
    2  Selected to be installed, of which:
        1  Passed pre-installation verification
        1  Already installed (directly or via superseding filesets)
  ----
    1  Total to be installed

+-----------------------------------------------------------------------------+
                         Installing Software...
+-----------------------------------------------------------------------------+

installp:  APPLYING software for:
        Java14.sdk 1.4.2.250


. . . . . << Copyright notice for Java14.sdk >> . . . . . . .
 Licensed Materials - Property of IBM

 5648C9802
   Copyright International Business Machines Corp. 1996, 2008.
JAVA(tm) and HOTJAVA(tm) web development products are owned and licensed
exclusively by Sun Microsystems, Inc.  Copyright 1992-97 Sun Microsystems,
Inc.  All rights reserved.  JAVA, HOTJAVA, the JAVA/HOTJAVA Logos, Sun,
Sun Microsystems, and the Sun Logo are trademarks or registered trademarks
of Sun Microsystems, Inc. in the U.S. and other countries.
For full information regarding copyrights and trademarks associated with
this software, see the URL http://java.sun.com/copy_trademarks.html.
Detailed licensing terms for this software are set forth at the URL
http://java.sun.com/nav/business/index.html  To get copyright, trademark or
license information without using a WWW browser, send electronic mail
containing your query to licensing@java.sun.com.
   Copyright Sun Microsystems, Inc. 1992, 1997.
 All rights reserved.
 US Government Users Restricted Rights - Use, duplication or disclosure
 restricted by GSA ADP Schedule Contract with IBM Corp.
. . . . . << End of copyright notice for Java14.sdk >>. . . .

ln: A file or directory in the path name does not exist.
update:  Failed while executing the Java14.sdk.pre_u script.


0503-464 installp:  The installation has FAILED for the "usr" part
        of the following filesets:
        Java14.sdk 1.4.2.250
installp:  Cleaning up software for:
        Java14.sdk 1.4.2.250

Finished processing all filesets.  (Total time:  1 secs).

+-----------------------------------------------------------------------------+
                                Summaries:
+-----------------------------------------------------------------------------+

Pre-installation Failure/Warning Summary
----------------------------------------
Name                      Level           Pre-installation Failure/Warning
-------------------------------------------------------------------------------
Java14.sdk                1.4.2.0         Already superseded by 1.4.2.20


Installation Summary
--------------------
Name                        Level           Part        Event       Result
-------------------------------------------------------------------------------
Java14.sdk                  1.4.2.250       USR         APPLY       FAILED
Java14.sdk                  1.4.2.250       USR         CLEANUP     SUCCESS

[BOTTOM]
Most Valuable Expert 2013
Top Expert 2013
Commented:
Hmm,

might indeed be a packaging error.

Do you have an IBM ID?

If yes, you could try to download the latest Java 1.4 from here -

https://www14.software.ibm.com/webapp/iwm/web/reg/download.do?source=dka&S_PKG=dka14232ww&S_TACT=105AGX05&S_CMP=JDK&lang=en_US&cp=UTF-8#new

Select "32-bit SDK 1.4.2 base images (at latest APAR level; in installp format)", then 'License',  'Base SDK' and maybe 'src', if you need it.

Install using 'force', because we have a complete package at the latest level here, not just an upgrade fileset.

wmp
Most Valuable Expert 2013
Top Expert 2013

Commented:
Btw...
I remember that we once had a similar issue in old AIX 5.2 days.
The whole thing ended up with IBM shipping a fix for bos.rte.install to get rid of the 'oslevel' message,
and leaving the rest as it was.
This just as a hint for you on how important some Java upgrades are.

Author

Commented:
Like always, woolmilkporc finds a way! Thank you.  I went to IBM's site and downloaded the license, src, and sdk for Java14 lastest apar.  It failed at first, bc for some reason when I untar the file it changed the owner and group on the files.  Tweaked a couple of persmissions and forced to overwrite install.  Finally, came back with success.  Ran # oslevel -rl 5300-10 and came back with no output.  Ran # oslevel -s
and got 5300-10-01-0921.  Thank you!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial