RDP 5 clients on Windos Server 2008

BuchananHauling
BuchananHauling used Ask the Experts™
on
I have a new install of Windows Server 2008 Terminal Server and I am trying to get the client's thin clients to connect.  I believe the thin clients are using RDP v5 and I can not figure out how to change the RDP level for the Terminal Server.  When I go to make a new connection the drop down box is grayed out for "Connection type".  How do I change this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Henrik JohanssonSystems engineer
Top Expert 2008

Commented:
I haven't understood why it's a dropdown box when it's not possibly to change it.

In System Properties (sysdm.cpl) -> Remote tab, make sure the option 'Allow connections from computers running any version of Remote Desktop'

In Terminal Server Configuration:
Double-click on RDP-TCP and in the Properties dialog on General tab, set the security dropdowns to be 'Security layer'=Negotiate and 'Encryption level'=Client compatible.

Author

Commented:
I changed those settings and the thin client is still unable to connect.
Henrik JohanssonSystems engineer
Top Expert 2008

Commented:
What error do you get when tyring to connect?
Anything in eventlog?

It can be a firewall issue blocking port 3389/TCP.
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
Don't see anything in the event logs.  On the thin client it acts like it is trying to connect and the screen flashes for a milisecond.  No error messages and no logs that I can find on the thin client.  The thin client does show that it is using RDP5.  It is a Neoware Thin Client, FYI.  I can connect to the server from the XP worsktations and other 2008 servers so I don't think it is a firewall issue.  I tried disabling the firewall and that did not help.
Henrik JohanssonSystems engineer
Top Expert 2008

Commented:
Any difference when trying to connect by using IP-address or servername with/without DNS suffix?

Author

Commented:
None work...
Henrik JohanssonSystems engineer
Top Expert 2008

Commented:
This forum thread sounds like the same issue. See if it helps to set 'Security layer' to 'RDP Security Layer' and 'Encryption level' to Low. If still problem, remove the TS role as suggested in thread and do the configuration before installing TS role to see if it works when running the server in 'Remote Desktop for Administration' mode. Make sure NLA requirement isn't selected.
http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/700488cd-a872-47e5-85a7-595f050afc10
Windows Server 2008 Requires at least RDP 6.0 according to Microsoft Tech Support.  There is no way to get 2008 to support anything less than RDP 6.  Microsoft Tech support guy said this was due to security settings in Windows 2008 that require RDP 6 and higher.  FYI.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial