Local activation permissin to the IIS WAMREG Admin Service required

rkkhandelwal54
rkkhandelwal54 used Ask the Experts™
on
The BPA of SBS 2008 throws up this issue:
    Local activation permissin to the IIS WAMREG Admin Service required:
    The Network Service is missing local activation permissions to the IIS WAMREG admin Service in accordance with the event ID 10016 in the system event log. For more information, see KB "Event ID error messages 10016 and 10017 are logged in the System log after you install Windows SharePoint Services 3.0" at http://go.microsoft.com/fwlink/?LinkId=128063.

The instructions in the KB article have been followed but still the issue does not resolve. Any suggestions?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
those are pretty common errors and are usually resolved following those instructions from M$ (here's my 'visual' version if it helps).
http://blog.brainlitter.com/archive/2009/03/03/sharepoint-10016-clsid-dcom-errors-and-how-you-fix-em.aspx
Are you giving the right account the local activation rights?  Local Network Service?
 

Author

Commented:
Thanks for the post. Event viewer does not show any error but the Best Practice Analyzer still shows the error.

Author

Commented:
Thanks for the resolution. There is no message in the Event Logs however the Best Practice Analyzer still shows it.

Commented:
Nice and easy fix.  This was an outstanding instructional for fixing the error.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial