Microsoft Volume Shadow Copy Service + Swprv.dll Problem

mivbinfotech
mivbinfotech used Ask the Experts™
on
Hi

We are having trouble taking System State Backups, from NT Backup, the problem seems to be from Volume Shadow Copy Service from MS, when trying to register all DLLS all of them register except 2 :

swprv.dll
msxml3.dll (however msxml4.dll registers)

below is the error i get fro swprv.dll in App Log



Event Type:      Error
Event Source:      VSS
Event Category:      None
Event ID:      12289
Date:            7/19/2009
Time:            6:26:04 PM
User:            N/A
Computer:      NEWSERVER
Description:
Volume Shadow Copy Service error: Unexpected error CreateService(swprv,Microsoft Software Shadow Copy Provider,SERVICE_CHANGE_CONFIG,SERVICE_WIN32_OWN_PROCESS,SERVICE_ERROR_NORMAL,%SystemRoot%\System32\svchost.exe -k swprv,RPCSS).  hr = 0x80070002.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 2d 20 43 6f 64 65 3a 20   - Code:
0008: 53 50 52 53 57 50 52 43   SPRSWPRC
0010: 30 30 30 30 30 38 30 38   00000808
0018: 2d 20 43 61 6c 6c 3a 20   - Call:
0020: 53 50 52 53 57 50 52 43   SPRSWPRC
0028: 30 30 30 30 30 37 35 31   00000751
0030: 2d 20 50 49 44 3a 20 20   - PID:  
0038: 30 30 30 30 35 36 35 36   00005656
0040: 2d 20 54 49 44 3a 20 20   - TID:  
0048: 30 30 30 30 35 36 31 32   00005612
0050: 2d 20 43 4d 44 3a 20 20   - CMD:  
0058: 72 65 67 73 76 72 33 32   regsvr32
0060: 20 73 77 70 72 76 2e 64    swprv.d
0068: 6c 6c 20 20 20 20 20 20   ll      
0070: 2d 20 55 73 65 72 3a 20   - User:
0078: 50 52 49 4d 41 58 5c 41   PRIMAX\A
0080: 64 6d 69 6e 69 73 74 72   dministr
0088: 61 74 6f 72 20 20 20 20   ator    
0090: 2d 20 53 69 64 3a 20 20   - Sid:  
0098: 53 2d 31 2d 35 2d 32 31   S-1-5-21
00a0: 2d 32 30 31 35 36 37 39   -2015679
00a8: 35 30 37 2d 36 38 39 38   507-6898
00b0: 35 35 32 35 33 2d 33 30   55253-30
00b8: 37 32 36 38 31 34 30 38   72681408
00c0: 2d 35 30 30 20 20 20 20   -500    
00c8: 2d 20 45 72 72 6f 72 3a   - Error:
00d0: 43 72 65 61 74 65 53 65   CreateSe
00d8: 72 76 69 63 65 28 73 77   rvice(sw
00e0: 70 72 76 2c 4d 69 63 72   prv,Micr
00e8: 6f 73 6f 66 74 20 53 6f   osoft So
00f0: 66 74 77 61 72 65 20 53   ftware S
00f8: 68 61 64 6f 77 20 43 6f   hadow Co
0100: 70 79 20 50 72 6f 76 69   py Provi
0108: 64 65 72 2c 53 45 52 56   der,SERV
0110: 49 43 45 5f 43 48 41 4e   ICE_CHAN
0118: 47 45 5f 43 4f 4e 46 49   GE_CONFI
0120: 47 2c 53 45 52 56 49 43   G,SERVIC
0128: 45 5f 57 49 4e 33 32 5f   E_WIN32_
0130: 4f 57 4e 5f 50 52 4f 43   OWN_PROC
0138: 45 53 53 2c 53 45 52 56   ESS,SERV
0140: 49 43 45 5f 45 52 52 4f   ICE_ERRO
0148: 52 5f 4e 4f 52 4d 41 4c   R_NORMAL
0150: 2c 25 53 79 73 74 65 6d   ,%System
0158: 52 6f 6f 74 25 5c 53 79   Root%\Sy
0160: 73 74 65 6d 33 32 5c 73   stem32\s
0168: 76 63 68 6f 73 74 2e 65   vchost.e
0170: 78 65 20 2d 6b 20 73 77   xe -k sw
0178: 70 72 76 2c 52 50 43 53   prv,RPCS
0180: 53 29 20 20 20 20 20 20   S)      

for msxml3.dll i get the following

DLLRegisterServer in msxml3.dll failed
Return Code was: 0x800700005

I have reinstalled MSXML3 Service Pack 3 from MS Site, with no avail

I am using admin account, so permissions is not an issue, I have tried updating various patches available on  windows site no avail

My OS is Windows 2003 R2 Server Standard Editon SP2

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Please list the updates that you have tried, so experts can assist you properly.
To attempt a fix for the msxml3 issue, download Xmlinst.exe from http://www.microsoft.com/downloads/details.aspx?FamilyID=1E6185D7-E4E4-43B1-8056-0E5ECD15A88A&displaylang=en and place it in \Windows\System32. Open a command prompt using a local admin account, and run "Xmlinst.exe -u". Then try re-registering msxml3.dll with Regsvr32 by running "REGSVR32 MSXML3.DLL". Finally, run Xmlinst.exe again, and reboot.
After the reboot, try "regsvr32 /u swprv.dll" and "regsvr32 /i swprv.dll".

Author

Commented:
Ok, the above  has worked me through the VSS Problem Now I am able to take a system state backup on to a file,

But when I try the same backup on a Tape I get the following error;

Error: C: is not a valid drive, or you do not have access.

The Tape is new, and I have checked it, I will try again with a new Tape, using Windows 2003 SP1,

Any ideas, why this happens.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial