Call Manager Express on Cisco 2811 configuration setup help

naiadmin
naiadmin used Ask the Experts™
on
I have just installed CME 7 on my 2811 and I would like some configuration advice and assistance.  
I need some help with the phone loads?  I have a DHCP and tftp server already running...is it best to leave the phone loads on the router? or can I put them on my server and push them to the phones?  
I will add the appropriate VLAN's
I would like to do 100 for phones and 200 for data
I have several switches that can support 802.1q and one full layer 3 swtich (cisco 3550)
What phone loads should I be using?  I did the full CME install to the routers flash, so I believe I have all the loads on the router already? I only see the ringtones..I must have to get the phone loads seperate and upload them?
I will be connecting this to my SIP provider and will be adding an FXO card to allow for pots line useage...I will set up a dial-peer group for the pots lines. advice around that would be great
I will have 1 pots line and the SIP service
I would like to dial 8 to get to the pots line and 9 to get to SIP

I've attached a config that I have been working with...I have incorporated many pieces of configs I've found on EE and cisco...please provide feedback and insight.

This is a fresh install so not a whole lot of security or other hardening has been applied...I do have an ASA sitting between this and the internet connection and I will lock this down.  I'm more interested in getting the CME pieces at this point.  :-)

router#sh run
Building configuration...

Current configuration : 6584 bytes
!
! Last configuration change at 11:18:55 pacific Sun Jul 19 2009
! NVRAM config last updated at 11:18:51 pacific Sun Jul 19 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password ********
!
no aaa new-model
clock timezone pacific -8
clock summer-time pacific recurring
!
ip source-route
!
!
ip cef
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 2
 rule 1 /^9\(.......\)$/ /+1714\1/
 rule 2 /^9\(..........\)$/ /+1\1/
 rule 3 /^9\(.*\)$/ /+\1/
 rule 4 /^9\(...........\)$/ /+\1/
 rule 5 /^9011\(.*\)$/ /+\1/
!
!
voice-card 0
!
!
!
archive
 log config
  hidekeys
!
!
!
class-map match-any voice-signaling
 match  dscp af31
class-map match-any voice-udp
 description Class Mapping for VoIP RTP
 match  dscp ef
!
!
policy-map voice-qos
 description VoIP QoS
 class voice-udp
    priority 256
 class voice-signaling
    bandwidth 128
 class class-default
    fair-queue
!
!
!
!
interface FastEthernet0/0
 ip address 172.31.0.11 255.255.255.0
 ip helper-address 172.31.0.9
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface BRI0/1/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.31.0.1
!
!
ip http server
ip http path flash:
!
!
!
!
!
control-plane
!
!
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
!
dial-peer voice 101 voip
 translation-profile outgoing SIPCALL
 destination-pattern 9[2-9]......T
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 clid network-number MY NUMBER <--my number removed
 no vad
!
dial-peer voice 202 voip
 translation-profile outgoing SIP
 destination-pattern 9714.......
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 203 voip
 translation-profile outgoing SIP
 destination-pattern 9[2-9]......
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 204 voip
 translation-profile outgoing SIP
 destination-pattern 1[2-9].........
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 205 voip
 translation-profile outgoing SIP
 destination-pattern 9011T
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 199 voip
 translation-profile incoming voip
 translate-outgoing calling 91
 incoming called-number xxxxxxxx <--my number removed
!
dial-peer voice 206 voip
 translation-profile outgoing SIP
 destination-pattern 1714.......
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--Target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 207 voip
 translation-profile outgoing SIP
 destination-pattern 714.......
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <-- target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 208 voip
 translation-profile outgoing SIP
 destination-pattern 1[2-9].........
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 209 voip
 translation-profile outgoing SIP
 destination-pattern 011T
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 210 voip
 translation-profile outgoing SIP
 destination-pattern *..
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 211 voip
 translation-profile outgoing SIP
 destination-pattern *1
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 212 voip
 translation-profile outgoing SIP
 destination-pattern *67.......
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 213 voip
 translation-profile outgoing SIP
 destination-pattern *671..........
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 214 voip
 translation-profile outgoing SIP
 destination-pattern *123
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 200 voip
 translation-profile outgoing SIP
 destination-pattern 9[2-9]11
 voice-class codec 1
 session protocol sipv2
 session target dns:x.x.x.x <--target removed
 dtmf-relay rtp-nte
 no vad
!
!
sip-ua
 authentication username ******** password 7 ********
 no remote-party-id
 retry invite 4
 retry response 3
 retry bye 2
 retry cancel 2
 retry register 5  
 timers register 250
 mwi-server dns:x.x.x.x expires 3600 port 5060 transport udp

unsolicited
 registrar dns:x.x.x.x expires 3600
 sip-server dns:x.x.x.x
!
!
gatekeeper
 shutdown
!
!
telephony-service
 em logout 0:0 0:0 0:0
 max-ephones 24
 max-dn 48
 service phone displayIdleTimeout 00:30
 service phone displayOnDuration 1:00
 timeouts interdigit 8
 system message CME 7.0
 url services /phone-xml.berbee.com/menu.xml
 time-zone 12
 time-format 24
 dialplan-pattern 1 xxxxxxxx extension-length 4 <--advice around pattern
 voicemail *123
 max-conferences 8 gain -6
 call-forward pattern .T
 moh music-on-hold.au
 web admin system name XXXXX secret 5 XXXXXXX
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 after-hours block pattern 1 1900 7-24
 after-hours block pattern 2 1976 7-24
 create cnf-files version-stamp 7960 Jul 19 2009 10:58:43
!
!
line con 0
line aux 0
line vty 0 4
 password xxxxxxxx
 login
!
scheduler allocate 20000 1000
ntp server 172.31.0.3
end

Please let me know if additional info is required...i have tried to put in as much detail as possible...but I know i may have missed something...

thx
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
*Update*
I would like to use SCCP to the CME and register my CME with the SIP provider?  does this make sense?
If the phone are running the SIP software then I don't need the CME i can just register the phone directly to the SIP provider...I want to have my phones register to the CME and leverage the CME functionality...Thoughts?

Author

Commented:
The phones are all working internall correctly...I believe the issue may be related to the ASA that sits in front of the CME box...I have a single dynamic address ...I'm forwarding SIP, STUN, RTP, etc at the CME...I'm not sure if this is why CME does not register with the SIP provider? I have read that NAT and CME don't play that well together...?
I have a SIP phone that registers and works fine...CME is not working fine...

Some log dumps
router# sh sip-ua register status
Line          peer           expires(sec)  registered   P-Associated-URI
============  =============  ============  ===========  ================
100                               20001       0             no
101                               20002       0             no
102                               20003       0             no
103                               20004       0             no
15                                20007       0             no
A10002                            20006       0             no
A10102    



router# sh sip-ua service
SIP Service is up

router# sh sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70
SIP DNS SRV version: 2 (rfc 2782)
NAT Settings for the SIP-UA
Role in SDP: NONE
Check media source packets: DISABLED
Maximum duration for a telephone-event in NOTIFYs: 2000 ms
SIP support for ISDN SUSPEND/RESUME: ENABLED
Redirection (3xx) message handling: ENABLED
Reason Header will override Response/Request Codes: DISABLED
Out-of-dialog Refer: DISABLED
Presence support is DISABLED
protocol mode is ipv4

SDP application configuration:
 Version line (v=) required
 Owner line (o=) required
 Timespec line (t=) required
 Media supported: audio video image
 Network types supported: IN
 Address types supported: IP4 IP6
 Transport types supported: RTP/AVP udptl



router#sh sip-ua calls
SIP UAC CALL INFO

   Number of SIP User Agent Client(UAC) calls: 0

SIP UAS CALL INFO

   Number of SIP User Agent Server(UAS) calls: 0


router#sh sip-ua mwi
MWI type: 2
MWI server: dns:mysipprovider.com
MWI expires: 3600
MWI port: 5060
MWI transport type: UDP
MWI unsolicited
MWI server IP address:
0
0
0
0
0
0
0
0
MWI ipaddr cnt 0:
MWI ipaddr idx 0:
MWI server: 0.0.0.0, port 0, transport 1
MWI server dns lookup retry cnt: 1714
Top Expert 2008

Commented:
I know you said your phones were working but you may check to see if they are downloading the proper loads below is an ecample of what you need to code. First off in version 7 CME moved to a directory structure for all the flash software (before it was dumped in the root of the Flash.. big mess) now you have to pay close atention to the alias syntax as you need the alias to specifiy in the "telephony-service" the phone loads themselves for each phone type.
tftp-server flash:/phones/7902/CP7902080002SCCP060817A.sbin alias CP7902080002SCCP060817A.sbin
tftp-server flash:/phones/7940_7960/P00308000500.bin alias P00308000500.bin
tftp-server flash:/phones/7940_7960/P00308000500.loads alias P00308000500.loads
tftp-server flash:/phones/7940_7960/P00308000500.sb2 alias P00308000500.sb2
tftp-server flash:/phones/7940_7960/P00308000500.sbn alias P00308000500.sbn
tftp-server flash:/phones/7914/S00105000300.sbn alias S00105000300.sbn
tftp-server flash:/phones/7915/B015-1-0-2.SBN alias B015-1-0-2.SBN
tftp-server flash:/phones/7916/B016-1-0-2.SBN alias B016-1-0-2.SBN
tftp-server flash:/phones/7936/cmterm_7936.3-3-15-0.bin alias cmterm_7936.3-3-15-0.bin
tftp-server flash:/phones/7937/apps37sccp.1-1-1-1.bin alias apps37sccp.1-1-1-1.bin
tftp-server flash:/phones/3951/BOOT3951.0-0-0-9.zz alias BOOT3951.0-0-0-9.zz
tftp-server flash:/phones/3951/DSP3951.0-0-0-2.zz alias DSP3951.0-0-0-2.zz
tftp-server flash:/phones/3951/SIP3951.8-1-2-0.zz alias SIP3951.8-1-2-0.zz
tftp-server flash:/phones/3951/SIP3951.8-1-2.loads alias SIP3951.8-1-2.loads
tftp-server flash:/phones/521_524/cp524g-08-01-13.bin alias cp524g-08-01-13.bin
tftp-server flash:/phones/525/spa525g-7-1-7.bin alias spa525g-7-1-7.bin
tftp-server flash:/phones/7921/APPS-1.2.1.SBN alias APPS-1.2.1.SBN
tftp-server flash:/phones/7921/CP7921G-1.2.1.LOADS alias CP7921G-1.2.1.LOADS
tftp-server flash:/phones/7921/GUI-1.2.1.SBN alias GUI-1.2.1.SBN
tftp-server flash:/phones/7921/SYS-1.2.1.SBN alias SYS-1.2.1.SBN
tftp-server flash:/phones/7921/TNUX-1.2.1.SBN alias TNUX-1.2.1.SBN
tftp-server flash:/phones/7921/TNUXR-1.2.1.SBN alias TNUXR-1.2.1.SBN
tftp-server flash:/phones/7921/WLAN-1.2.1.SBN alias WLAN-1.2.1.SBN
tftp-server flash:/phones/7925/APPSH-1.3.1.SBN alias APPSH-1.3.1.SBN
tftp-server flash:/phones/7925/CP7925G-1.3.1.LOADS alias CP7925G-1.3.1.LOADS
tftp-server flash:/phones/7925/GUIH-1.3.1.SBN alias GUIH-1.3.1.SBN
tftp-server flash:/phones/7925/SYSH-1.3.1.SBN alias SYSH-1.3.1.SBN
tftp-server flash:/phones/7925/TNUXH-1.3.1.SBN alias TNUXH-1.3.1.SBN
tftp-server flash:/phones/7925/WLANH-1.3.1.SBN alias WLANH-1.3.1.SBN
tftp-server flash:/phones/7906_7911/SCCP11.8-3-5S.loads alias SCCP11.8-3-5S.loads
tftp-server flash:/phones/7906_7911/term11.default.loads alias term11.default.loads
tftp-server flash:/phones/7906_7911/term06.default.loads alias term06.default.loads
tftp-server flash:/phones/7906_7911/cnu11.8-3-4-16.sbn alias cnu11.8-3-4-16.sbn
tftp-server flash:/phones/7906_7911/apps11.8-3-4-16.sbn alias apps11.8-3-4-16.sbn
tftp-server flash:/phones/7906_7911/dsp11.8-3-4-16.sbn alias dsp11.8-3-4-16.sbn
tftp-server flash:/phones/7906_7911/jar11sccp.8-3-4-16.sbn alias jar11sccp.8-3-4-16.sbn
tftp-server flash:/phones/7906_7911/cvm11sccp.8-3-4-16.sbn alias cvm11sccp.8-3-4-16.sbn
tftp-server flash:/phones/7931/SCCP31.8-3-5S.loads alias SCCP31.8-3-5S.loads
tftp-server flash:/phones/7931/cnu31.8-3-4-16.sbn alias cnu31.8-3-4-16.sbn
tftp-server flash:/phones/7931/term31.default.loads alias term31.default.loads
tftp-server flash:/phones/7931/apps31.8-3-4-16.sbn alias apps31.8-3-4-16.sbn
tftp-server flash:/phones/7931/dsp31.8-3-4-16.sbn alias dsp31.8-3-4-16.sbn
tftp-server flash:/phones/7931/jar31sccp.8-3-4-16.sbn alias jar31sccp.8-3-4-16.sbn
tftp-server flash:/phones/7931/cvm31sccp.8-3-4-16.sbn alias cvm31sccp.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/SCCP41.8-3-5S.loads alias SCCP41.8-3-5S.loads
tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads
tftp-server flash:/phones/7941_7961/cnu41.8-3-4-16.sbn alias cnu41.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/apps41.8-3-4-16.sbn alias apps41.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/dsp41.8-3-4-16.sbn alias dsp41.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/jar41sccp.8-3-4-16.sbn alias jar41sccp.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/cvm41sccp.8-3-4-16.sbn alias cvm41sccp.8-3-4-16.sbn
tftp-server flash:/phones/7942_7962/SCCP42.8-3-5S.loads alias SCCP42.8-3-5S.loads
tftp-server flash:/phones/7942_7962/term42.default.loads alias term42.default.loads
tftp-server flash:/phones/7942_7962/term62.default.loads alias term62.default.loads
tftp-server flash:/phones/7942_7962/cnu42.8-3-4-16.sbn alias cnu42.8-3-4-16.sbn
tftp-server flash:/phones/7942_7962/dsp42.8-3-4-16.sbn alias dsp42.8-3-4-16.sbn
tftp-server flash:/phones/7942_7962/apps42.8-3-4-16.sbn alias apps42.8-3-4-16.sbn
tftp-server flash:/phones/7942_7962/jar42sccp.8-3-4-16.sbn alias jar42sccp.8-3-4-16.sbn
tftp-server flash:/phones/7942_7962/cvm42sccp.8-3-4-16.sbn alias cvm42sccp.8-3-4-16.sbn
tftp-server flash:/phones/7945_7965/SCCP45.8-3-5S.loads alias SCCP45.8-3-5S.loads
tftp-server flash:/phones/7945_7965/term45.default.loads alias term45.default.loads
tftp-server flash:/phones/7945_7965/term65.default.loads alias term65.default.loads
tftp-server flash:/phones/7945_7965/cnu45.8-3-4-16.sbn alias cnu45.8-3-4-16.sbn
tftp-server flash:/phones/7945_7965/dsp45.8-3-4-16.sbn alias dsp45.8-3-4-16.sbn
tftp-server flash:/phones/7945_7965/apps45.8-3-4-16.sbn alias apps45.8-3-4-16.sbn
tftp-server flash:/phones/7945_7965/jar45sccp.8-3-4-16.sbn alias jar45sccp.8-3-4-16.sbn
tftp-server flash:/phones/7945_7965/cvm45sccp.8-3-4-16.sbn alias cvm45sccp.8-3-4-16.sbn
tftp-server flash:/phones/7970_7971/SCCP70.8-3-5S.loads alias SCCP70.8-3-5S.loads
tftp-server flash:/phones/7970_7971/term70.default.loads alias term70.default.loads
tftp-server flash:/phones/7970_7971/term71.default.loads alias term71.default.loads
tftp-server flash:/phones/7970_7971/cnu70.8-3-4-16.sbn alias cnu70.8-3-4-16.sbn
tftp-server flash:/phones/7970_7971/apps70.8-3-4-16.sbn alias apps70.8-3-4-16.sbn
tftp-server flash:/phones/7970_7971/dsp70.8-3-4-16.sbn alias dsp70.8-3-4-16.sbn
tftp-server flash:/phones/7970_7971/jar70sccp.8-3-4-16.sbn alias jar70sccp.8-3-4-16.sbn
tftp-server flash:/phones/7970_7971/cvm70sccp.8-3-4-16.sbn alias cvm70sccp.8-3-4-16.sbn
tftp-server flash:/phones/7975/SCCP75.8-3-5S.loads alias SCCP75.8-3-5S.loads
tftp-server flash:/phones/7975/cnu75.8-3-4-16.sbn alias cnu75.8-3-4-16.sbn
tftp-server flash:/phones/7975/term75.default.loads alias term75.default.loads
tftp-server flash:/phones/7975/apps75.8-3-4-16.sbn alias apps75.8-3-4-16.sbn
tftp-server flash:/phones/7975/dsp75.8-3-4-16.sbn alias dsp75.8-3-4-16.sbn
tftp-server flash:/phones/7975/cvm75sccp.8-3-4-16.sbn alias cvm75sccp.8-3-4-16.sbn
tftp-server flash:/phones/7975/jar75sccp.8-3-4-16.sbn alias jar75sccp.8-3-4-16.sbn
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias  en_bacd_xferto_operator.au
 
telephony-service
 load 7902 CP7902080002SCCP060817A
 load 7906 SCCP11.8-3-5S
 load 7911 SCCP11.8-3-5S
 load 7914 S00105000300
 load 7915-12 B015-1-0-2
 load 7915-24 B015-1-0-2
 load 7916-12 B016-1-0-2
 load 7916-24 B016-1-0-2
 load 7921 CP7921G-1.2.1
 load 7925 CP7925G-1.3.1
 load 7931 SCCP31.8-3-5S
 load 7936 cmterm_7936.3-3-15-0
 load 7937 apps37sccp.1-1-1-1
 load 7960-7940 P00308000500
 load 7941 SCCP41.8-3-5S
 load 7961 SCCP41.8-3-5S
 load 7941GE SCCP41.8-3-5S
 load 7961GE SCCP41.8-3-5S
 load 7970 SCCP70.8-3-5S
 load 7971 SCCP70.8-3-5S
 load 7942 SCCP42.8-3-5S
 load 7945 SCCP45.8-3-5S
 load 7962 SCCP42.8-3-5S
 load 7965 SCCP45.8-3-5S
 load 7975 SCCP75.8-3-5S
 load 521G-524G cp524g-08-01-13
 load 525G spa525g-7-1-7

Open in new window

Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
bkepford - your are right on the money...the phone are not downloading the correct load...they are working, but they do errror on the load...I figured I was doing something wrong...
question - when I look in flash, I don't see the Phones directory? Do I need to create that...I agree it would make things cleaner...and previous versions of CME made managing Flash exciting :-)

below is contents of flash:
router#sh flash
-#- --length-- -----date/time------ path
1       820224 Jul 25 2005 01:59:50 COMMON.TAR
2         1038 Jul 25 2005 02:00:10 home.shtml
3      1208320 Jul 25 2005 02:01:04 IPS.TAR
4            0 Feb 27 2009 12:14:32 GUI
5     45737148 Mar 01 2009 14:24:58 c2800nm-ipvoice_ivs-mz.124-22.YB.bin
6       763392 Jul 25 2005 01:59:32 ES.TAR
7       113152 Jul 25 2005 02:00:26 HOME.TAR
8      3085312 Jul 25 2005 01:59:14 SDM.TAR
9            0 Feb 27 2009 11:47:08 FLASH
10      504643 Jul 25 2005 02:00:44 128MB.SDF
11        5134 Jul 19 2009 10:21:18 7970-71-75-Background-readme-v1.txt
12     2593969 Jul 19 2009 10:21:30 APPS-1.2.1.SBN
13     2925555 Jul 19 2009 10:21:46 apps11.8-4-1-23.sbn
14     2925555 Jul 19 2009 10:22:02 apps31.8-4-1-23.sbn
15     7892498 Jul 19 2009 10:22:42 apps37sccp.1-2-1-0.bin
16     2915997 Jul 19 2009 10:22:58 apps41.8-4-1-23.sbn
17     2918613 Jul 19 2009 10:23:12 apps42.8-4-1-23.sbn
18     2918613 Jul 19 2009 10:23:28 apps45.8-4-1-23.sbn
19     2915997 Jul 19 2009 10:23:46 apps70.8-4-1-23.sbn
20     2918613 Jul 19 2009 10:24:00 apps75.8-4-1-23.sbn
21       13301 Jul 19 2009 10:24:02 CME-7-1-full-readme-v.1.1.txt
22      463556 Jul 19 2009 10:24:04 cnu11.8-4-1-23.sbn
23      464028 Jul 19 2009 10:24:08 cnu31.8-4-1-23.sbn
24      459836 Jul 19 2009 10:24:12 cnu41.8-4-1-23.sbn
25      485066 Jul 19 2009 10:24:16 cnu42.8-4-1-23.sbn
26      485266 Jul 19 2009 10:24:18 cnu45.8-4-1-23.sbn
27      460275 Jul 19 2009 10:24:22 cnu70.8-4-1-23.sbn
28      485244 Jul 19 2009 10:24:26 cnu75.8-4-1-23.sbn
29         894 Jul 19 2009 10:24:26 CP7921G-1.2.1.LOADS
30     2666103 Jul 19 2009 10:24:40 cvm11sccp.8-4-1-23.sbn
31     2661176 Jul 19 2009 10:24:54 cvm31sccp.8-4-1-23.sbn
32     2660448 Jul 19 2009 10:25:08 cvm41sccp.8-4-1-23.sbn
33     2659498 Jul 19 2009 10:25:22 cvm42sccp.8-4-1-23.sbn
34     2662633 Jul 19 2009 10:25:36 cvm45sccp.8-4-1-23.sbn
35     2665016 Jul 19 2009 10:25:50 cvm70sccp.8-4-1-23.sbn
36     2661855 Jul 19 2009 10:26:04 cvm75sccp.8-4-1-23.sbn
37           0 Mar 01 2009 11:53:04 Desktops
38           0 Mar 01 2009 11:53:04 Desktops/320x212x12
39      131470 Jul 19 2009 10:26:06 Desktops/320x212x12/CampusNight.png
40       80565 Jul 19 2009 10:26:08 Desktops/320x212x12/CiscoFountain.png
41        8156 Jul 19 2009 10:26:08 Desktops/320x212x12/CiscoLogo.png
42      138278 Jul 19 2009 10:26:10 Desktops/320x212x12/Fountain.png
43         726 Jul 19 2009 10:26:10 Desktops/320x212x12/List.xml
44      109076 Jul 19 2009 10:26:12 Desktops/320x212x12/MorroRock.png
45      108087 Jul 19 2009 10:26:12 Desktops/320x212x12/NantucketFlowers.png
46       10820 Jul 19 2009 10:26:14 Desktops/320x212x12/TN-CampusNight.png
47        9657 Jul 19 2009 10:26:14 Desktops/320x212x12/TN-CiscoFountain.png
48        2089 Jul 19 2009 10:26:14 Desktops/320x212x12/TN-CiscoLogo.png
49        7953 Jul 19 2009 10:26:14 Desktops/320x212x12/TN-Fountain.png
50        7274 Jul 19 2009 10:26:16 Desktops/320x212x12/TN-MorroRock.png
51        9933 Jul 19 2009 10:26:16 Desktops/320x212x12/TN-NantucketFlowers.png
52           0 Mar 01 2009 11:53:18 Desktops/320x216x16
53         726 Jul 19 2009 10:26:16 Desktops/320x216x16/List.xml
54           0 Mar 01 2009 11:53:18 Desktops/320x212x16
55         726 Jul 19 2009 10:26:16 Desktops/320x212x16/List.xml
56      335003 Jul 19 2009 10:26:18 dsp11.8-4-1-23.sbn
57      335003 Jul 19 2009 10:26:22 dsp31.8-4-1-23.sbn
58      539441 Jul 19 2009 10:26:24 dsp41.8-4-1-23.sbn
59      335003 Jul 19 2009 10:26:26 dsp42.8-4-1-23.sbn
60      335003 Jul 19 2009 10:26:30 dsp45.8-4-1-23.sbn
61      539441 Jul 19 2009 10:26:32 dsp70.8-4-1-23.sbn
62      335003 Jul 19 2009 10:26:34 dsp75.8-4-1-23.sbn
63           0 Mar 01 2009 11:53:54 gui
64        3987 Jul 19 2009 10:26:36 gui/admin_user.html
65      650596 Jul 19 2009 10:26:40 gui/admin_user.js
66        1029 Jul 19 2009 10:26:40 gui/CiscoLogo.gif
67         618 Jul 19 2009 10:26:40 gui/CME_GUI_README.TXT
68         953 Jul 19 2009 10:26:42 gui/Delete.gif
69       16344 Jul 19 2009 10:26:42 gui/dom.js
70         864 Jul 19 2009 10:26:42 gui/downarrow.gif
71        6146 Jul 19 2009 10:26:44 gui/ephone_admin.html
72        4558 Jul 19 2009 10:26:44 gui/logohome.gif
73        3866 Jul 19 2009 10:26:44 gui/normal_user.html
74       78428 Jul 19 2009 10:26:46 gui/normal_user.js
75        1347 Jul 19 2009 10:26:46 gui/Plus.gif
76         843 Jul 19 2009 10:26:46 gui/sxiconad.gif
77         174 Jul 19 2009 10:26:48 gui/Tab.gif
78        2432 Jul 19 2009 10:26:48 gui/telephony_service.html
79         870 Jul 19 2009 10:26:48 gui/uparrow.gif
80        9968 Jul 19 2009 10:26:50 gui/xml-test.html
81        3412 Jul 19 2009 10:26:50 gui/xml.template
82     1833102 Jul 19 2009 10:27:00 GUI-1.2.1.SBN
83      485341 Jul 19 2009 10:27:04 jar11sccp.8-4-1-23.sbn
84      485636 Jul 19 2009 10:27:06 jar31sccp.8-4-1-23.sbn
85      500440 Jul 19 2009 10:27:10 jar41sccp.8-4-1-23.sbn
86      628112 Jul 19 2009 10:27:14 jar42sccp.8-4-1-23.sbn
87      754716 Jul 19 2009 10:27:20 jar45sccp.8-4-1-23.sbn
88      700829 Jul 19 2009 10:27:24 jar70sccp.8-4-1-23.sbn
89      757132 Jul 19 2009 10:27:30 jar75sccp.8-4-1-23.sbn
90      496521 Jul 19 2009 10:27:32 music-on-hold.au
91           0 Mar 01 2009 11:55:02 ringtones
92        8160 Jul 19 2009 10:27:34 ringtones/Analog1.raw
93        8160 Jul 19 2009 10:27:34 ringtones/Analog2.raw
94        5280 Jul 19 2009 10:27:34 ringtones/AreYouThere.raw
95        5040 Jul 19 2009 10:27:36 ringtones/AreYouThereF.raw
96        8160 Jul 19 2009 10:27:36 ringtones/Bass.raw
97       12240 Jul 19 2009 10:27:36 ringtones/CallBack.raw
98       16040 Jul 19 2009 10:27:36 ringtones/Chime.raw
99        8160 Jul 19 2009 10:27:38 ringtones/Classic1.raw
100      16080 Jul 19 2009 10:27:38 ringtones/Classic2.raw
101      10800 Jul 19 2009 10:27:38 ringtones/ClockShop.raw
102       2823 Jul 19 2009 10:27:40 ringtones/DistinctiveRingList.xml
103       9600 Jul 19 2009 10:27:40 ringtones/Drums1.raw
104      13440 Jul 19 2009 10:27:40 ringtones/Drums2.raw
105      15840 Jul 19 2009 10:27:40 ringtones/FilmScore.raw
106      16080 Jul 19 2009 10:27:42 ringtones/HarpSynth.raw
107       8160 Jul 19 2009 10:27:42 ringtones/Jamaica.raw
108      16080 Jul 19 2009 10:27:42 ringtones/KotoEffect.raw
109      12720 Jul 19 2009 10:27:42 ringtones/MusicBox.raw
110       8160 Jul 19 2009 10:27:44 ringtones/Piano1.raw
111      15360 Jul 19 2009 10:27:44 ringtones/Piano2.raw
112       9360 Jul 19 2009 10:27:44 ringtones/Pop.raw
113       7200 Jul 19 2009 10:27:44 ringtones/Pulse1.raw
114       4000 Jul 19 2009 10:27:46 ringtones/Ring1.raw
115       4000 Jul 19 2009 10:27:46 ringtones/Ring2.raw
116       4000 Jul 19 2009 10:27:46 ringtones/Ring3.raw
117       4000 Jul 19 2009 10:27:46 ringtones/Ring4.raw
118       4000 Jul 19 2009 10:27:48 ringtones/Ring5.raw
119       4000 Jul 19 2009 10:27:48 ringtones/Ring6.raw
120       4000 Jul 19 2009 10:27:48 ringtones/Ring7.raw
121        495 Jul 19 2009 10:27:48 ringtones/RingList.xml
122      10800 Jul 19 2009 10:27:50 ringtones/Sax1.raw
123      14160 Jul 19 2009 10:27:50 ringtones/Sax2.raw
124      16080 Jul 19 2009 10:27:50 ringtones/Vibe.raw
125        658 Jul 19 2009 10:27:50 SCCP11.8-4-2S.loads
126        639 Jul 19 2009 10:27:52 SCCP31.8-4-2S.loads
127        638 Jul 19 2009 10:27:52 SCCP41.8-4-2S.loads
128        658 Jul 19 2009 10:27:52 SCCP42.8-4-2S.loads
129        638 Jul 19 2009 10:27:52 SCCP45.8-4-2S.loads
130        638 Jul 19 2009 10:27:52 SCCP70.8-4-2S.loads
131        638 Jul 19 2009 10:27:54 SCCP75.8-4-2S.loads
132    2083047 Jul 19 2009 10:28:04 SYS-1.2.1.SBN
133        662 Jul 19 2009 10:28:06 term06.default.loads
134        662 Jul 19 2009 10:28:06 term11.default.loads
135        643 Jul 19 2009 10:28:06 term31.default.loads
136        642 Jul 19 2009 10:28:06 term41.default.loads
137        662 Jul 19 2009 10:28:08 term42.default.loads
138        642 Jul 19 2009 10:28:08 term45.default.loads
139        642 Jul 19 2009 10:28:08 term61.default.loads
140        662 Jul 19 2009 10:28:08 term62.default.loads
141        642 Jul 19 2009 10:28:08 term65.default.loads
142        642 Jul 19 2009 10:28:10 term70.default.loads
143        642 Jul 19 2009 10:28:10 term71.default.loads
144        642 Jul 19 2009 10:28:10 term75.default.loads
145     895905 Jul 19 2009 10:28:14 TNUX-1.2.1.SBN
146    2196478 Jul 19 2009 10:28:26 TNUXR-1.2.1.SBN
147    1350650 Jul 19 2009 10:28:36 WLAN-1.2.1.SBN
148        660 Mar 01 2009 13:28:06 vlan.dat
149       3987 Jul 19 2009 10:29:38 admin_user.html
150     679306 Jul 19 2009 10:29:42 admin_user.js
151       1029 Jul 19 2009 10:29:44 CiscoLogo.gif
152        617 Jul 19 2009 10:29:44 CME_GUI_README.TXT
153        953 Jul 19 2009 10:29:44 Delete.gif
154      16344 Jul 19 2009 10:29:44 dom.js
155        864 Jul 19 2009 10:29:44 downarrow.gif
156       6146 Jul 19 2009 10:29:46 ephone_admin.html
157       4558 Jul 19 2009 10:29:46 logohome.gif
158       3866 Jul 19 2009 10:29:46 normal_user.html
159      78428 Jul 19 2009 10:29:48 normal_user.js
160       1347 Jul 19 2009 10:29:48 Plus.gif
161        843 Jul 19 2009 10:29:48 sxiconad.gif
162        174 Jul 19 2009 10:29:48 Tab.gif
163       2431 Jul 19 2009 10:29:50 telephony_service.html
164        870 Jul 19 2009 10:29:50 uparrow.gif
165       9968 Jul 19 2009 10:29:50 xml-test.html
166       3412 Jul 19 2009 10:29:50 xml.template
167     130552 Jul 21 2009 01:50:52 p003-8-12-00.bin
168     130956 Jul 21 2009 01:51:18 p003-8-12-00.sbn
169        458 Jul 21 2009 01:51:42 p0s3-8-12-00.loads
170     756524 Jul 21 2009 01:53:22 p0s3-8-12-00.sb2
171     130952 Jul 21 2009 03:00:50 p00308010100.sbn
172     130548 Jul 21 2009 03:01:06 p00308010100.bin
173        461 Jul 21 2009 03:01:18 p00308010100.loads
174     708448 Jul 21 2009 03:01:32 p00308010100.sb2
175         14 Jul 23 2009 05:08:16 OS79XX.TXT

897155072 bytes available (127369216 bytes used)

And is P00308000500 the most current load supported by the 7940 and 7960?  
I did see that in the matrix, but I figured that I could load P00308010100...one of my 7960's appears to have loaded that version?  

Author

Commented:
I figured out why the phones were not getting the proper loads...when I tftp'ed the loads, I used a lower case "p" in the syntax...on the config I used an upper case "P"  phones are now getting the correct loads.  I have changed my config a bit...I will post later...I believe my inability to access my sip provider is due to a nat issue....any thoughts on that?  I'm sending 5060 UDP to my CME...I will also send RTP, STUN, and the others...I wonder if anyone has some feedback on this type of config...
Cable Modem<-->ASA <-->Switch<-->CME 2811
Phones are connected to the switch
all works better (since i corrected my load syntax) internally...no SIP provider access from CME.  I do have a standalone SIP phone that works fine (connected to the switch)

Thoughts?

thx

Author

Commented:
I was also keeping the config kinda simple...I don't have any phones other than 7940's, 7960's, and a few 7920's( I will create the CNF files and add the loads once i get the SIP stuff working)
that's why I did not add the additional tftp stuff...i accidentially cut that out when I posted my config last time...sorry about that one...I have also played around with all this info on a windows server with solar winds tftp service running...works well..that's usually how I convert the phones from skinny to sip or back the other way...
Top Expert 2008

Commented:
You may just want to try adding sip to your global inspection policy on your ASA.

policy-map global_policy
 class inspection_default
   inspect sip

Author

Commented:
bkepford - I did have that global inspect policy on my ASA -thx for the heads up

I'm now able to make outbound calls, however i can only make them from one phone?  The other phones fail....When I call support this provider says they do not support IP PBX's...so I get little support from them...typically they provide individual phones to end users, so an IP PBX is not something they sell.  So they can't help me....

Could it be a provider issue?  Or could it be that the one phone that registers with the SIP provider does not unregister to allow another phone to make a call?  Does anyone have any thoughts on this?  Im guessing this might even be something simple with the CME config?
Top Expert 2008

Commented:
Is it one phone at a time or just one phone?

Author

Commented:
it's just one phone...I expect 1 call at a time...I only have 1 sip account/number...that's whats kinda strange only 1 phone is able to make calls...?

thoughts?

Author

Commented:
it looks like it might be a provider issue...only on sip-ua can be used...so it would appear the provider needs to bundle all sip trunks into a single authentication request
attached is the sup-ua reg stat

The single phone registers with the sip provider...and it can place outbound calls...but the other 3 phones can't make outbound calls.
Is there a way to get the phone to un-reg after the call drops, to allow for another phone to make a call on the same account?  I can't believe this would not be possible????
I must be doing something wrong..perhaps the "credentials" commnad in the sip-ua section??

sipua-reg-stat.txt

Commented:
Hi there!
Top Expert 2008
Commented:
Here is a page with a solid CME SIP trunk configuration example. Let me know if it helps

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml#conf
greg wardSenior Systems Engineer
Commented:
Hi
had a quick look at my sip-ua and you are missing a few lines.
here is my working version.

sip-ua
 authentication username blah password blah
 retry invite 4
 retry response 3
 retry bye 2
 retry cancel 2
 retry register 5
 timers notify 1000
 timers register 1000
 registrar dns:sip.myphone.ge expires 3600
 sip-server dns:sip.myphone.ge
!
Regards

Greg

Author

Commented:
post were very helpful...problem was found on sip provider side

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial