ASA Allows Every thing but VPN through ASA does not work

tariqmansoor
tariqmansoor used Ask the Experts™
on
Hi Team,
I have ASA running and evey thing is workin ok and no issues, But when i initiate a VPN from any LAN PC to outside world, it does nto establish.
below is the running config. I have checked the debug messages and get the following, that makes sens eto me but how to fix this through nat ?
quick help greatly appriciated...

Debug Messages:
===============
305006   regular translation failed for protocol47 src inside:x.x.x.x dst outside:y.y.y.y
302013   built outbound connection for outside:y.y.y.y/1723 to inside:x.x.x.x/54444
609001   built local-host outside:y.y.y.y
===============================================

Running Config
===============================================================
hostname ASA

names
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address a.a.a.a 255.255.255.252
!
interface Ethernet0/1
 description Inside Network
 nameif inside
 security-level 100
 ip address 10.30.0.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.0.50 255.255.255.0
 management-only
boot system disk0:/asa803-k8.bin
ftp mode passive
clock timezone EST 10
clock summer-time EDT recurring last Sun Oct 2:00 last Sun Mar 3:00
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 61.9.134.49
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object ip
 protocol-object gre
access-list out extended permit tcp any host a.a.a.a eq 3389 log disable
access-list out extended permit icmp any any
access-list out extended permit gre any 10.30.0.0 255.255.255.0
access-list out extended permit ip any 10.30.0.0 255.255.255.0
access-list inside extended permit icmp any any
access-list inside_access_in extended permit icmp 10.30.0.0 255.255.255.0 any
access-list inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 10.30.0.0 255.255.255.0 any
pager lines 24
logging enable
logging asdm critical
mtu outside 1500
mtu inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 b.b.b.b 3389 netmask 255.255.255.255
access-group out in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 203.27.207.101 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 management
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 0.0.0.0 0.0.0.0 inside
telnet 192.168.0.0 255.255.255.0 management
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context

: end
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Hi

the translation group is showing port 1723 which is pptp traffic - you need to add pptp to your inspect list:

policy-map global_policy
 class inspection_default
  inspect pptp

Also , you are not allowing gre traffic back in to your translated addresses:

access-list out extended permit gre any 10.30.0.0 255.255.255.0
should be
access-list out extended permit gre any any



If you still have issues, try translating your inside vpn lan machine to a free public ip address from your range and then try again - you may problems connecting to a VPN device is nat translation is not enabled on the far side.

You will need PPTP inspect on though for starters.

hth

Author

Commented:
Thanks for elaborative response,
while i was waiting i searched and added below command that fixed the issue, Just wondering how that is different to what you have suggested as that also appeared correct sol

ASA (config)# fixup prottocol pptp 1723

Wondering how this would be different from below that you suggested ?
policy-map global_policy
 class inspection_default
  inspect pptp

Thanks,


Commented:
Hey

fixup is the older PIX command for protocol handling - this is being deprecated in favour of the policy protocol inspection on the ASA models.  To be honest with you, i didn't even realise that fixup worked on ASA - I have always used fixup on PIX and inspects on ASA - I thought they had ditched the command!

:-)

Author

Commented:
Great Help

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial