cisco 2611 and catalyst 2950 set up dhcp server between them

awilderbeast
awilderbeast used Ask the Experts™
on
hi all

i have the two devices mentioned above and im trying to get the 2611 to act as a dhcp server to the 2950 switch

i have put the port my pc is connected to in access mode and have assigned it to vlan 10 (my management vlan)
even though ti doesnt matter what vlan its in does it?

below is my configs for each
everything else is already set up, i have a trunk between the router and the switch the fa interface on the router is 192.168.5.1
all is up apart from this part
as far as i can tell is should work no?
but the pc plugged into fa0/3 still isnt picking up an address

any ideas?
thanks
########### 2611 #############
ip dhcp pool CoreSwitch
network 192.168.5.0 255.255.255.0
default-router 192.168.5.1
dns-server 4.2.2.2
domain-name Alex-Lab.com
 
########### 2950 #############
ip dhcp-server 192.168.5.1

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
Hi,
you must plug same vlan PC and router, and it will work

Author

Commented:
i dont understand what you mean?
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
did you typed the config: service dhcp?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
at the switch:

int range fast 0/1 - 24
 switchmode mode access
 switchport access vlan 10
int vlan 10
 no shut
 ip address 192.168.5.254 255.255.255.0

Author

Commented:
on the router yes

Author

Commented:
i have already done the above commands, the vlan 10s ip is 192.168.5.2 the router is 192.168.5.1

all ports are in vlan 10

cheers
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
can you show me all of the configs id the config isn't working?
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
and show cdp nei?

Author

Commented:
yup
see below

CDP Neigh on 2611
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
CoreSwitch       Eth 0/0            136         T S       WS-C2924-XFas 0/2
##########################2611###############################
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.5.1 255.255.255.0
!
ip dhcp pool CoreSwitch
   network 192.168.5.0 255.255.255.0
   default-router 192.168.5.1 
   dns-server 213.249.130.100 
   domain-name Alex-Lab.com
!
!
no ip ips deny-action ips-interface
no ip domain lookup
ip domain name alexslab.com
ip ssh version 2
!
 --More-- 
*Aug 19 01:56:28.074: DHCPD: checking for expired leases.
!         
!
!
username admin password 7 02050B5518121D344F5A00160B4747
username CoreRouter password 7 094E411C170612
!
! 
!
!
!
interface Ethernet0/0
 no ip address
 full-duplex
!
interface Ethernet0/0.1
 encapsulation dot1Q 1 native
 no snmp trap link-status
!
interface Ethernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.5.1 255.255.255.0
 no snmp trap link-status
!
interface Ethernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 no snmp trap link-status
!
interface Ethernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
 no snmp trap link-status
##########################2650###############################
Building configuration...
 
!
hostname CoreSwitch
 
!         
spanning-tree vlan 1 priority 4096
ip subnet-zero
no ip domain-lookup
ip dhcp-server 192.168.5.1
!
!
!
interface FastEthernet0/1
 duplex full
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 duplex full
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
 switchport access vlan 10
 spanning-tree portfast
!
interface VLAN1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN10
 ip address 192.168.5.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 192.168.5.1
 
 
 

Open in new window

Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
can you debug on the router??
sh ip sockets
debug ip dhcp server packet
debug ip dhcp server event

Author

Commented:
here it is
RouterA#
*Aug 19 02:06:28.078: DHCPD: checking for expired leases.
RouterA#sh ip sockets
Proto    Remote      Port      Local       Port  In Out Stat TTY OutputIF
 17   --listen--          192.168.5.1      2887   0   0   11   0 
 17 255.255.255.255    68 192.168.5.1        67   0   0 2211   0 
 88   --listen--          192.168.5.1       100   0   0    0   0 
 17   --listen--          192.168.10.2      520   0   0    1   0 
RouterA#
*Aug 19 02:07:17.190: DHCPD: Sending notification of DISCOVER:
*Aug 19 02:07:17.190:   DHCPD: htype 1 chaddr 0008.7416.055d
*Aug 19 02:07:17.194:   DHCPD: remote id 020a0000c0a805010000000a0000
*Aug 19 02:07:17.194:   DHCPD: circuit id 00000000
*Aug 19 02:07:17.194: DHCPD: DHCPDISCOVER received from client 0100.0874.1605.5d on interface Ethernet0/0.10.
*Aug 19 02:07:17.194: DHCPD: Seeing if there is an internally specified pool class:
*Aug 19 02:07:17.194:   DHCPD: htype 1 chaddr 0008.7416.055d
*Aug 19 02:07:17.194:   DHCPD: remote id 020a0000c0a805010000000a0000
*Aug 19 02:07:17.198:   DHCPD: circuit id 00000000
RouterA#
*Aug 19 02:07:17.198: DHCPD: Allocate an address without class information (192.168.5.0)
*Aug 19 02:07:17.198: DHCPD: subnet [192.168.5.1,192.168.5.254] in address pool CoreSwitch is empty.
RouterA#
*Aug 19 02:07:25.191: DHCPD: Sending notification of DISCOVER:
*Aug 19 02:07:25.191:   DHCPD: htype 1 chaddr 0008.7416.055d
*Aug 19 02:07:25.191:   DHCPD: remote id 020a0000c0a805010000000a0000
*Aug 19 02:07:25.191:   DHCPD: circuit id 00000000
*Aug 19 02:07:25.191: DHCPD: DHCPDISCOVER received from client 0100.0874.1605.5d on interface Ethernet0/0.10.
*Aug 19 02:07:25.195: DHCPD: Seeing if there is an internally specified pool class:
*Aug 19 02:07:25.195:   DHCPD: htype 1 chaddr 0008.7416.055d
*Aug 19 02:07:25.195:   DHCPD: remote id 020a0000c0a805010000000a0000
*Aug 19 02:07:25.195:   DHCPD: circuit id 00000000
RouterA#
*Aug 19 02:07:25.195: DHCPD: Allocate an address without class information (192.168.5.0)
*Aug 19 02:07:25.199: DHCPD: subnet [192.168.5.1,192.168.5.254] in address pool CoreSwitch is empty.
RouterA#
*Aug 19 02:07:42.191: DHCPD: Sending notification of DISCOVER:
*Aug 19 02:07:42.191:   DHCPD: htype 1 chaddr 0008.7416.055d
*Aug 19 02:07:42.191:   DHCPD: remote id 020a0000c0a805010000000a0000
*Aug 19 02:07:42.191:   DHCPD: circuit id 00000000
*Aug 19 02:07:42.191: DHCPD: DHCPDISCOVER received from client 0100.0874.1605.5d on interface Ethernet0/0.10.
*Aug 19 02:07:42.195: DHCPD: Seeing if there is an internally specified pool class:
*Aug 19 02:07:42.195:   DHCPD: htype 1 chaddr 0008.7416.055d
*Aug 19 02:07:42.195:   DHCPD: remote id 020a0000c0a805010000000a0000
*Aug 19 02:07:42.195:   DHCPD: circuit id 00000000
RouterA#
*Aug 19 02:07:42.195: DHCPD: Allocate an address without class information (192.168.5.0)
*Aug 19 02:07:42.195: DHCPD: subnet [192.168.5.1,192.168.5.254] in address pool CoreSwitch is empty.
RouterA#
*Aug 19 02:08:28.078: DHCPD: checking for expired leases.
RouterA#
*Aug 19 02:10:28.079: DHCPD: checking for expired leases.
RouterA#

Open in new window

Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
Hi,

The switch is working corretly, but the router not sends DHCP offer!

You reloaded the router?

Author

Commented:
rebooted the router, nothing still :|
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
did you configured ip dhcp excluded address?

Author

Commented:
yup you can see above, i excluded 192.168.5.1
Instructor
Top Expert 2015
Commented:
ip dhcp excluded-address 192.168.5.1 255.255.255.0

You are excluding all addresses in the pool.

Remove the above line and replace it with:

ip dhcp excluded-address 192.168.5.1 192.168.5.7

Author

Commented:
that was it :)
i thought i had to put the netmask in, i didnt know you just put the hosts you want to exclude in! :|

thanks alot :)
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:

If you showed your config earlier I wolud be helpfull, but I didnt understand why Am I dont catch points????

Author

Commented:
ooops sorry! i didnt know that the other guy posted i thought i was only talking to you and i tought i gave the points to you
i would of split them if id checked who was posting :|

sorry

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial