Server based autorespond message stalls at Message submitted to categorizer

rltomalin
rltomalin used Ask the Experts™
on
Microsoft SBS 2003 - with exchange 2003.  I have set up a rule for a user that has "have server reply using.." message.
I have tested this out but the message tracking shows the reply getting stopped at the "Message submitted to categorizer" step.
I have tested by manually sending the exact same message (subject and body) to the same user.  This works fine.  I do have IMF running but I don't understand how that could affect this as I thought it only traps incoming messages.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Expert of the Quarter 2009
Expert of the Year 2009
Commented:
Categoriser is where AV and Antispam does its thing.
However if you are sending the message to an external recipient then automatic replies are not enabled by default in Exchange. You have to enable them.

They are also dangerous things to have enabled as they can (and will eventually) cause an email loop.

Simon.
SurajSenior System Engineer

Commented:
If message is stuck in CAT there can be many reasons... Yes 3rd party application can be one of the cause.. and they work between the POST AND PRE Categorizer operation...

what 3rd party app do you have?
do one thing... try to disable them  and see if it works...
also increase the diagnostic logging and see wht errors does it give on categorizer?
HOW ?
here it is .. open registry.. HKLM\SYSTEM\CCS\SERVICES\MSEXCHANGE TRANSPORT\DIAGNOSTIC
on the right side ... put all of those keys to 7 decimal

restart the smtp and routing engine service...
check the envent viewer and see what errors and warnings do you get and paste it here..

-sam

Author

Commented:
Thanks Methsa
It was the autoresponses flag not set.  I will try that but keep in mind the possibility of looping.  I guess one key to this is to specify criteria for the response, rather than to every message.  That would work fine for my requirement.

I figured out where to set the flag, but it is a bit difficult to find (I think).  For those coming after - here is the method:
Log onto server as an administrator
Server Management
Advanced Management
First Organisation (Exchange)
Global Settings
Double click Internet Message Formats
Properties of Default
Advanced tab
Tick Allow automatic responses

Thank you - best regards
Richard Tomalin

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial