SMTP drops with large email size - Cisco 1841

espirit2
espirit2 used Ask the Experts™
on
We have an ADSL modem connected to Cisco 1841 router. Previously we used a Belkin router instead of the 1841 and had no problem.

The 1841 is setup simply,
FE0/0 WAN getting IP via DHCP from ADSL modem
FE0/1 LAN running DHCP server to rest of network.

All works as expected, except when sending a larger email to our external mail server

With a small email there is no problem, the email goes through via encrypted, authenticated, IMAP. When sending a larger email the connection hangs after sending some perentage of the email and then never completes.

If I send any email directly via the ADSL modem (not through the 1841, everything works OK)

Here is my 1841 running config. I am new to the Cisco 1841 router

How do I fix this please?

Building configuration...
 
Current configuration : 3544 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FBRouter1
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 <removed>
enable password <removed>
!
no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1 192.168.2.99
ip dhcp excluded-address 192.168.2.201 192.168.2.254
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.2.0 255.255.255.0
   update dns
   default-router 192.168.2.254
!
!
!
!
crypto pki trustpoint TP-self-signed-3528004658
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3528004658
 revocation-check none
 rsakeypair TP-self-signed-3528004658
!
!
crypto pki certificate chain TP-self-signed-3528004658
 certificate self-signed 01
  <removed>
  quit
username admin privilege 15 password 0 <removed>
!
!
!
crypto ipsec df-bit set
!
!
!
interface FastEthernet0/0
 description $ETH-WAN$$FW_OUTSIDE$
 ip address dhcp client-id FastEthernet0/0
 ip verify unicast reverse-path
 ip nat outside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 description $FW_INSIDE$$ETH-WAN$
 ip address 192.168.2.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
!
interface FastEthernet0/0/0
 shutdown
!
interface FastEthernet0/0/1
 shutdown
!
interface FastEthernet0/0/2
 shutdown
!
interface FastEthernet0/0/3
 shutdown
!
interface ATM0/1/0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface Vlan1
 no ip address
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 remark INSIDE_IF=FastEthernet0/1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.2.0 0.0.0.255
no cdp run
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 password <removed>
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
end

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
We have now resolved this issue.

The cable on the fe0/1 had a partial short on two wires. Not enough to stop it from working, but enough to generate a huge number of packet problems, hence connection problems over sustained connections (like sending large emails).

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial